Announcement

Collapse
No announcement yet.

cisco 881 - am i doing anything wrong ?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • cisco 881 - am i doing anything wrong ?

    Just want to validate myself.
    The client has just upgraded a 10M service to a 70M service.
    However - no matter what we do, we can't seem to exceed more than about 250KB/sec download speed in a single IE session (plus, the director keeps telling me it's "slow")

    If I run multiple IE download sessions, I can get 8-10 sessions going with 200+KB/sec for each instance, but cannot seem to find a single source I could download from to demonstrate the speed will max out.
    speedtest.net and a speedtest specific to the IP generally don't show more than 10M/sec download either.

    I'm wondering if, somehow, there's something wrong in my admittedly very plain and boring config below. If any QoS or something would help out?


    Cisco IOS Software, C880 Software (C880DATA-UNIVERSALK9-M), Version 15.0(1)M7, RELEASE SOFTWARE (fc2)

    Current configuration : 4729 bytes
    !
    ! Last configuration change at 03:51:43 UTC Fri Jun 7 2013 by admin
    !
    version 15.0
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname WME-RTR-001
    !
    boot-start-marker
    boot-end-marker
    !
    logging buffered 12800 notifications
    !
    no aaa new-model
    memory-size iomem 10
    !
    crypto pki trustpoint TP-self-signed-3010904806
    enrollment selfsigned
    subject-name cn=IOS-Self-Signed-Certificate-3010904806
    revocation-check none
    rsakeypair TP-self-signed-3010904806
    !
    !
    crypto pki certificate chain TP-self-signed-3010904806
    certificate self-signed 01
    (BLA)
    quit
    ip source-route
    !
    !
    !
    !
    ip cef
    ip name-server 8.8.8.8
    no ipv6 cef
    !
    !
    license udi pid CISCO881-K9 sn FGL154125R1
    !
    !
    username admin privilege 15 secret 5 ASECRETPASSWORDHERE
    interface FastEthernet0
    !
    interface FastEthernet1
    shutdown
    !
    interface FastEthernet2
    shutdown
    !
    interface FastEthernet3
    shutdown
    !
    interface FastEthernet4
    description $ETH-WAN$
    ip address 115.70.206.201 255.255.255.254
    ip nat outside
    ip virtual-reassembly
    duplex full
    speed 100
    no cdp enable
    !
    interface Vlan1
    ip address 192.168.10.254 255.255.255.0
    ip nbar protocol-discovery
    ip flow ingress
    ip flow egress
    ip nat inside
    ip virtual-reassembly
    !
    ip forward-protocol nd
    ip http server
    ip http authentication local
    no ip http secure-server
    ip flow-top-talkers
    top 20
    sort-by bytes
    !
    ip nat pool MyPool 115.x.y.a 115.X.Y.f netmask 255.255.255.248
    ip nat inside source list 2 pool MyPool overload
    ip nat inside source static tcp 192.168.X.1 3389 115.Z.Q.Y 3389 extendable
    (more nat BLA along the same lines)
    ip route 0.0.0.0 0.0.0.0 115.1.1.1
    !
    logging trap notifications
    logging 192.168.x.1
    access-list 2 permit 192.168.X.0 0.0.0.255
    !
    !
    control-plane
    !
    !
    line con 0
    no modem enable
    line aux 0
    privilege level 15
    login local
    transport input ssh
    !
    scheduler max-task-time 5000
    end
    Yep - that's really it. I know that's very poor firewall control - but one step at a time.

    There's only data going over this network, no voice. The internal fabric is a bunch of SF300s, (Fast Ethernet, 100Mb/sec) switches, with a single flat vlan, connected with Gigabit uplinks between the switches and the router.

    there's about 70 seats within the network at the moment.

    anything else that might help paint a picture, let me know
    Please do show your appreciation to those who assist you by leaving Rep Point https://www.petri.com/forums/core/im.../icon_beer.gif

  • #2
    Re: cisco 881 - am i doing anything wrong ?

    I think the max throughput on an 881 is 25Mbps unidirectional without ipsec etc. I did notice you had cef enabled which is good. I see that your wan interface is hard coded for speed/duplex. Is the isp device hard coded as well? If its set to auto it may force that port to half duplex. I usually use auto negotiation unless the ISP states to hard code my side.


    Post the result of or take a look at the result of:

    show interface fastethernet4


    Look for the duplex on the interface and any input,fcs, crc, output errors. Those are usually indications of a duplex mismatch.
    Last edited by auglan; 14th June 2013, 12:24.
    CCNA, CCNA-Security, CCNP
    CCIE Security (In Progress)

    Comment


    • #3
      Re: cisco 881 - am i doing anything wrong ?

      One thing caught my eye, the command 'memory-size iomem 10'. doing a very quick search, I found a site (packetlife.net) with the following statement: "If you encounter a router which seems to have a disproportionately large or small IO memory allocation, the memory-size iomem command can be used to modify it as a percentage between 5 and 50 percent (in increments of 5%) of the total DRAM installed."

      If that applies here, could that command be limiting the amount of IO memory to just 10% of what's installed, which would have the effect of throttling the bandwidth? Maybe the '10' figure is coincidental, but it just a bit suspicioius, anyway.

      The command "default memory-size iomem" puts the device back to factory memory allocation. Worth a try? The original setting can always be re-entered if the unthinkable happens.
      *RicklesP*
      MSCA (2003/XP), Security+, CCNA

      ** Remember: credit where credit is due, and reputation points as appropriate **

      Comment


      • #4
        Re: cisco 881 - am i doing anything wrong ?

        definitely hard coded speed and duplex, confirmed by the ISP prior.

        25M/sec unicast means basically, one given computer cannot exceed more htan 25M/sec, but overall - 4 computers could generate 10M/sec inbound each, correct? (or, are we just exceeding the fabric of this device.. i checked some errata and it looks targetted for only 25 users...)

        that would all explain a lot. luckily, i never purchased nor advised on this...if it has to be updated to a 2920 it does. He'll just have to pay for it.

        thank you.. i'll keep an eye on it.

        i suspect it's just "user experience" anyway - the internet isn't actually slow.
        guy wants "no downtime" on anything, ever. but isn't prepared to pay the sorts of costs he'd need to pay for an environmnet, ever.

        rock| me | hardplace
        Please do show your appreciation to those who assist you by leaving Rep Point https://www.petri.com/forums/core/im.../icon_beer.gif

        Comment


        • #5
          Re: cisco 881 - am i doing anything wrong ?

          25Mbs max throughput one way. So technically you should get 50Mbps "total" throughput for the Gen1 880's. I assume the new Gen2 ISR's would have a higher maximum throughput.
          CCNA, CCNA-Security, CCNP
          CCIE Security (In Progress)

          Comment


          • #6
            Re: cisco 881 - am i doing anything wrong ?

            hmm. ok then. that actually explains quite a bit...
            Please do show your appreciation to those who assist you by leaving Rep Point https://www.petri.com/forums/core/im.../icon_beer.gif

            Comment

            Working...
            X