Announcement

Collapse
No announcement yet.

NAT & Unicast to Multicast Conversion

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • NAT & Unicast to Multicast Conversion

    Dear all,
    I am trying to simulate two below scenarios, and finding some difficulties in implementation, and really need your support, please have a look if you can point out something.

    Scenario One:-

    I am planning to get the unicast streams from different 2-3 sources over internet, and I am doing NAT for port-forwarding all those unicast streams to a one private IP. Attached is the setup for your understanding.

    Setup: - Both unicast streams will be hitting to One Public IP (3.3.3.2) on UDP/TCP Port 1234, 1236 & 1238 only & the same ports need to be forwarded to natted One Private IP (10.10.10.4)

    My motive is to,
    1) NATTING these 2 unicast streams into one private IP(10.10.10.4) by checking Source & Destination based IPís and ports, but in below configuration I cannot achieve on checking Source & Destination based IPís and ports
    Router configuration:-

    interface GigabitEthernet0/0
    description ***Connected to Internet ***
    ip address 3.3.3.2 255.255.255.252
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip nat outside
    ip virtual-reassembly in
    load-interval 30
    duplex auto
    speed auto
    !
    interface GigabitEthernet0/1
    description ***Connected to Cisco 2900 Switch***
    ip address 10.10.10.1 255.255.255.0
    ip nat inside
    ip virtual-reassembly in
    load-interval 30
    duplex auto
    speed auto
    !
    ip nat inside source static tcp 10.10.10.2 1234 3.3.3.2 1234 extendable
    ip nat inside source static udp 10.10.10.2 1234 3.3.3.2 1234 extendable
    ip nat inside source static tcp 10.10.10.2 1236 3.3.3.2 1236 extendable
    ip nat inside source static udp 10.10.10.2 1236 3.3.3.2 1236 extendable
    ip nat inside source static tcp 10.10.10.2 1238 3.3.3.2 1238 extendable
    ip nat inside source static udp 10.10.10.2 1238 3.3.3.2 1238 extendable


    Scenario Two:-

    I am planning to get the unicast streams from different 2-3 sources over internet, and I am doing NAT for converting these unicast streams into multicast streams. Attached is the setup for your understanding.

    Setup: - Both unicast streams will be hitting to One Public IP (3.3.3.2) on UDP/TCP Port 1234, 1236 & 1238 only & the same these 3 ports need to be forwarded on Natted these 2 multicast IPs 239.200.1.1 & 239.200.1.2

    My motive is to,
    1) Convert these 2 unicast streams by NATTING into 2 multicast unique streams using Source based IPís and ports, but in below configuration I cannot achieve checking Source based IPís and ports for converting to have 2 multicast IPs with same ports and cannot receive/join these multicast
    Router configuration:-

    ip multicast-routing
    !
    interface GigabitEthernet0/0
    description ***Connected to Internet ***
    ip address 3.3.3.2 255.255.255.252
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip nat outside
    ip pim sparse-mode
    ip virtual-reassembly in
    load-interval 30
    duplex auto
    speed auto
    !
    interface GigabitEthernet0/1
    description ***Connected to Cisco 2900 Switch***
    ip address 10.10.10.1 255.255.255.0
    ip nat inside
    ip pim sparse-mode
    ip virtual-reassembly in
    load-interval 30
    duplex auto
    speed auto
    !
    interface Loopback0
    description ***RP for Multicast***
    ip address 10.10.40.1 255.255.255.255
    ip pim sparse-mode
    !
    ip pim rp-address 10.10.40.1
    !
    ip nat inside source static udp 239.200.1.1 1234 3.3.3.2 1234 extendable
    ip nat inside source static udp 239.200.1.1 1236 3.3.3.2 1236 extendable
    ip nat inside source static udp 239.200.1.1 1238 3.3.3.2 1238 extendable
    ip nat inside source static udp 239.200.1.2 1234 3.3.3.2 1234 extendable
    ip nat inside source static udp 239.200.1.2 1236 3.3.3.2 1236 extendable
    ip nat inside source static udp 239.200.1.2 1238 3.3.3.2 1238 extendable
    Attached Files

  • #2
    Re: NAT & Unicast to Multicast Conversion

    Your understanding of multicast isn't correct. You specify the group address in your nat statements but the Class D address range is used only for the group address or destination address of IP multicast traffic. The source address for multicast datagrams is always the unicast source address. The source will never be the multicast group address but always the unicast source. Clients join the multicast group to receive multicast streams from the unicast source.

    Example:

    A unicast source is configured to send a stream to 239.0.0.12 which is only a group address. Hosts that want that multicast traffic then join said group (IGMP) which in turn creates the multicast tree.

    What you need to do is take those unicast streams from the internet nat them to an internal address and have that address be the source for the group.
    CCNA, CCNA-Security, CCNP
    CCIE Security (In Progress)

    Comment


    • #3
      Re: NAT & Unicast to Multicast Conversion

      hi auglan,

      so you mean for "Unicast to multicast" configuration I use NAT, so in the below command lines I need to modify something ? Can you suggest what it should be the configurations ?

      ip nat inside source static udp 239.200.1.1 1234 3.3.3.2 1234 extendable
      ip nat inside source static udp 239.200.1.1 1236 3.3.3.2 1236 extendable
      ip nat inside source static udp 239.200.1.1 1238 3.3.3.2 1238 extendable
      ip nat inside source static udp 239.200.1.2 1234 3.3.3.2 1234 extendable
      ip nat inside source static udp 239.200.1.2 1236 3.3.3.2 1236 extendable
      ip nat inside source static udp 239.200.1.2 1238 3.3.3.2 1238 extendable

      Comment


      • #4
        Re: NAT & Unicast to Multicast Conversion

        You cant use the multicast group as the source in your nat as a multicast group address is never the source. The unicast source for that group is the source. I suggest reading on how multicast works.


        http://www.cisco.com/en/US/products/...807631d2.shtml
        Last edited by auglan; 10th February 2013, 14:30.
        CCNA, CCNA-Security, CCNP
        CCIE Security (In Progress)

        Comment

        Working...
        X