Announcement

Collapse
No announcement yet.

Access Point(s) - AIR-AP1231G-A-K9 and others - Spotty Connectivity ...

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Access Point(s) - AIR-AP1231G-A-K9 and others - Spotty Connectivity ...

    Hello,

    We have eighteen Cisco Aironet wireless access points (most of them are AIR-AP1231G-A-K9 with 12.3(2)JA2 IOS loaded) across our campus which people have weird issues with connecting.

    Everywhere, people can associate and get an IP address without any issues. However, they cannot maintain a reliable connection to systems either on our network or off. They will get a web page to load and then it drops them out. In addition, they cannot connect back again for random intervals of time. To make this even more bizarre is that for random intervals they maintain a solid connection until it kicks people out again.

    The vlan itself (60 in the configuration file below) works without issue as we have devices plugged in directly to the vlan via a hardwired port and they are stable.

    Below is the configuration file. Any reason why we would have this issue?

    Thank you for your time.

    Regards,
    Christopher Koeber

    Code:
    !
    version 12.3
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    !
    hostname AP-6
    !
    enable secret {authentication information}
    enable password {authentication information}
    !
    username Cisco password {authentication information}
    username admin password {authentication information}
    ip subnet-zero
    ip domain name {Domain Information}
    !
    no aaa new-model
    !
    dot11 ssid (Secure) Staff/Faculty
       vlan 70
       authentication open 
    !
    dot11 ssid Public
       vlan 60
       authentication open 
       guest-mode
    !
    !
    !
    bridge irb
    !
    !
    interface Dot11Radio0
     no ip address
     no ip route-cache
     !
     ssid (Secure) Staff/Faculty
     !
     ssid Public
     !
     short-slot-time
     speed basic-1.0 2.0 5.5 6.0 9.0 11.0 12.0 18.0 24.0 36.0 48.0 54.0
     station-role root
     no cdp enable
    !
    interface Dot11Radio0.60
     encapsulation dot1Q 60 native
     no ip route-cache
     no cdp enable
     bridge-group 60
     bridge-group 60 subscriber-loop-control
     bridge-group 60 block-unknown-source
     no bridge-group 60 source-learning
     no bridge-group 60 unicast-flooding
     bridge-group 60 spanning-disabled
    !
    interface Dot11Radio0.70
     encapsulation dot1Q 70
     no ip route-cache
     no cdp enable
     bridge-group 70
     bridge-group 70 subscriber-loop-control
     bridge-group 70 block-unknown-source
     no bridge-group 70 source-learning
     no bridge-group 70 unicast-flooding
     bridge-group 70 spanning-disabled
    !
    interface FastEthernet0
     no ip address
     no ip route-cache
     duplex auto
     speed auto
    !
    interface FastEthernet0.60
     encapsulation dot1Q 60 native
     ip address 10.60.255.6 255.255.0.0
     no ip route-cache
     bridge-group 60
     no bridge-group 60 source-learning
     no bridge-group 60 unicast-flooding
     bridge-group 60 spanning-disabled
    !
    interface FastEthernet0.70
     encapsulation dot1Q 70
     ip address dhcp
     no ip route-cache
     bridge-group 70
     no bridge-group 70 source-learning
     no bridge-group 70 unicast-flooding
     bridge-group 70 spanning-disabled
    !
    interface BVI1
     ip address 10.60.255.6 255.255.0.0
     no ip route-cache
    !
    ip default-gateway 10.60.0.1
    ip http server
    no ip http secure-server
    ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
    ip radius source-interface BVI1 
    logging snmp-trap emergencies
    logging snmp-trap alerts
    logging snmp-trap critical
    logging snmp-trap errors
    logging snmp-trap warnings
    !
    !
    !
    line con 0
     transport preferred all
     transport output all
    line vty 0 4
     login local
     transport preferred all
     transport input all
     transport output all
    line vty 5 15
     login
     transport preferred all
     transport input all
     transport output all
    !
    end

  • #2
    Re: Access Point(s) - AIR-AP1231G-A-K9 and others - Spotty Connectivity ...

    Could be alot of things. Interference from other devices and/or obstruction of signal. Do you have older wireless devices connectioning? Such as b devices? If a b device associates to an ap then the speed for all clients will get knocked down to "B" unless you have dual radios. Also what channels are you using? Do you have AP's with overlapping channels? Do you have other devices running wifi networks? I know mac's will let you setup your lan connection as a wifi hotspot. We had issues with this where I work due to channel interference from these wifi networks. May be worth while to get a wireless expert in there to check things out. Also you version of code on the AP's is very old (12.3). How many client's are associating to a single AP? Cisco recommends 15 to 20 at the max. Are you rate-limiting your wireless at all? Do you have any of your AP's acting as repeaters? Repeaters will cut your wifi bandwidth in half.
    CCNA, CCNA-Security, CCNP
    CCIE Security (In Progress)

    Comment


    • #3
      Re: Access Point(s) - AIR-AP1231G-A-K9 and others - Spotty Connectivity ...

      Originally posted by auglan View Post
      Could be alot of things. Interference from other devices and/or obstruction of signal. Do you have older wireless devices connectioning? Such as b devices? If a b device associates to an ap then the speed for all clients will get knocked down to "B" unless you have dual radios. Also what channels are you using? Do you have AP's with overlapping channels? Do you have other devices running wifi networks? I know mac's will let you setup your lan connection as a wifi hotspot. We had issues with this where I work due to channel interference from these wifi networks. May be worth while to get a wireless expert in there to check things out. Also you version of code on the AP's is very old (12.3). How many client's are associating to a single AP? Cisco recommends 15 to 20 at the max. Are you rate-limiting your wireless at all? Do you have any of your AP's acting as repeaters? Repeaters will cut your wifi bandwidth in half.

      Thank you very much for the detailed reply; at the moment I cannot answer all of the questions you posted but I can answer some.

      Most likely we do have older devices connecting, as all of the devices connect to a Public network that people on campus (we are a school) connect to.

      On the overlapping channels, my guess is we do, but is that recommended? Or should we just use one universal channel?

      On other devices running Wi-Fi networks, we have no official ones but since it is a campus we may have individuals trying to jerry-rig things, which we know causes problems. In our case the problem is more or less campus-wide so I am not sure if that is the main issue.

      I'll have answers to the other questions later today.

      Comment


      • #4
        Re: Access Point(s) - AIR-AP1231G-A-K9 and others - Spotty Connectivity ...

        Channels 1,6,11 are used on the 2.4ghz spectrum. Those channels do not overlap with each other on that spectrum. You want a little bit of overlap between ap's as that should give you seamless roaming when a client moves to a different ap. What you dont want is say 2 ap's on channel 1 right next to each other or 2 aps one one channel 1 and the other on 6 right next to each other bleeding into each other. You want the ap's next to each other on different channels but not so close to each other that they overlap each other. Granted this is going to be tough with autonomous AP's with no site survey.

        I would defiantly set your ap's to only accept connections from G and above clients. There is no reason in the world that someone is still using a "b" radio.

        Since this is campus wide then it may be worthwhile to hire a consultant to actually do a wireless site survey. Yes they are expensive but if its a signal, interference issue there this is the best way to figure out what is going on.

        I know you said you lan connections are fine but I would also look at the utilization on your links. Are they congested? Are you droppling packets from wireless clients?

        Also are the wireless clients getting disassociated with the AP's? or are they just loosing internet/intranet access? If they are still associated to the AP's and just loosing intranet/internet access then I would look at your data links from the AP's to the switch. Look at any trunk links to other switches and also look at bandwidth utilization on all your links.
        Last edited by auglan; 16th November 2012, 17:18.
        CCNA, CCNA-Security, CCNP
        CCIE Security (In Progress)

        Comment

        Working...
        X