No announcement yet.

DHCP issues on Cisco 870

  • Filter
  • Time
  • Show
Clear All
new posts

  • DHCP issues on Cisco 870

    Hi Guys,

    I'm trying to figure out a strange problem I have.
    My Cisco 870 (SMB router) is configured to get an IP address using DHCP on its Fast Ethernet 4 port.
    It is connected to a cable modem which I know is working fine since a direct connection to my PC has no troubles at all.
    I've tried to connect the WAN port (fa4) to other DHCP devices that I have (such as a DSL modem) and the results were the same (still can't get an IP address).
    When I assign a static IP address to the interface the connection is ok (I'm able to get to the DSL modem management using telnet), however in order to connect it to a cable modem I must get the address dynamically (I'm connecting using l2tp).
    I had this issue before and I was able to solve it after upgrading the IOS version.
    I had an IP and was able to connect.
    Now it's stopped all of a sudden and I'm back to square one

    This is how the interface is configured:
    interface FastEthernet4
     description WAN interface to ISP
     ip address dhcp
     ip broadcast-address
     ip virtual-reassembly
     load-interval 30
     duplex auto
     speed auto
     no cdp enable
    And this is what I've tried so far:
    - Removed all ACLs.
    - Changed several IOS versions (currently its c870-advipservicesk9-mz.124-15.T1).
    - Added client-id, changed dhcp sent hostname and other args.
    Still nothing helps.

    This is what I get after running the "debug dhcp detail" command:

    *Oct  7 11:10:51.827: DHCP: SDiscover attempt # 3 for entry:
    *Oct  7 11:10:51.827: Temp IP addr:  for peer on Interface: FastEthernet4
    *Oct  7 11:10:51.827: Temp  sub net mask:
    *Oct  7 11:10:51.827:    DHCP Lease server:, state: 3 Selecting
    *Oct  7 11:10:51.827:    DHCP transaction id: 11E7
    *Oct  7 11:10:51.827:    Lease: 0 secs,  Renewal: 0 secs,  Rebind: 0 secs
    *Oct  7 11:10:51.827:    Next timer fires after: 00:00:04
    *Oct  7 11:10:51.827:    Retry count: 3   Client-ID: cisco-0014.f2e3.12d9-Fa4
    *Oct  7 11:10:51.827:    Client-ID hex dump: 632953621F2D302031432E363245332E
    *Oct  7 11:10:51.827:                        333361352D444136
    *Oct  7 11:10:51.827:    Hostname: R1
    *Oct  7 11:10:51.827: DHCP: SDiscover: sending 294 byte length DHCP packet
    *Oct  7 11:10:51.827: DHCP: SDiscover 294 bytes
    *Oct  7 11:10:51.827:             B'cast on FastEthernet4 interface from
    *Oct  7 11:10:55.827: DHCP: QScan: Timed out Selecting state%Unknown DHCP problem.. No allocation possible
    *Oct  7 11:11:05.103: DHCP: Waiting for 30 seconds on interface FastEthernet4
    I'm getting a broadcast from fa4 but for some reason the router is not accepting the DHCP offer.
    Is there someone who saw this happening before and might be able to help


  • #2
    Re: DHCP issues on Cisco 870

    From the look of the debug your router is sending the discover but not getting an offer and then timing out.

    Remove this:

    ip broadcast-address

    This is an old command.
    CCNA, CCNA-Security, CCNP
    CCIE Security (In Progress)


    • #3
      Re: DHCP issues on Cisco 870

      Thanks for your prompt reply :]

      Sorry, I forgot to mention that for some reason I can't get this line removed (using the command no ip broadcast-address
      When I try to change into something else, for example
      it returns as a few moments later...also after the removal it disappears for a while and then comes back.
      Any idea how can I remove/change this?

      Thanks again.


      • #4
        Re: DHCP issues on Cisco 870

        May want to see about an updated IOS. The one you are using is kinda old. Could be a buggy version of code as well.
        CCNA, CCNA-Security, CCNP
        CCIE Security (In Progress)


        • #5
          Re: DHCP issues on Cisco 870

          I've replaced it with c870-advipservicesk9-mz.124-15.T9 however the problem persists.
          Is there any other recommended version?


          • #6
            Re: DHCP issues on Cisco 870

            I would check the cisco feature navigator for an IOS that has the features you want. Also did you reboot the cable modem as well? Sometimes cable modems will associate with a particular mac address (your pc for example) and wont learn any other mac's. Make sure there is no filtering happening either that could be blocking the dhcp process.
            CCNA, CCNA-Security, CCNP
            CCIE Security (In Progress)


            • #7
              Re: DHCP issues on Cisco 870

              The following article may help. Specifically the "Troubleshooting" section. At least it worked for me a few years back.

              Good luck!

              How to Configure a Cisco Router Behind a Non-Cisco Cable Modem


              • #8
                Re: DHCP issues on Cisco 870

                Thank you for helping
                I was able to isolate the problem by connecting the router's fa4 interface (wan port) to my PC after installing a DHCP server and running Wireshark.
                I've noticed that the DHCP packets are being sent with destination address of, so the following command indeed seems to be the root cause:
                ip broadcast-address
                Since I'm not able to remove this definition (it just keeps coming back), I tried running the following command consecutively as a workaround:
                ip broadcast-address
                After several tries the DHCP discovery packets were sent with as their destination address.
                I finally received a DHCP offer from the server and the transaction was successful.
                I did the same after re-connecting the modem and I finally was able to get an IP address on my fa4 interface.
                The only thing I'm still trying to understand is why I'm not able to change this permanently (I might get disconnected when the lease is over).
                I already tried updating to the latest IOS and erasing the start-up configuration + reloading.


                • #9
                  Re: DHCP issues on Cisco 870

                  In older implementations was used as the broadcast address which has been depricated as the RFC calls for Not sure why the command is still there though. 12.4 is pretty old now so it may have something to do with it. I tested this with 12.4 (24)T release and the command was not in there by default.
                  CCNA, CCNA-Security, CCNP
                  CCIE Security (In Progress)


                  • #10
                    Re: DHCP issues on Cisco 870

                    Just to add, an easy way to figure out the broadcast address on an interface is with the

                    sh ip int "your interface" command. If the fa4 interface shows the broadcast address as you should be fine when it comes time to renew the lease. Also on cisco devices, if a command shows up explicitly in the running config, then typically it is not a default command but a user defined command. For example, on serial links the default encapsulation type is HDLC. If you do a show run int s0/0, you will not see "encapsulation HDCL in the config as it is a "default".


                    Falls_of_Neuse_3750#sh ip int vlan 10
                    Vlan10 is up, line protocol is up
                    Internet address is
                    Broadcast address is
                    Address determined by configuration file
                    MTU is 1500 bytes
                    Helper address is not set
                    Directed broadcast forwarding is disabled
                    Multicast reserved groups joined:
                    Outgoing access list is not set
                    Inbound access list is not set
                    Proxy ARP is enabled
                    Local Proxy ARP is disabled
                    Security level is default
                    Split horizon is enabled
                    ICMP redirects are always sent
                    ICMP unreachables are always sent
                    ICMP mask replies are never sent
                    IP fast switching is enabled
                    IP CEF switching is enabled
                    IP CEF switching turbo vector
                    IP multicast fast switching is disabled
                    IP multicast distributed fast switching is disabled
                    IP route-cache flags are Fast, CEF
                    Router Discovery is disabled
                    IP output packet accounting is disabled
                    IP access violation accounting is disabled
                    TCP/IP header compression is disabled
                    RTP/IP header compression is disabled
                    Probe proxy name replies are disabled
                    Policy routing is disabled
                    Network address translation is disabled
                    WCCP Redirect outbound is disabled
                    WCCP Redirect inbound is disabled
                    WCCP Redirect exclude is disabled
                    BGP Policy Mapping is disabled
                    Input features: QoS Classification, QoS Marking
                    Last edited by auglan; 2nd November 2012, 13:29.
                    CCNA, CCNA-Security, CCNP
                    CCIE Security (In Progress)


                    • #11
                      Re: DHCP issues on Cisco 870

                      Hi auglan,

                      First of all, thanks again for all your help
                      I'm currently running c870-advipservicesk9-mz.124-22.T1 so maybe I'll try to upgrade to the version you've mentioned and see if it helps.

                      According to the sh ip int fa4 command output the broadcast address is still the one which I determined (

                      FastEthernet4 is up, line protocol is up
                        Internet address is x.x.x.x/21
                        Broadcast address is
                        Address determined by DHCP
                        MTU is 1500 bytes
                      I'm not sure as well why it came back all the time, I also tried to reset it to its default setting by issuing the default ip broadcast-address command several times, it then disappeared from the config (sh run int fa4 didn't show it) and returned as soon as a DHCP discovery was sent.


                      • #12
                        Re: DHCP issues on Cisco 870

                        Im thinking its a buggy version of code. It the interface broadcast address is correct now you should be fine though.
                        CCNA, CCNA-Security, CCNP
                        CCIE Security (In Progress)


                        • #13
                          Re: DHCP issues on Cisco 870

                          So far so good
                          Thanks a lot!


                          • #14
                            Re: DHCP issues on Cisco 870


                            i hade same experience.

                            This is happend when in the rommon Mode (Console->Break@boot->confreg->enabled are:use all zero broadcast) is enabled.

                            since i disabled it, no ip broadcast-address additions where made
                            and the DHCP Broadcast are

                            regards steini


                            • #15
                              Re: DHCP issues on Cisco 870

                              That seems to resolve the issue, I've changed the config-register back to its default value (0x2102) using the following commands:
                              R1#configure terminal
                              R1(config)#config-register 0x2102
                              And then reload.
                              Many thanks!