Announcement

Collapse
No announcement yet.

Partial Connection to Wireless Network using 1242 AG Access Point...

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Partial Connection to Wireless Network using 1242 AG Access Point...

    Hello,

    Thanks to the folks who help me in this thread. Unfortunately, I am at another impasse.

    Basically, I have a Cisco 1242 AG wireless access point with multiple SSIDs. They broadcast correctly and I can connect to them. The problem is wierd, in my opinion. If I connect to the "Public" network, for example, I do not get a DHCP address but if I set a static address while connected I can ping any other device on the 60 VLAN.

    Other devices connected (but not through this Access Point) can get a DHCP address and connect just fine.

    What am I doing wrong here?

    Here is the configuration for the Cisco 1242 AG access point in question:

    {I attached the file}

    In addition, here is the configuration for the device that the above AP is physically connected to:

    {I attached the file}

    And, here is the configuration for VLAN 60 from our Catalyst 4506 Distribution Switch:

    Code:
    interface Vlan60
     no ip address
     ip helper-address 10.10.1.112
    !
    Not sure what else may be needed to troubleshoot this issue.

    Thank you for your time.

    Regards,
    Christopher Koeber
    Attached Files

  • #2
    Re: Partial Connection to Wireless Network using 1242 AG Access Point...

    How can vlan 60 forward any dhcp requests (or route any ip traffic for hosts in vlan 60 to other vlans) to the dhcp server if IP is not configured on the vlan 60 interface?

    interface Vlan60
    no ip address
    ip helper-address 10.10.1.112


    Also why does your 2950 have 2 vlan interfaces with ip addresses? I do realize that vlan 60 on the 2950 is shutdown but I would remove the ip. Remember the ip address for the interface on the layer 2 switch is only used for remote management.
    CCNA, CCNA-Security, CCNP
    CCIE Security (In Progress)

    Comment


    • #3
      Re: Partial Connection to Wireless Network using 1242 AG Access Point...

      Originally posted by auglan View Post
      How can vlan 60 forward any dhcp requests (or route any ip traffic for hosts in vlan 60 to other vlans) to the dhcp server if IP is not configured on the vlan 60 interface?

      interface Vlan60
      no ip address
      ip helper-address 10.10.1.112
      I gave VLAN60 an ip address but I still have the same problem; no DHCP address.

      Originally posted by auglan View Post
      Also why does your 2950 have 2 vlan interfaces with ip addresses? I do realize that vlan 60 on the 2950 is shutdown but I would remove the ip. Remember the ip address for the interface on the layer 2 switch is only used for remote management.
      The extra IP was removed.

      Comment


      • #4
        Re: Partial Connection to Wireless Network using 1242 AG Access Point...

        Do you have reachability to the DHCP server? Can you source a ping from that Vlan60 interface to the DHCP server? Is their a dhcp scope properly configured for hosts in vlan 60? Is routing setup properly for bidirectional communication between these vlans?
        CCNA, CCNA-Security, CCNP
        CCIE Security (In Progress)

        Comment


        • #5
          Re: Partial Connection to Wireless Network using 1242 AG Access Point...

          Originally posted by auglan View Post
          Do you have reachability to the DHCP server? Can you source a ping from that Vlan60 interface to the DHCP server? Is their a dhcp scope properly configured for hosts in vlan 60? Is routing setup properly for bidirectional communication between these vlans?
          How do you ping from the interface to an ip? I know how to do a general ping when not in configure mode but I don't know how to switch to an interface and ping from that interface.

          Thanks.

          Comment


          • #6
            Re: Partial Connection to Wireless Network using 1242 AG Access Point...

            ping 10.10.1.112 source vlan 60
            CCNA, CCNA-Security, CCNP
            CCIE Security (In Progress)

            Comment


            • #7
              Re: Partial Connection to Wireless Network using 1242 AG Access Point...

              Originally posted by auglan View Post
              Do you have reachability to the DHCP server? Can you source a ping from that Vlan60 interface to the DHCP server? Is their a dhcp scope properly configured for hosts in vlan 60? Is routing setup properly for bidirectional communication between these vlans?
              Interesting note; I can ping the DHCP server from the BVI interface of the AP that I have set up; but a wireless client connecting on the same VLAN as the BVI interface I get nothing....

              Comment


              • #8
                Re: Partial Connection to Wireless Network using 1242 AG Access Point...

                Originally posted by auglan View Post
                ping 10.10.1.112 source vlan 60

                Yep:

                Code:
                {Distribution Switch} #ping 10.10.1.112 source vlan 60
                
                Type escape sequence to abort.
                Sending 5, 100-byte ICMP Echos to 10.10.1.112, timeout is 2 seconds:
                Packet sent with a source address of 10.60.0.3
                !!!!!
                Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms

                Comment


                • #9
                  Re: Partial Connection to Wireless Network using 1242 AG Access Point...

                  Interesting note; I can ping the DHCP server from the BVI interface of the AP that I have set up; but a wireless client connecting on the same VLAN as the BVI interface I get nothing...
                  If your clients can't get an address via dhcp then this would be expected.


                  I would try plugging a client into the distribution switch and put that port into vlan 60 as an access port. See if the client can get an address from dhcp for the vlan 60 scope when connected directly to the distro switch.
                  CCNA, CCNA-Security, CCNP
                  CCIE Security (In Progress)

                  Comment


                  • #10
                    Re: Partial Connection to Wireless Network using 1242 AG Access Point...

                    Originally posted by auglan View Post
                    If your clients can't get an address via dhcp then this would be expected.


                    I would try plugging a client into the distribution switch and put that port into vlan 60 as an access port. See if the client can get an address from dhcp for the vlan 60 scope when connected directly to the distro switch.
                    Yep, I can get an IP when plugged in directly. I also get an IP with the older access points that are plugged into ports that are just access ports and not trunks.

                    I am hoping I can get the multiple VLAN going so I really want to use this new AP as a model to set the other ones up.

                    Thank you for your time.

                    Comment


                    • #11
                      Re: Partial Connection to Wireless Network using 1242 AG Access Point...

                      You can always run dhcp on the switch itself. I do this for our guest wireless network.
                      CCNA, CCNA-Security, CCNP
                      CCIE Security (In Progress)

                      Comment


                      • #12
                        Re: Partial Connection to Wireless Network using 1242 AG Access Point...

                        Originally posted by auglan View Post
                        You can always run dhcp on the switch itself. I do this for our guest wireless network.
                        On the 4506? I saw the feature on the access point. I will research...

                        Comment


                        • #13
                          Re: Partial Connection to Wireless Network using 1242 AG Access Point...

                          Originally posted by auglan View Post
                          You can always run dhcp on the switch itself. I do this for our guest wireless network.
                          Kind of sucks that the IP helper feature works fine on the older APs configured to use the port as an access port but when you want to use multiple SSIDs you need something different. Dam...

                          Comment


                          • #14
                            Re: Partial Connection to Wireless Network using 1242 AG Access Point...

                            I am just posting my other AP that DOES work off of VLAN 60 but this AP is configured to just connect to a port that has been defined as an access port.

                            Code:
                            Building configuration...
                            
                            Current configuration : 1205 bytes
                            !
                            version 12.2
                            no service pad
                            service timestamps debug datetime msec
                            service timestamps log datetime msec
                            service password-encryption
                            !
                            hostname ap
                            !
                            enable {Account Information}
                            !
                            username {Account Information}
                            ip subnet-zero
                            !
                            !
                            bridge irb
                            !
                            !
                            interface Dot11Radio0
                             no ip address
                             no ip route-cache
                             !
                             ssid Public
                                authentication open
                                guest-mode
                                infrastructure-ssid
                             !
                             ssid tsunami
                                authentication open
                             !
                             speed basic-1.0 basic-2.0 basic-5.5 basic-11.0
                             rts threshold 2312
                             station-role root
                             bridge-group 1
                             bridge-group 1 subscriber-loop-control
                             bridge-group 1 block-unknown-source
                             no bridge-group 1 source-learning
                             no bridge-group 1 unicast-flooding
                             bridge-group 1 spanning-disabled
                            !
                            interface FastEthernet0
                             no ip address
                             no ip route-cache
                             duplex auto
                             speed auto
                             bridge-group 1
                             no bridge-group 1 source-learning
                             bridge-group 1 spanning-disabled
                            !
                            interface BVI1
                             ip address 10.60.255.1 255.255.0.0
                             no ip route-cache
                            !
                            ip default-gateway 10.60.0.1
                            ip http server
                            ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag/ivory/1100
                            bridge 1 route ip
                            !
                            !
                            line con 0
                            line vty 0 4
                             login local
                            line vty 5 15
                             login
                            !
                            end
                            And here is the configuration for the port that AP connects to:

                            Code:
                            interface GigabitEthernet0/43
                             switchport access vlan 60
                             spanning-tree portfast
                            !
                            It's just configured like any other port.

                            Posting this to see if, other than the fact that the port is just configured for access, there is anything else that catches the eye.

                            Thanks.

                            Comment


                            • #15
                              Re: Partial Connection to Wireless Network using 1242 AG Access Point...

                              Possible bug in the ios release? Maybe try an updated IOS? Simple solution would be to run dhcp on the switch at least to get it working.
                              CCNA, CCNA-Security, CCNP
                              CCIE Security (In Progress)

                              Comment

                              Working...
                              X