No announcement yet.

Cisco 3650's Trunking

  • Filter
  • Time
  • Show
Clear All
new posts

  • Cisco 3650's Trunking

    I have 4 Cisco 3650's that connect to a Cisco 3750 via the FSP Gigabit Ports. We are moving over to a VoIP solution and I have configured the Ports to use the Voice Vlan. However, I need to know Trunk the Ga Ports so all traffic is passed through to the switches. When I issue the #switchport mode trunk command I get the error...
    Command rejected: An interface whose trunk encapsulation is "Auto" can not be configured to "trunk" mode.
    I believe I need to make a change to this port to allow Trunking. I am not a CCNA but I play one on tv or for my company at least. Am I suppose to issue this command to get it working...
    (config-if)#switchport trunk encapsulation dot1q 
    (config-if)#switchport mode dynamic desirable 
    (config-if)#switchport mode trunk
    I kinda understand what it is doing but not sure if I am better of leaving it at negotiate. Any help would be greatly appreciated. I will also need to start looking at turning on QoS too.

  • #2
    Re: Cisco 3650's Trunking

    By default the 3560 and 3750 ports are "dynamic auto". If both are set to dynamic auto they will never form a trunk as none of the switches will send dtp frames. I always hard code the trunks. You could set one side as dynamic desirable and they will negotiate the trunking but as I said I always like to statically assign the trunks

    If you want to hard code them then you need to specify the encapsulation first

    switchport trunk encap dot1q
    switchport mode trunk

    Technically your are still running dtp with the above config and if the other side is dynamic auto/desirable/trunk it will form a trunk

    You could also add:

    switchport nonegotiate (This disables DTP)
    Last edited by auglan; 18th September 2012, 19:48.
    CCNA, CCNA-Security, CCNP
    CCIE Security (In Progress)


    • #3
      Re: Cisco 3650's Trunking

      Thanks for the quick reply I thought that seemed correct and you confirmed what I was thinking (scary). I ran the two commands to hard code the encapsulation and I will turn off DTP after I confirm everything is working as I thought. Again thank you for the quick reply.