Announcement

Collapse
No announcement yet.

Cisco 2960 switch

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cisco 2960 switch

    Hi all,

    i am new for cisco 2960 config,

    i have configured 2 vlans in a cisco 2960 switch, how to communicate with each vlans,

    if possible kindly explain with commands.

    Regards
    Devendra

  • #2
    Re: Cisco 2960 switch

    Basic 2960's are Layer 2 only so in order to communicate between vlans you would need a router. You could trunk the 2960 to a router and then setup sub-interfaces on the router , each with its own ip address in that vlans subnet. You would then have your endpoints use that interface as their default-gateway.


    Switch:

    vlan 10

    vlan 20


    int fa0/0
    switchport mode trunk
    switchport trunk allowed vlan 10,20


    Router:


    int fa0/0
    no shut
    int fa0/0.10 (Subinterfaces)
    encapsulation dot1q 10
    ip address 10.1.10.1 255.255.255.0

    int fa0/0.20
    encapsulation dot1q 20
    ip address 10.1.20.1 255.255.255.0


    Some of the 2960's with the appropriate IOS version do support limited Layer 3 functions. I think you need IOS 12.2(55)SE or newer. If your switch does have limited layer 3 functions, instead of using sub interfaces on the route you could use SVI's on the switch. The layer 3 features on the 2960 are very limited though. I think its only static routes (No dynamic routing protocols)



    int vlan 10
    ip address 10.1.10.1 255.255.255.0

    int vlan 20 10.1.20.1 255.255.255.0
    CCNA, CCNA-Security, CCNP
    CCIE Security (In Progress)

    Comment


    • #3
      Re: Cisco 2960 switch

      Hi,

      Thanks for your reply.........

      Cisco IOS Software, C2960 Software (C2960-LANLITEK9-M), Version 12.2(50)SE5,

      please guide can we do this version.

      Regards
      Devendra

      Comment


      • #4
        Re: Cisco 2960 switch

        I believe your 2960 is only layer 2 capable so you would have to go with the first option I used which means you need a router or another layer 3 device to implement inter-vlan routing.


        Switch:

        vlan 10

        vlan 20


        int fa0/0
        switchport mode trunk
        switchport trunk allowed vlan 10,20


        Router:


        int fa0/0
        no shut
        int fa0/0.10 (Subinterfaces)
        encapsulation dot1q 10
        ip address 10.1.10.1 255.255.255.0

        int fa0/0.20
        encapsulation dot1q 20
        ip address 10.1.20.1 255.255.255.0
        CCNA, CCNA-Security, CCNP
        CCIE Security (In Progress)

        Comment


        • #5
          Re: Cisco 2960 switch

          Hi,

          I will explain once again what exactly i need.

          In 24 port, Port 1 is input, and port is connected to my laptop,

          rest of all the ports connected diff user, from port no 2 (my laptop) i want monitor all the other ports, but they ( port 3 -24) should speak each other, i have to monitor all the ports from port no 2

          Pls help me.

          Comment


          • #6
            Re: Cisco 2960 switch

            If you want these vlans to communicate then you HAVE to go through a router/Layer 3 device. There is no way around it. Now if all ports are in the same vlan (by default will be vlan 1) then they will be able to communicate as long as the end hosts are assigned addresses on the same subnet.


            If you want to monitor specifics ports on the switch with a sniffer etc than you need to configure SPAN on the switch. See the link below on the configuration.


            http://www.cisco.com/en/US/products/...8015c612.shtml
            CCNA, CCNA-Security, CCNP
            CCIE Security (In Progress)

            Comment

            Working...
            X