Announcement

Collapse
No announcement yet.

Duplicate MAC address

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Duplicate MAC address

    Interesting situation I have

    My ISP gives me an IP based on MAC address. Because this is a cable internet and I have 877W model of cisco, it is necessary to put cable in one of the switchports. In fact that it's not a routable port, I made VLAN interface bridged to BVI and then have set MAC on it. So it looks like:

    Fastethernet -> VLAN1 -> BVI1 (with MAC set)

    Problem is that sometimes ISP sees both Ethernet and BVI MAC addressess and I think this is why connection sometimes brakes and their DHCP server gets confused. So now I have a question, can I set the same MAC address both to the Ethernet and BVI interfaces so ISP will see only one MAC?

    thanks
    Last edited by zx128k; 6th June 2012, 17:20.

  • #2
    Re: Duplicate MAC address

    Can you not just use the VLAN interface without the BVI for your layer 3 interface connected to your provider. Then just set the port plugged into the cable modem in the appropriate vlan

    Then you should be able to create a second VLAN interface for you internal network and then put those switchports in the appropriate vlan. (I am not sure on what the vlan limits are on this device) Then you could create your BVI and bridge-group.


    int vlan 2
    description == Connected to cable modem
    ip x.x.x.x y.y.y.y
    ip address dhcp setroute
    ip nat outside

    interface FastEthernet3 (Switchport to Cable modem)
    switchport access vlan 2


    int vlan 1
    description == Inside Network
    ip x.x.x.x y.y.y.y
    ip nat inside
    Last edited by auglan; 6th June 2012, 18:42.
    CCNA, CCNA-Security, CCNP
    CCIE Security (In Progress)

    Comment


    • #3
      Re: Duplicate MAC address

      No Auglan, problem is that I HAVE to set MAC address to the L3 interface! Otherwise ISP wouldn't give me an IP adderss. I can't set it on VLAN interface, cisco says it's not possible. So I created BVI interface on which I can set MAC.

      Comment


      • #4
        Re: Duplicate MAC address

        I'll try to explain more detail


        ISP registered my MAC address which is 1111.1111.1111

        L2 Switchports has MAC 2222.2222.2222

        BVI Interface has MAC 1111.1111.1111


        interface FastEthernet0
        !
        interface Vlan1
        no ip address
        bridge-group 1
        !
        interface BVI1
        mac-address 1111.1111.1111
        ip address dhcp
        no ip redirects
        ip directed-broadcast
        ip nat outside
        ip virtual-reassembly
        zone-member security OUTSIDE
        crypto map rtp
        !

        In this case of configuration, everything works good, but sometimes ISP DHCP Server stops giving me an IP Address because it sees both 1111.1111.1111 and 2222.2222.2222 MAC addressess.



        I can change MAC address of the switchport interface (which is 2222.2222.2222) to registered mac - 1111.1111.1111 and remove BVI interface in hope that VLAN interface will get IP address but it will not work because regardless of the switchport mac setting, it will always have its native mac.
        Last edited by zx128k; 6th June 2012, 19:08.

        Comment


        • #5
          Re: Duplicate MAC address

          Typically cable providers let you have one CPE device behind the cable modem whether it be a pc or a router/firewall. When the cable modem learns the mac of the CPE device that is what it uses for authentication via radius to assign your ip address etc. Im not sure why you have to hardcode your mac address is what I am getting at. Most of the time rebooting the cable modem will flush that mac address out of the modems config and it will learn another. Are you saying you have to use a specific mac? If thats the case call your provider and give them the mac of the VLAN interface or ask them if they can add a mac address (some providers will do this for a fee). I have swapped out numerous pix's, asa's, isr routers etc with my cable connection at home and I have never had an issue. I may have had to reboot the modem a few times to flush the old mac out but eventually it learned the new mac of the new device.

          Your correct in saying you cant change the mac on a SVI interface. What I am saying is you shouldn't have to hard code it at all.
          CCNA, CCNA-Security, CCNP
          CCIE Security (In Progress)

          Comment


          • #6
            Re: Duplicate MAC address

            I guess the problem then is that the 877 doesn't give you real routable layer 3 interface. If you had one then this wouldn't be an issue at all as you wouldnt need a Layer2 port to connect to your cable modem and it would only learn the mac of the L3 interface.
            Last edited by auglan; 6th June 2012, 19:22.
            CCNA, CCNA-Security, CCNP
            CCIE Security (In Progress)

            Comment


            • #7
              Re: Duplicate MAC address

              I talked with ISP personnel and he told me that the dhcp server only sees one mac address of the requested interface and another mac is just seen somewhere in the middle by their switches, so problem relies at isp side when sometimes link goes off.

              thanks again Auglan.

              Comment

              Working...
              X