Announcement

Collapse
No announcement yet.

2948g-l3 - Can't Ping

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • 2948g-l3 - Can't Ping

    I discovered this problem the other day when i tried to save the actual configuration via TFTP. I configured an interface like Cisco says and when i tried ping it failed. I tried with an IBR, with and without ip routing, and everything that i could think with the same end.

    Can someone help me with this?

  • #2
    Re: 2948g-l3 - Can't Ping

    Post your config please. Is the tftp server on the same subnet as your switch management interface?
    CCNA, CCNA-Security, CCNP
    CCIE Security (In Progress)

    Comment


    • #3
      Re: 2948g-l3 - Can't Ping

      Right now my configuration is this: (I saw an example of configuration where you could access via telnet if you configurated a bridge like this;at first i tried with the interface f1 but with no luck)

      Current configuration:
      !
      version 12.0
      no service pad
      service timestamps debug uptime
      service timestamps log uptime
      service password-encryption
      !
      hostname Router
      !
      enable secret 5 $1$AFUf$9Fmlrhokc68z8ScW1SjVD1
      enable password 7 0879191E514C55
      !
      ip subnet-zero
      bridge irb
      !
      !
      !
      interface FastEthernet1
      no ip address
      no ip directed-broadcast
      bridge-group 1
      !
      interface FastEthernet2
      no ip address
      no ip directed-broadcast
      bridge-group 1
      !
      (...) [Interface 2 to 40 has the same configuration)
      !
      interface FastEthernet41
      no ip address
      no ip directed-broadcast
      bridge-group 1
      !
      interface FastEthernet42
      no ip address
      no ip directed-broadcast
      !
      interface FastEthernet43
      no ip address
      no ip directed-broadcast
      bridge-group 1
      !
      interface FastEthernet44
      no ip address
      no ip directed-broadcast
      !
      interface FastEthernet45
      no ip address
      no ip directed-broadcast
      bridge-group 1
      !
      interface FastEthernet46
      no ip address
      no ip directed-broadcast
      !
      interface FastEthernet47
      no ip address
      no ip directed-broadcast
      bridge-group 1
      !
      interface FastEthernet48
      no ip address
      no ip directed-broadcast
      !
      interface GigabitEthernet49
      no ip address
      no ip directed-broadcast
      shutdown
      !
      interface GigabitEthernet50
      no ip address
      no ip directed-broadcast
      shutdown
      !
      interface BVI1
      ip address 10.0.0.10 255.255.255.0
      no ip directed-broadcast
      no ip route-cache cef
      !
      ip classless
      !
      bridge 1 protocol ieee
      !
      line con 0
      transport input none
      line aux 0
      line vty 0 4
      password 7 1043001A04
      login
      !
      end

      The tfpt server is on the same subnet.

      Comment


      • #4
        Re: 2948g-l3 - Can't Ping

        Try this:



        ip routing


        bridge 1 route ip


        Also are you plugging your pc directly into this switch or going through another switch? Are you using a crossover cable? Depending if the switch uses auto-mdix will determine if a crossover is needed or not.
        Last edited by auglan; 13th May 2012, 16:26.
        CCNA, CCNA-Security, CCNP
        CCIE Security (In Progress)

        Comment


        • #5
          Re: 2948g-l3 - Can't Ping

          Hi, I'm sorry for the late reply.

          I tried with what you told me but it didn't work. I'm plugged directly into the switch with a crossover cable.

          Is there something that dosen't reset when i use the command erase startup-config?(in theory not) at this point i just don't know what more i can try. this is driving me crazy.

          Comment


          • #6
            Re: 2948g-l3 - Can't Ping

            I would remove the Bridge Group and just set one of your interface as a routed interface and assign an ip address on it in the same subnet as your pc. Then see if you can ping that interface directly from the pc.


            From PC to switch you need a straight-through cable
            Switch to Switch you need a crossover (Unless it supports auto-mdix)
            CCNA, CCNA-Security, CCNP
            CCIE Security (In Progress)

            Comment


            • #7
              Re: 2948g-l3 - Can't Ping

              i plugged mi pc to the switch with a straight-through and still nothing. I remove the bridge and configured an interface but still didn't work.

              Comment


              • #8
                Re: 2948g-l3 - Can't Ping

                When you plug your pc into the switchport does the port come up?

                Check using:

                show ip int b

                or


                sh int status
                CCNA, CCNA-Security, CCNP
                CCIE Security (In Progress)

                Comment

                Working...
                X