Announcement

Collapse
No announcement yet.

2960 problems

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • 2960 problems

    Hi All,
    First time posting and hoping someone can shed some light on an issue im having.
    Relative networking newb and first time working with a Cisco switch. I'm trying to connect a Cisco 2960-S to an existing Cisco 3750 switch stack. There seems to be switch activity however I cannot access anything on our network from the 2960.
    I don't have access to the 3750 so Im assuming its configured as it should be with the proper vlan and the port used configured as a trunk port.
    I didn't have any issues setting up the 2960 and managed to configure the uplink port as a trunk as well.
    When I connected the switch to another 2060 it worked fine.

    Am I missing something here or is there something I can do to figure this out?
    Thanks...

    The 2960 port config is as such:

    !
    vlan internal allocation policy ascending
    !
    !
    !
    interface FastEthernet0
    no ip address
    !
    interface GigabitEthernet1/0/1
    switchport mode trunk
    !
    interface GigabitEthernet1/0/2
    !
    interface GigabitEthernet1/0/3
    !
    interface GigabitEthernet1/0/4
    !
    interface GigabitEthernet1/0/5
    !
    interface GigabitEthernet1/0/6
    !
    interface GigabitEthernet1/0/7
    !
    interface GigabitEthernet1/0/8
    !
    interface GigabitEthernet1/0/9
    !
    interface GigabitEthernet1/0/10
    !
    interface GigabitEthernet1/0/11
    !
    interface GigabitEthernet1/0/12
    !
    interface GigabitEthernet1/0/13
    !
    interface GigabitEthernet1/0/14
    !
    interface GigabitEthernet1/0/15
    !
    interface GigabitEthernet1/0/16
    !
    interface GigabitEthernet1/0/17
    !
    interface GigabitEthernet1/0/18
    !
    interface GigabitEthernet1/0/19
    !
    interface GigabitEthernet1/0/20
    !
    interface GigabitEthernet1/0/21
    !
    interface GigabitEthernet1/0/22
    !
    interface GigabitEthernet1/0/23
    !
    interface GigabitEthernet1/0/24
    !
    interface GigabitEthernet1/0/25
    !
    interface GigabitEthernet1/0/26
    !
    interface GigabitEthernet1/0/27
    !
    interface GigabitEthernet1/0/28
    !
    interface GigabitEthernet1/0/29
    !
    interface GigabitEthernet1/0/30
    !
    interface GigabitEthernet1/0/31
    !
    interface GigabitEthernet1/0/32
    !
    interface GigabitEthernet1/0/33
    !
    interface GigabitEthernet1/0/34
    !
    interface GigabitEthernet1/0/35
    !
    interface GigabitEthernet1/0/36
    !
    interface GigabitEthernet1/0/37
    !
    interface GigabitEthernet1/0/38
    !
    interface GigabitEthernet1/0/39
    !
    interface GigabitEthernet1/0/40
    !
    interface GigabitEthernet1/0/41
    !
    interface GigabitEthernet1/0/42
    !
    interface GigabitEthernet1/0/43
    !
    interface GigabitEthernet1/0/44
    !
    interface GigabitEthernet1/0/45
    !
    interface GigabitEthernet1/0/46
    !
    interface GigabitEthernet1/0/47
    !
    interface GigabitEthernet1/0/48
    !
    interface GigabitEthernet1/0/49
    !
    interface GigabitEthernet1/0/50
    !
    interface GigabitEthernet1/0/51
    !
    interface GigabitEthernet1/0/52
    !
    interface Vlan1
    ip address 10.99.116.19 255.255.254.0
    !
    ip default-gateway 10.99.116.10
    ip http server
    ip http secure-server
    ip sla enable reaction-alerts
    !

  • #2
    Re: 2960 problems

    Check that the port on the 3750 is a trunk port and what type of trunking encapsulation it is running. The 3750 supports ISL and Dot1q and I believe ISL may be the default. Also the 2960 only supports dot1q so if the 3750 is set to ISL a trunk wont form. They would have to change the encap type to dot1q on their side. Also the 3750 defaults to dynamic auto for DTP (Dynamic Trunking Protocol) This means it will not initiate trunking but will listen for DTP frames. The 2960 may be setup for dynamic auto as well and if both ports are setup to dynamic auto neither side will initiate trunking and a trunk line will never form. I usually dont run DTP and statically assign trunks.

    I am pretty sure in this case the 3750 may be running ISL trunking. If thats not the case and the 3750 is running dot1q make sure the native vlan is the same on both sides as well. (default is vlan 1) Also if DTP is used between the switches and VTP (Vlan Trunking Protocol) is used then the VTP domain needs to be the same on both sides as the vtp info is passed during the trunk negotiation.


    switchport mode trunk
    switchport nonegotiate
    Last edited by auglan; 30th April 2012, 17:42.
    CCNA, CCNA-Security, CCNP
    CCIE Security (In Progress)

    Comment

    Working...
    X