Announcement

Collapse
No announcement yet.

IPv6 IPv4 network interconnection, NAT-PT (v4-mapped)

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • IPv6 IPv4 network interconnection, NAT-PT (v4-mapped)

    Hello , I am trying to setup nat-pt so that an ipv6-only network can communicate with an ipv4-only network and vice-versa..

    I have followed the cisco ipv6 configuration guide.
    - Static NAT-PT, Dynamic NAT-PT and PAT overload were working

    - however IPv4-mapped is not working and unfortunately for me it's what i have to implement on a network



    Routers' configuration with important commands;

    Router0 config;
    ipv6 unicast-routing
    !
    interface FastEthernet0/0
    no ip address
    ipv6 address 2001:A:B:C::4/64
    ipv6 nat prefix 2001::/96 v4-mapped WHAT_to_IPv4
    ipv6 enable
    ipv6 nat
    !
    interface FastEthernet0/1
    ip address 192.168.40.199 255.255.255.0

    ipv6 nat
    !
    ipv6 nat v4v6 source 192.168.40.104 2001::C0A8:2868
    ipv6 nat v6v4 source list list_to-ipv4 interface FastEthernet0/1 overload


    ipv6 access-list list_to-ipv4
    permit ipv6 2001:A:B:C::/64 any


    ipv6 access-list WHAT_to_IPv4
    permit ipv6 any 2001::/96
    !

    end




    Router2 config;

    ipv6 unicast-routing
    !
    interface FastEthernet0/0
    no ip address
    ipv6 address 2001:A:B:C::1/64
    ipv6 enable
    !
    ipv6 route ::/0 2001:A:B:C::4
    !
    end




    Router1 config;
    interface FastEthernet0/0

    ip address 192.168.40.200 255.255.255.0
    !
    end





    Now, when i ping ''server'' from ''router2'', even static is not working. i.e "ping ipv6 2001::C0A8:2868" says unreachable.

    ALso when testing v4mapped i.e "ping 2001::192.168.40.200", same result.

    After lots of trial,testing,web research, i still have no clue what configuration is wrong.



    note ; i have also attached both the topology together with the packet tracer simulation file.
    Attached Files

  • #2
    Re: IPv6 IPv4 network interconnection, NAT-PT (v4-mapped)

    So I assume this is a practice lab for CCIE or other certification? May want to read through
    the IPV6 configuration guide again.
    CCNA, CCNA-Security, CCNP
    CCIE Security (In Progress)

    Comment


    • #3
      Re: IPv6 IPv4 network interconnection, NAT-PT (v4-mapped)

      thanks for replying, but the the thing is that i have throughly read the guide, and not only the cisco guide!

      cisco.com/en/US/docs/ios/ipv6/configuration/guide/ip6
      nat_trnsln_ps6350_TSD_Products_Configuration_Guide _Chapter.html#wp1056266[/

      cciethebeginning.wordpress.com/2009/07/27/ipv6-nat-pt-transition

      Comment


      • #4
        Re: IPv6 IPv4 network interconnection, NAT-PT (v4-mapped)

        From a real world prospective this is not really an option anymore. Actually they are contemplating moving this feature to a historic status in the RFC as it has many issues.
        One big issue is that it doesnt work with CEF switching on cisco devices, which means you need to disable cef globally and it will be processed switched, resulting in a huge load on your router cpu. The are many other options such as dual stacking and tunneling. However it still is on the CCIE R&S blueprint.


        Check this link out to see if it makes anymore sense. I know Cisco documentation can be confusing sometimes.


        http://blog.ine.com/2008/04/18/under...g-ipv6-nat-pt/
        CCNA, CCNA-Security, CCNP
        CCIE Security (In Progress)

        Comment


        • #5
          Re: IPv6 IPv4 network interconnection, NAT-PT (v4-mapped)

          thanks, but i already used this blog and the thing is that i can't make the v4-mapped configuration to work

          Comment

          Working...
          X