Announcement

Collapse
No announcement yet.

Can't ping pc within the same vlan

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Can't ping pc within the same vlan

    I have a simple home network but can't seem to ping a PC within the same VLAN but I do have internet access on both PC's.
    Here are the facts
    Internet <---> Comcast Modem <---> Cisco router <---> Cisco switch (3550) <---> PC
    I'm also running NAT on my Cisco router(2600)
    I have a static IP from Comcast.
    My comcast modem is in bridged mode.
    Can you tell me what I'm missing
    (Shortened the config a little bit)

    MYROUTER#sh run
    Building configuration...
    !
    hostname MYROUTER
    !
    ip subnet-zero
    ip cef
    !
    !
    ip dhcp excluded-address 192.168.50.1 192.168.50.20
    !
    ip dhcp pool POOL
    network 192.168.50.0 255.255.255.0
    default-router 192.168.50.1
    dns-server 68.87.68.162 68.87.74.162
    !
    !
    username cisco password 0 cisco
    !
    !
    interface Ethernet0/0
    ip address 192.168.50.1 255.255.255.0
    ip nat inside
    full-duplex
    description TO CISCO SWITCH
    !
    interface Ethernet0/1
    ip address 173.x.x.114 255.255.255.248
    ip nat outside
    full-duplex
    description TO COMCAST MODEM
    !
    ip nat inside source list 1 interface Ethernet0/1 overload
    ip http server
    ip classless
    ip route 0.0.0.0 0.0.0.0 173.x.x.118
    !
    !
    access-list 1 permit 192.168.50.0 0.0.0.255 log
    !
    !
    end
    -----------------------
    MYSWITCH#sh run
    Building configuration...
    Current configuration : 2528 bytes
    !
    version 12.2
    hostname MYSWITCH
    !
    ip subnet-zero
    ip routing
    !
    !
    spanning-tree mode pvst
    spanning-tree extend system-id
    !
    !
    vlan internal allocation policy ascending
    !
    !
    interface FastEthernet0/1
    description TO ROUTER
    switchport trunk encapsulation dot1q
    switchport trunk native vlan 10
    switchport mode trunk
    duplex full
    !
    interface FastEthernet0/8
    switchport mode dynamic desirable
    interface FastEthernet0/9
    switchport mode dynamic desirable
    !
    interface FastEthernet0/10
    switchport mode dynamic desirable
    !
    interface FastEthernet0/11
    switchport mode dynamic desirable
    !
    interface FastEthernet0/12
    switchport mode dynamic desirable
    !
    interface FastEthernet0/13
    description PC1
    switchport access vlan 10
    switchport mode access
    duplex full
    speed 100
    spanning-tree portfast
    !
    interface FastEthernet0/19
    description PC2
    switchport access vlan 10
    switchport mode access
    duplex full
    speed 100
    spanning-tree portfast
    !
    !
    interface Vlan1
    no ip address
    shutdown
    !
    interface Vlan10
    ip address 192.168.50.2 255.255.255.0
    !
    ip default-gateway 192.168.50.1
    ip classless
    ip http server
    !
    end
    ---------------------
    MYSWITCH#sh vlan brie
    VLAN Name Status Ports
    ---- -------------------------------- --------- -------------------------------
    1 default active Fa0/2, Fa0/3, Fa0/4, Fa0/5
    Fa0/6, Fa0/7, Fa0/8, Fa0/9
    Fa0/10, Fa0/11, Fa0/12, Fa0/14
    Fa0/15, Fa0/16, Fa0/17, Fa0/18
    Fa0/20, Fa0/21, Fa0/22, Fa0/23
    Fa0/24, Gi0/1, Gi0/2
    10 VLAN0010 active Fa0/13, Fa0/19
    1002 fddi-default act/unsup
    1003 token-ring-default act/unsup
    1004 fddinet-default act/unsup
    1005 trnet-default act/unsup

  • #2
    Re: Can't ping pc within the same vlan

    You do have some mistakes in the config but first check to see if the firewall is turned off on the pc's. Also since you hardcoded the access ports on the switch make sure you hardcode the speed/duplex on the pc's. If one side is hardcoded and the other is setup for auto it could result in a duplex mismatch. 100Mbs half-duplex. Can you ping the pc's from the switch and router? or is the issue ping from pc to pc? Since all devices are in the same broadcast domain i wouldn't think the trunking issue below would cause this problem as since all devices are in vlan 10 they should be able to resolve each other locally.

    You didn't specify the native vlan on the e0/0 interface on the router nor did you tell it it was a trunk. . Not sure why you are trunking to the router at all really as your are only running 1 vlan. You could just put the port connected to the router as an access port and put it in vlan 10. If you need to trunk multiple vlans create subinterfaces on the router. Depending on the IOS version will determine if you can create sub-interfaces on the router etc.

    int e0/0.10
    encapsulation dot1q 10 native
    ip address x.x.x.x y.y.y.y

    Also if you going to hard code the duplex, you may as well hardcode the speed and duplex as well on both ends.

    If your switch is L3 aware (with 3550's it depends on the IOS version) then you could let the switch handle the intervlan routing ( you only have one vlan now but for in the future) and set the port connected to the router as an access port. There is really no reason to trunk unless you are carrying traffic for multiple vlans.

    I do see you have ip routing enabled on the switch. So it will use the routing table to route. The ip default-gateway command does nothing when ip routing is enabled. Right now your router is using proxy arp to resolve layer 3 to layer 2 for the switch for traffic not local to it. I would also put a static route on the switch or disable routing on the switch and just use the ip default-gateway.


    ip route 0.0.0.0 0.0.0.0 192.168.50.1
    Last edited by auglan; 25th January 2012, 17:51.
    CCNA, CCNA-Security, CCNP
    CCIE Security (In Progress)

    Comment

    Working...
    X