Announcement

Collapse
No announcement yet.

VLAN communication between two L3 Switch 3560 X sERIES

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • VLAN communication between two L3 Switch 3560 X sERIES

    I have TWO L3 Switch (Cisco 3560 X-Series) 48T.

    One L3 Switch is on Site A
    And another L3 switch is on Site B.
    The distance between both Sites is about 20 Km.

    We are using Fiber link to Connect to Both L3 Switches.

    Site A Switch:
    Vlan 11 (1 to 12 Port)----- SVI=10.28.11.1, Subnet= 255.255.255.0
    Vlan 12 (13 to 24 Port)----- SVI=10.28.12.11 Subnet= 255.255.255.0
    Vlan 1 Default No IP

    Site B Switch:
    No Configuration yet.

    I have two question:

    1) How to do Intervlan communication from Vlan 12 to Vlan 11 or Vlan Default to Vlan 11 . For example if my machine is connected to Vlan 12 with an IP of 10.28.12.2 and another machine connected to Vlan 11 with an IP of 10.28.11.2. Which configuration command should I use to communicate between two different Vlans. Remember the switch is Layer 3.

    2) How can I communicate from Site B to Site A. I m connected via Fiber Link with Live IP's. What Configuration should I do on Site B switch and what changes should I do on Site A switch.
    My main purpose is I that My users are sitting on Site B and my Machines are connected on VLAN 11 at site A. How can my user can access server machines from Site B to Site A?

    Please help me. This is my project which I have to complete in a week time. I will be waiting for an expert Advice..

    If you required diagram please let me know I will send it to you..

    Regards,
    Waqs..
    Last edited by waqas2964; 5th January 2012, 10:18.

  • #2
    Re: VLAN communication between two L3 Switch 3560 X sERIES

    If you need its diagram please send me ur Email ID I will forward it to you..

    Regards,,

    Waqs

    Comment


    • #3
      Re: VLAN communication between two L3 Switch 3560 X sERIES

      The subnets should show up in the switch as connected routes when looking at the routing table. Since Switchh A has both of those subnets as "connected" then there is nothing further you need to do (im assuming that there is no filtering or ACL's between the vlans) in regards to inter-vlan communication. They should be able to reach each other at Layer 3.

      To configure SwitchB just create your vlans. Assign different subnets to your SVI's and either create static routes from SwitchA to SwitchB and vice versa or run a dynamic routing protocol. (Eigrp, Ripv2 etc)

      Keep in mind that SwitchA and SwitchB are separate layer 2 networks (I assume they are unless you are running q in q tunneling with your provider over the fiber link) so you can use the same vlans on SwitchB.

      If your goal is to span your layer 2 vlans across the fiber link then your provider needs to setup q in q tunneling (ie Metro Ethernet) to extend those vlans across the fiber.
      CCNA, CCNA-Security, CCNP
      CCIE Security (In Progress)

      Comment


      • #4
        Re: VLAN communication between two L3 Switch 3560 X sERIES

        This configuration I have done on Site A Switch 3560 X Series....

        sh run
        Building configuration...

        Current configuration : 6118 bytes
        !
        version 12.2
        no service pad
        service timestamps debug datetime msec
        service timestamps log datetime msec
        no service password-encryption
        !
        hostname SWITCH-siteA
        !
        boot-start-marker
        boot-end-marker
        !
        enable password cisco
        !
        !
        !
        no aaa new-model
        system mtu routing 1500
        ip routing
        !
        !
        !
        !

        spanning-tree mode pvst
        spanning-tree extend system-id
        !
        !
        !
        !
        vlan internal allocation policy ascending
        !
        !
        !
        interface FastEthernet0
        no ip address
        no ip route-cache cef
        no ip route-cache
        !
        interface GigabitEthernet0/1
        switchport access vlan 11
        switchport mode access
        spanning-tree portfast
        !
        interface GigabitEthernet0/2
        switchport access vlan 11
        switchport mode access
        spanning-tree portfast
        !
        interface GigabitEthernet0/3
        switchport access vlan 11
        switchport mode access
        spanning-tree portfast
        !
        interface GigabitEthernet0/4
        switchport access vlan 11
        switchport mode access
        spanning-tree portfast
        !
        interface GigabitEthernet0/5
        switchport access vlan 11
        switchport mode access
        spanning-tree portfast
        !
        interface GigabitEthernet0/6
        switchport access vlan 11
        switchport mode access
        spanning-tree portfast
        !
        interface GigabitEthernet0/7
        switchport access vlan 11
        switchport mode access
        spanning-tree portfast
        !
        interface GigabitEthernet0/8
        switchport access vlan 11
        switchport mode access
        spanning-tree portfast
        !
        interface GigabitEthernet0/9
        switchport access vlan 11
        switchport mode access
        spanning-tree portfast
        !
        interface GigabitEthernet0/10
        switchport access vlan 11
        switchport mode access
        spanning-tree portfast
        !
        interface GigabitEthernet0/11
        switchport access vlan 11
        switchport mode access
        spanning-tree portfast
        !
        interface GigabitEthernet0/12
        switchport access vlan 11
        switchport mode access
        spanning-tree portfast
        !
        interface GigabitEthernet0/13
        switchport access vlan 12
        switchport mode access
        spanning-tree portfast
        !
        interface GigabitEthernet0/14
        switchport access vlan 12
        switchport mode access
        spanning-tree portfast
        !
        interface GigabitEthernet0/15
        switchport access vlan 12
        switchport mode access
        spanning-tree portfast
        !
        interface GigabitEthernet0/16
        switchport access vlan 12
        switchport mode access
        spanning-tree portfast
        !
        interface GigabitEthernet0/17
        switchport access vlan 12
        switchport mode access
        spanning-tree portfast
        !
        interface GigabitEthernet0/18
        switchport access vlan 12
        switchport mode access
        spanning-tree portfast
        !
        interface GigabitEthernet0/19
        switchport access vlan 12
        switchport mode access
        spanning-tree portfast
        !
        interface GigabitEthernet0/20
        switchport access vlan 12
        switchport mode access
        spanning-tree portfast
        !
        interface GigabitEthernet0/21
        switchport access vlan 12
        switchport mode access
        spanning-tree portfast
        !
        interface GigabitEthernet0/22
        switchport access vlan 12
        switchport mode access
        spanning-tree portfast
        !
        interface GigabitEthernet0/23
        switchport access vlan 12
        switchport mode access
        spanning-tree portfast
        !
        interface GigabitEthernet0/24
        switchport access vlan 12
        switchport mode access
        spanning-tree portfast
        !
        interface GigabitEthernet0/25
        !
        interface GigabitEthernet0/26
        !
        interface GigabitEthernet0/27
        !
        interface GigabitEthernet0/28
        !
        interface GigabitEthernet0/29
        !
        interface GigabitEthernet0/30
        !
        interface GigabitEthernet0/31
        !
        interface GigabitEthernet0/32
        !
        interface GigabitEthernet0/33
        !
        interface GigabitEthernet0/34
        !
        interface GigabitEthernet0/35
        !
        interface GigabitEthernet0/36
        !
        interface GigabitEthernet0/37
        !
        interface GigabitEthernet0/38
        !
        interface GigabitEthernet0/39
        !
        interface GigabitEthernet0/40
        !
        interface GigabitEthernet0/41
        !
        interface GigabitEthernet0/42
        !
        interface GigabitEthernet0/43
        !
        interface GigabitEthernet0/44
        !
        interface GigabitEthernet0/45
        !
        interface GigabitEthernet0/46
        !
        interface GigabitEthernet0/47
        !
        interface GigabitEthernet1/1
        !
        interface GigabitEthernet1/2
        !
        interface GigabitEthernet1/3
        !
        interface GigabitEthernet1/4
        !
        interface TenGigabitEthernet1/1
        !
        interface TenGigabitEthernet1/2
        !
        interface Vlan1
        no ip address
        !
        interface Vlan11
        ip address 10.28.11.1 255.255.255.0
        !
        interface Vlan12
        ip address 10.28.12.1 255.255.255.0
        !
        ip classless
        ip forward-protocol udp 4546
        ip http server
        ip http secure-server
        !
        ip sla enable reaction-alerts
        !
        !
        line con 0
        line vty 0 4
        password cisco
        login
        line vty 5 15
        login
        !
        end

        Comment


        • #5
          Re: VLAN communication between two L3 Switch 3560 X sERIES

          NOw tell me what configuration I have to do on Site B Switch ..3560 X Series... Layer 3

          Comment


          • #6
            Re: VLAN communication between two L3 Switch 3560 X sERIES

            You could use an almost identical config on SWB. Just change the ip addressing on the SVI's. Your vlans could stay the same if you want or you could create new ones. What interface on SWA is connected to the provider?

            Also what type of circuit is it? Q in Q tunnel?
            Last edited by auglan; 6th January 2012, 15:46.
            CCNA, CCNA-Security, CCNP
            CCIE Security (In Progress)

            Comment


            • #7
              Re: VLAN communication between two L3 Switch 3560 X sERIES

              The connection between L3 Switch A and L3 Switch B is a simple VPN with Live IP's will be provided by ISP. VPN will keep both sites as we are on LAN.

              - My Server Machines are connected with Switch A on VLAN 11.
              VLAN 11 SVI 10.28.11.1 255.255.255.0
              VLAN 12 SVI 10.28.12.1 255.255.255.0
              Vlan 1 Default No IP

              - And my users are sitting on Switch B.
              User from this site will access my machines on SITE A

              Subnet Available
              10.28.11.0/24 to 10.28.20.0/24

              What do you think ISP will provide me??? I think ISP will give me IP pool with Gateway & Subnet + DNS..
              And what sort of Configuration should I do on Switch B?
              Should I use Default Routes?
              Actually I m beginner in this network stuff L3 Switching... Please help me... And please gv me ur Email ID I will send you the complete diagram.

              Regards..

              Waqs..

              Comment


              • #8
                Re: VLAN communication between two L3 Switch 3560 X sERIES

                The big question is what technology is going to be used? Metro Ethernet? MPLS VPN?

                Have you not talked to the provider about this. They would be able to help you in the preparation etc. Either way mpls or metro ethernet, 99 percent of the config is done on the providers side.
                CCNA, CCNA-Security, CCNP
                CCIE Security (In Progress)

                Comment


                • #9
                  Re: VLAN communication between two L3 Switch 3560 X sERIES

                  MPLS vpn...
                  Now please tell me what configuration I have to do on Site A Switch L3 & Site B L3 Switch...

                  What parameter I have to take?
                  And what other things should I ask from ISP??

                  Regards.

                  Waqs..

                  Comment


                  • #10
                    Re: VLAN communication between two L3 Switch 3560 X sERIES

                    And also tell me should I have to add routing as well...

                    How should I provide Route etc.... Please Kindly help me I will be very be thankful for ur help in this regards..

                    Comment


                    • #11
                      Re: VLAN communication between two L3 Switch 3560 X sERIES

                      My main focus is if I m using my Laptop from Site B and I if I ping the desired IP to Site A like 10.28.11.2 255.255.255.0 .. it should start pinging....

                      Comment


                      • #12
                        Re: VLAN communication between two L3 Switch 3560 X sERIES

                        You need to contact your provider to see what your config should look like. Will you be running a routing protocol with them? Most MPLS VPN's run a routing protocol with the provider, this is usually BGP but I have seen some run OSPF as well. You will also need to tell them what subnets you will be advertising to them so they can setup their side. If you are doing static routing you need to confirm that this is supported as well. Depending on what the provider requires will determine what your config will look like.
                        CCNA, CCNA-Security, CCNP
                        CCIE Security (In Progress)

                        Comment


                        • #13
                          Re: VLAN communication between two L3 Switch 3560 X sERIES

                          I m using subnet 10.28.11.0/24 in Switch A

                          I dont know what subnet and IP's ISP is using on there End.

                          Who should have to add routes in L3 CISCO 3560 X Switch Me or ISP????

                          Should I use Default Routes or should I use Static Routes??

                          If my DHCP server is configure should I use same subnet on switch B as well???? Or i have to use Different subnets...

                          Remember my L3 Switch are connected Point to Point VPN (MPLS)
                          My one L3 Switch is connected on Site A and other is connected on site B.

                          Comment


                          • #14
                            Re: VLAN communication between two L3 Switch 3560 X sERIES

                            This all depends on the provider. Did you contact them? Do you know how MPLS VPN's work?

                            Typically your switch/router will be the CE device (Customer Edge). The CE connects to the PE (Provider Edge) Normally you would run a routing protocol with them so they can learn your routes. This is needed so they can setup the VRF's in their cloud. There are also layer 2 mpls vpn's. From what you post its a layer 3 mpls vpn.

                            You need to get with your provider and find out what info they need from you. Also find out what your configuration needs to be on your ends. I would use different subnets on both switches

                            As far as routing goes, this again depends on what routing protocol you will be running with your provider. Typically its BGP or OSPF. Really all they need to do is send you a default route as you only have one possible endpoint.
                            CCNA, CCNA-Security, CCNP
                            CCIE Security (In Progress)

                            Comment

                            Working...
                            X