Announcement

Collapse
No announcement yet.

Cisco Aironet and 3560 switch to internet

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cisco Aironet and 3560 switch to internet

    I have a Cisco Aironet 1131AG and a Cisco 3560 8-port POE switch that I'm trying to get connected through DSL service. The Aironet is connected to the switch and the switch is connected to a DSL modem. I can ping external IPs from the switch and Aironet command prompt, and can get internet connection when connected directly to the switch. I cannot get internet service when I connect through the Aironet with a wireless device. The wireless devices gets assigned an IP, since I setup dhcp on the Aironet, but no internet service. What is the simplest way I can get this fixed through these devices? Can I get by with these two devices or would I need to add a small router?

  • #2
    Re: Cisco Aironet and 3560 switch to internet

    what default gateway is the DHCP service giving to the wireless clients?
    Is it the same as the clients on the switch?
    Please do show your appreciation to those who assist you by leaving Rep Point https://www.petri.com/forums/core/im.../icon_beer.gif

    Comment


    • #3
      Re: Cisco Aironet and 3560 switch to internet

      Yes, the wireless devices are getting the right IP. It looks like they connect successfully, but no internet service. I made my default gateway the ip of the DSL service modem.

      The devices connected to the switch are using static IPs. I checked and there isn't any devices using the same IP.

      Comment


      • #4
        Re: Cisco Aironet and 3560 switch to internet

        Here's my current configs:

        DSL Service Name Server
        222.22.222.185
        222.22.222.186
        222.22.222.187
        DSL Modem IP
        333.333.333.113
        Cisco 3560 8-port POE Switch
        333.333.333.114
        Cisco Aironet 1131AG
        333.333.333.118



        ---------------------------------------------------
        CISCO 3560 8-port POE Switch Configs
        ---------------------------------------------------
        Switch Configs
        Current configurations : 1101 bytes
        !
        version 12.2
        no service pad
        service timestamps debug datetime msec
        service timestamps log datetime msec
        no service password-encryption
        !
        hostname SAMPLEWIFI
        !
        boot-start-marker
        boot-end-marker
        !
        enable secret 5 $343$353564234
        enable password xxxxxxxxxx
        !
        no aaa new-model
        system mtu routing 1500
        ip subnet-zero
        ip routing
        ip name-server 222.22.222.185
        ip name-server 222.22.222.186
        ip name-server 222.22.222.187
        !
        !
        !
        !
        !
        !
        !
        !
        spanning-tree mode pvst
        spanning-tree extend system-id
        !
        vlan internal allocation policy ascending
        !
        !
        !
        interface FastEthernet0/1
        !
        interface FastEthernet0/2
        !
        interface FastEthernet0/3
        !
        interface FastEthernet0/4
        !
        interface FastEthernet0/5
        !
        interface FastEthernet0/6
        !
        interface FastEthernet0/7
        !
        interface FastEthernet0/8
        !
        interface GigabitEthernet0/1
        !
        interface Vlan1
        ip address 333.333.333.114 255.255.255.0
        !
        ip default-gateway 333.333.333.113
        ip classless
        ip route 333.333.333.0 255.255.255.0 333.333.333.113
        ip http server
        !
        !
        control-plane
        !
        !
        line con 0
        line vty 0 4
        password xxxxxxxxx
        login
        line vty 5 15
        password xxxxxxxxxx
        login
        !
        end


        ---------------------------------------------------
        CISCO AIRONET 1131AG Configs
        ---------------------------------------------------
        Aironet Configs
        version 12.4
        no service pad
        service timestamps debug datetime msec
        service timestamps log datetime msec
        service password-encryption
        !
        hostname SampleWIFI
        !
        enable secret 5 $$$$$$xxxxxxx
        !
        no aaa new-model
        clock timezone -0600 -6
        ip domain name samplewifi
        ip name-server 222.22.222.185
        ip name-server 222.22.222.186
        ip name-server 222.22.222.187
        no ip dhcp use vrf connected
        ip dhcp excluded-address 333.333.333.21 333.333.333.255
        !
        ip dhcp pool samplepool
        network 333.333.333.0 255.255.255.0
        default-router 333.333.333.113
        lease 3 23
        !
        !
        dot11 syslog
        !
        dot11 ssid SAMPLEWIFI
        vlan 1
        authentication open
        guest-mode
        !
        dot11 network-map
        dot11 arp-cache
        !
        !
        username xxxxx password 8 2423423423423
        !
        !
        bridge irb
        !
        !
        interface Dot11Radio0
        no ip address
        no ip address
        !
        ssid SAMPLEWIFI
        !
        speed basic-1.0 2.0 5.5 11.0 6.0 9.0 12.0 18.0 24.0 36.0 48.0 54.0
        station-role root
        !
        interface Dot11Radio0.1
        encapsulation dot1Q 1 native
        no ip route-cache
        bridge-group 1
        bridge-group 1 subscriber-loop-control
        bridge-group 1 block-unknown-source
        no bridge-group 1 source-learning
        no bridge-group 1 unicast-flooding
        bridge-group 1 spanning-disabled
        !
        interface Dot11Radio1
        no ip address
        no ip route-cache
        !
        ssid SAMPLEWIFI
        !
        dfs band 3 block
        channel dfs
        station-role root
        !
        interface Dot11Radio1.1
        encapsulation dot1Q 1 native
        no ip route-cache
        bridge-group 1
        bridge-group 1 subscriber-loop-control
        bridge-group 1 block-unknown-source
        no bridge-group 1 source-learning
        no bridge-group 1 unicast-flooding
        bridge-group 1 spanning-disabled
        !
        interface FastEthernet0
        no ip address
        no ip route-cache
        duplex auto
        speed auto
        !
        interface FastEthernet0.1
        encapsulation dot1Q 1 native
        bridge-group 1
        no bridge-group 1 source-learning
        bridge-group 1 spanning-disabled
        !
        interface BV1
        ip address 333.333.333.118 255.255.255.0
        no ip route route-cache
        !
        ip default-gateway 333.333.333.113
        ip http server
        no ip http secure-server
        ip http help-path h-tt-p://w-ww.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
        bridge 1 route ip
        !
        !
        !
        line con 0
        line vty 0 4
        login local
        !
        end

        Comment


        • #5
          Re: Cisco Aironet and 3560 switch to internet

          can you ping the default gateway, from a wireless client?
          Please do show your appreciation to those who assist you by leaving Rep Point https://www.petri.com/forums/core/im.../icon_beer.gif

          Comment


          • #6
            Re: Cisco Aironet and 3560 switch to internet

            Nat is not set of the SW

            Comment


            • #7
              Re: Cisco Aironet and 3560 switch to internet

              CONFIG DNS
              ip dhcp pool samplepool
              network 333.333.333.0 255.255.255.0
              default-router 333.333.333.113
              DNS NAME SERVER 8.8.8.8

              TEST PING TO THR GATEWAY FROM COMPUTER TO 333.333.333.113

              Comment


              • #8
                Re: Cisco Aironet and 3560 switch to internet

                Originally posted by cisconet View Post
                Nat is not set of the SW
                A 3560 cant do NAT. I would assume his dsl modem/router is handling that part. Also your dhcp pool isnt handing out any dns server options to your clients.

                You could enable the dns server service on the switch and use the switch as a dns proxy

                ip dns server

                Then change your dhcp pool on the AP to include the switch as the dns server for your clients.

                ip dhcp pool samplepool
                network 333.333.333.0 255.255.255.0
                default-router 333.333.333.113
                dns-server 333.333.333.114

                Another option is to just use public dns servers in your dhcp options to your clients

                ip dhcp pool samplepool
                network 333.333.333.0 255.255.255.0
                default-router 333.333.333.113
                dns-server 4.4.8.8
                dns-server 8.8.8.8



                Also whats with the route on the 3560?

                ip route 333.333.333.0 255.255.255.0 333.333.333.113


                Since all devices are on the same layer 2 network, I would disable routing on the switch and just use the default-gateway that's already configured:

                no ip routing
                ip default-gateway 333.333.333.113


                If you want to keep routing enable just in case you add more subnets later, change your route to a default route pointing all other traffic to the dsl modem.


                ip route 0.0.0.0 0.0.0.0 333.333.333.113
                CCNA, CCNA-Security, CCNP
                CCIE Security (In Progress)

                Comment

                Working...
                X