Announcement

Collapse
No announcement yet.

Cisco 1841

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cisco 1841

    Hi All
    Does anyone know if it is possible to setup an 1841 router using 2 x ADSL WIC's, so that you can have 2 seperate LAN's and 1 ADSL connection to each.
    The reason for this strange request is one of our ADSL accounts is for VoIP only (no data).

    Thanks

  • #2
    Re: Cisco 1841

    no reason you can't if you do your routing and vlan tagging appropriately..


    1841 only has a single FE if I remember correctly though.. ?
    Please do show your appreciation to those who assist you by leaving Rep Point https://www.petri.com/forums/core/im.../icon_beer.gif

    Comment


    • #3
      Re: Cisco 1841

      Hi
      Thanks for reply, router has FE 0/0 and FE 0/1, I don't suppose you have any idea were I can get a config example, I can handle straight forward configs etc but this would appear to be abit more complex.

      Comment


      • #4
        Re: Cisco 1841

        put vlan1 (phones) on FE0 and vlan2 on FE1

        then, route vlan1 specifically via dialer0, and everything else via dialer1.
        Please do show your appreciation to those who assist you by leaving Rep Point https://www.petri.com/forums/core/im.../icon_beer.gif

        Comment


        • #5
          Re: Cisco 1841

          Hi
          Here is my current attempt, but not working any help would be gratefully received,

          Ghost#sh conf
          Using 4636 out of 196600 bytes
          !
          version 12.4
          no service pad
          service tcp-keepalives-in
          service tcp-keepalives-out
          service timestamps debug datetime msec localtime show-timezone
          service timestamps log datetime msec localtime show-timezone
          service password-encryption
          service sequence-numbers
          !
          hostname Ghost
          !
          boot-start-marker
          boot-end-marker
          !
          security authentication failure rate 3 log
          security passwords min-length 6
          logging buffered 51200 debugging
          logging console critical
          enable secret 5 $1$./pN$A4MpU7t8BFaW.lm/ygQBx.
          !
          aaa new-model
          !
          !
          aaa authentication login local_authen local
          aaa authorization exec local_author local
          !
          aaa session-id common
          no ip source-route
          ip cef
          !
          !
          !
          !
          no ip bootp server
          ip name-server 208.67.222.222
          ip name-server 208.67.220.220
          !
          crypto pki trustpoint TP-self-signed-2649465439
          enrollment selfsigned
          subject-name cn=IOS-Self-Signed-Certificate-2649465439
          revocation-check none
          rsakeypair TP-self-signed-2649465439
          !
          !
          crypto pki certificate chain TP-self-signed-2649465439
          certificate self-signed 01 nvram:IOS-Self-Sig#3939.cer
          username theshire privilege 15 password 7 141F1D090E0D3E
          !
          !
          ip tcp synwait-time 10
          !
          !
          interface Null0
          no ip unreachables
          !
          interface FastEthernet0/0
          description $ETH-LAN$$FW_INSIDE$
          ip address 192.168.69.253 255.255.255.0
          no ip redirects
          no ip unreachables
          no ip proxy-arp
          ip nat inside
          ip route-cache flow
          duplex auto
          speed auto
          no mop enabled
          !
          interface FastEthernet0/1
          no ip address
          no ip redirects
          no ip unreachables
          no ip proxy-arp
          ip route-cache flow
          duplex auto
          speed auto
          no mop enabled
          !
          interface FastEthernet0/1.1
          description $ETH-LAN$$FW_INSIDE$
          encapsulation dot1Q 2
          ip address 10.10.10.1 255.255.255.0
          no ip redirects
          no ip unreachables
          no ip proxy-arp
          ip nat inside
          !
          interface ATM0/0/0
          no ip address
          no ip redirects
          no ip unreachables
          no ip proxy-arp
          ip route-cache flow
          no atm ilmi-keepalive
          dsl operating-mode auto
          !
          interface ATM0/0/0.1 point-to-point
          no ip redirects
          no ip unreachables
          no ip proxy-arp
          no snmp trap link-status
          pvc 0/38
          encapsulation aal5mux ppp dialer
          dialer pool-member 1
          !
          !
          interface ATM0/1/0
          no ip address
          no ip redirects
          no ip unreachables
          no ip proxy-arp
          ip route-cache flow
          no atm ilmi-keepalive
          dsl operating-mode auto
          !
          interface ATM0/1/0.1 point-to-point
          no ip redirects
          no ip unreachables
          no ip proxy-arp
          no snmp trap link-status
          pvc 0/38
          encapsulation aal5mux ppp dialer
          dialer pool-member 2
          !
          !
          interface Dialer0
          description $FW_OUTSIDE$
          ip address negotiated
          no ip redirects
          no ip unreachables
          no ip proxy-arp
          ip nat outside
          encapsulation ppp
          ip route-cache flow
          dialer pool 1
          dialer-group 1
          ppp authentication chap pap callin
          ppp chap hostname [email protected]
          ppp chap password 7 03105E1812
          ppp pap sent-username [email protected] password 7 044F0E151B
          !
          interface Dialer1
          description $FW_OUTSIDE$
          ip address negotiated
          no ip redirects
          no ip unreachables
          no ip proxy-arp
          encapsulation ppp
          ip route-cache flow
          dialer pool 2
          dialer-group 2
          ppp authentication chap pap callin
          ppp chap hostname [email protected]
          ppp chap password 7 044F0E151B70
          ppp pap sent-username [email protected] password 7 051F031C351D
          !
          ip forward-protocol nd
          ip route 10.10.10.0 255.255.255.0 Dialer1
          ip route 192.168.69.0 255.255.255.0 Dialer0
          !
          !
          ip http server
          ip http access-class 4
          ip http authentication local
          ip http secure-server
          ip nat inside source list 2 interface Dialer0 overload
          ip nat inside source list 3 interface Dialer0 overload
          ip nat inside source static tcp 10.10.10.2 5090 interface Dialer1 5090
          ip nat inside source static tcp 192.168.69.1 25 interface Dialer0 25
          !
          logging trap debugging
          access-list 1 remark INSIDE_IF=FastEthernet0/0
          access-list 1 remark SDM_ACL Category=2
          access-list 1 permit 192.168.69.0 0.0.0.255
          access-list 2 remark SDM_ACL Category=2
          access-list 2 permit 192.168.69.0 0.0.0.255
          access-list 3 remark SDM_ACL Category=2
          access-list 3 permit 10.10.10.0 0.0.0.255
          access-list 4 remark HTTP Access-class list
          access-list 4 remark CCP_ACL Category=1
          access-list 4 permit 10.10.10.0 0.0.0.255
          access-list 4 permit 192.168.69.0 0.0.0.255
          access-list 4 deny any
          dialer-list 1 protocol ip permit
          dialer-list 2 protocol ip permit
          no cdp run
          !
          !
          !
          control-plane
          !
          !
          banner login ^CGo Away !^C
          !
          line con 0
          login authentication local_authen
          transport output telnet
          line aux 0
          login authentication local_authen
          transport output telnet
          line vty 0 4
          authorization exec local_author
          login authentication local_authen
          transport input telnet ssh
          !
          scheduler allocate 20000 1000
          ntp update-calendar
          ntp server 212.159.6.9 source Dialer0 prefer
          end

          Thanks

          Comment


          • #6
            Re: Cisco 1841

            ok, I _Think_ your entries:

            ip route 10.10.10.0 255.255.255.0 Dialer1
            ip route 192.168.69.0 255.255.255.0 Dialer0
            would try and route enties for 10.10.10.0 over dialer1, and 192.168.69.0 over dialer0

            which probably isn't the desired outcome..

            but.. i can't tell you too much more sorry :/
            Please do show your appreciation to those who assist you by leaving Rep Point https://www.petri.com/forums/core/im.../icon_beer.gif

            Comment


            • #7
              Re: Cisco 1841

              Hi
              That is exactly what I am trying to achieve, all 10.10.10.0 traffic over dialer1 and all 192.168.69.0 traffic over dialer0, thanks for trying anyway.

              Comment


              • #8
                Re: Cisco 1841

                Change this:

                ip route 10.10.10.0 255.255.255.0 Dialer1
                ip route 192.168.69.0 255.255.255.0 Dialer0
                To this:
                ip route 10.10.10.0 0.0.0.255 Dialer1
                ip route 192.168.69.0 0.0.0.255 Dialer0
                CCNA, Network+

                Comment


                • #9
                  Re: Cisco 1841

                  I would suggest searching cisco.com for configuration examples using "policy based routing" or PBR. Basically you would define an access-list and route-map. The route-map would match the source/destinaion defined in the ACL. If a match is found, the route-map would then set the outbound interface to the correct dialer interface.

                  I'm going from memory here (no syntax verification or testing), but the changes "might" look something like...

                  NOTE: I have not accounted for any nat'ing or nat exemption that might need to be configured.

                  Code:
                   
                  access-list 100 remark 10.10.10.0/24 netblock to anywhere
                  access-list 100 permit ip 10.10.10.0 0.0.0.255 any
                   
                  access-list 101 remark 192.168.69.0/24 netblock to anywhere
                  access-list 101 permit ip 192.168.69.0 0.0.0.255 any
                   
                  route-map REDIRECT-DATA permit 10
                   match ip addresss 100
                   set interface dialer 1
                   
                  route-map REDIRECT-VOICE permit 10
                   match ip addresss 101
                   set interface dialer 0
                   
                  interface FastEthernet0/1.1
                   ip address 10.10.10.1 255.255.255.0
                   ip policy route-map REDIRECT-DATA
                   
                  interface FastEthernet0/0
                   ip address 192.168.69.253 255.255.255.0
                   ip policy route-map REDIRECT-VOICE

                  Comment


                  • #10
                    Re: Cisco 1841

                    Hi
                    Thanks to everyone for your input, as soon as I get the oppurtunity I will try these suggestions out. I am working away at the moment.

                    Comment

                    Working...
                    X