No announcement yet.

Cisco SPAN question

  • Filter
  • Time
  • Show
Clear All
new posts

  • Cisco SPAN question

    Hi - I am having trouble setting up a SPAN port monitor on my Cisco 871 router.

    I have a DSL modem connected to the WAN port, which is FastEthernet4.

    Of course to set up authentication for my DSL modem, a "Dialer0" interface was also created. I am assigned a dynamic IP from AT&T, and I use "IP negotiated".

    What I want to do is monitor all traffic coming into my router - I guess it would be into FastEthernet4 or Dialer0.

    But when I enter "monitor session 1 source interface FastEthernet4", the cli won't accept it. I also tried to use "Dialer0" instead of Fa4, but the same thing happens.

    I tried creating a destination port first, but it didnt make a difference.

    Everything worked fine, however, when I tried using "Vlan1" or FastEthernet3 for the source.

    So does anybody know what I am doing wrong? I can't imagine that SPAN wont work for the WAN interface. I can use SPAN to monitor my WAN interface on my ASA5505. Somehow I seem to recall having this issue several years ago - and IIRC I think I found a solution, but I cant remember now if or how I was able to solve it. Somehow I think it involved the syntax of how I was typing in the command....but I may be wrong.

    I have searched high and low on the net and at but cannot find an answer to my question.

    I know that I can accomplish the same thing with a hub or a passive ethernet tap....but I would prefer to use SPAN if possible.

    Thank you in advance for any help that you can provide.

    Take care,

  • #2
    Re: Cisco SPAN question

    Hello Mike,
    I saw your question posted on the Cisco fourm, and also saw the answer provided by the Cisco 'Ask The Expert'. Also saw the other response and the results of your research.
    Briefly for those on this forum, the reason it does not work is that the WAN port is not considered part of the level 2 switch on the 871, and SPAN only works with L2 switch ports.

    But I am interested in how you got it to work using the 'Vlan1' as the source.
    I have tried this on my 1811, but the cli will not accept it.

    Can you elaborate on how you suceeded when using 'vlan1'?

    I'm using image 12.4(22)T5 Advanced IP Servces.