Announcement

Collapse
No announcement yet.

connection between two vlans on same router

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • connection between two vlans on same router

    hi,
    my problem is this:
    we have two 2811 router with configured interfaces:
    Router1
    interface FastEthernet0/0.380
    encapsulation dot1Q 380
    ip address 192.168.232.18 255.255.255.248
    no snmp trap link-status
    crypto map clientmap
    !
    interface FastEthernet0/0.382
    encapsulation dot1Q 382
    ip address 10.132.1.126 255.255.255.252
    no snmp trap link-status

    interface Vlan1
    ip address 192.168.5.1 255.255.255.128
    ip nat inside
    ip virtual-reassembly

    ip route 0.0.0.0 0.0.0.0 192.168.232.17
    ip route 10.132.254.35 255.255.255.255 10.132.1.125

    Router2
    interface FastEthernet0/0.197
    encapsulation dot1Q 197
    ip address 192.168.222.2 255.255.255.248
    ip nat inside
    ip virtual-reassembly
    no cdp enable

    interface Vlan1
    ip address 192.168.1.1 255.255.255.128
    ip nat inside
    ip virtual-reassembly
    ip tcp adjust-mss 1452

    ip route 0.0.0.0 0.0.0.0 192.168.222.1

    so my case is:computer from router1's network can ping 192.168.222.2 (router2 -FastEthernet0/0.197 )
    computer from router2 network can ping 192.168.232.18 (router1- FastEthernet0/0.380),but can't ping 10.132.1.126 (router1- FastEthernet0/0.382)
    How can i connect vlan 380 and vlan382, so traffic intended to vlan 382 to pass through vlan380. I want the three vlan to see each other.Is this happen with IRB or not?
    TNX

  • #2
    Re: connection between two vlans on same router

    Based on the posted config snippits, both router1 and router2 are interconnected via a gateway or gateways (you have not shown the gateway(s) configuration), I would think the gateway device that used by router2 (192.168.222.1) does not know how to route to network 10.132.1.124/30.

    If you are using a routing protocol like OSPF, EIGRP, etc... add the 10.132.1.124/30 network on router1 so that its announced to the gateways and eventually added by router2 or add a static route to this network on the gateway device 192.168.222.1.

    Comment

    Working...
    X