Announcement

Collapse
No announcement yet.

How to configure Remote Desktop Connection on Cisco 2811 Router

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • How to configure Remote Desktop Connection on Cisco 2811 Router

    Hi all,

    Am new to this forum and wish to extend my warm regards to all of you.


    Kindly I need assistance in tackling these problems.

    1) Allowing Remote desktop connection in cisco router 2811 to windows 2003 server.

    2) When browsing on the internet am experiencing TTL Expired on Transit on some websites using the cisco router configs below.

    3) I need to share the internet from this Cisco 2811 router to another Cisco 1841 router in our office connected through serial interface that has point to point connection only.

    How do tackle remote desktop connection?

    Can anyone assist in pointing out the issues with TTL expiring on transit?

    How do I share the internet?

    The following is my configurations

    Building configuration...

    Current configuration : 2133 bytes
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    service sequence-numbers
    !
    hostname xxxxxxx
    !
    boot-start-marker
    boot-end-marker
    !
    logging message-counter syslog
    enable secret xxxxxxxxxxxxxxxxxxxxxx
    !
    no aaa new-model
    clock timezone PCTime 3
    !
    dot11 syslog
    ip source-route
    !
    !
    ip cef
    !
    !
    ip name-server 41.x.x.x
    ip name-server 41.x.x.x
    multilink bundle-name authenticated
    !
    vpdn enable
    !
    !
    !
    !
    !
    !
    username xxxxx privilege 15 password xxxxxxxxxxxx
    archive
    log config
    hidekeys
    !
    !
    !
    !
    !
    interface FastEthernet0/0
    ip address 10.x.x.x 255.x.x.x
    no ip unreachables
    ip nat inside
    ip virtual-reassembly
    no ip mroute-cache
    duplex auto
    speed auto
    no cdp enable
    !
    interface FastEthernet0/1
    description $ES_LAN$
    no ip address
    no ip unreachables
    no ip mroute-cache
    duplex auto
    speed auto
    pppoe enable
    pppoe-client dial-pool-number 1
    no cdp enable
    !
    interface Serial0/0/0
    ip address 192.x.x.x 255.x.x.252
    ip nat outside
    ip virtual-reassembly
    encapsulation ppp
    !
    interface Serial0/0/1
    no ip address
    shutdown
    clock rate 2000000
    !
    interface Dialer1
    ip address negotiated
    no ip unreachables
    ip mtu 1492
    ip nat outside
    ip virtual-reassembly
    encapsulation ppp
    ip tcp adjust-mss 1452
    no ip mroute-cache
    dialer pool 1
    dialer-group 1
    no cdp enable
    ppp authentication chap pap callin
    ppp chap hostname xxxxxxx
    ppp chap password xxxxxxxxxxxxxx
    ppp pap sent-username xxxxxx password xxxxxxxxxxxx
    ppp ipcp dns request accept
    ppp ipcp route default
    ppp ipcp address accept
    !
    ip forward-protocol nd
    ip route 0.0.0.0 0.0.0.0 Serial0/0/0
    !
    no ip http server
    ip http authentication local
    no ip http secure-server
    !
    ip nat inside source list 10 interface Dialer1 overload
    ip nat inside source list 101 interface Serial0/0/0 overload
    !
    ip access-list extended afr_accesslist
    !
    access-list 10 permit 10.x.x.x x.x.x.255
    dialer-list 1 protocol ip permit
    no cdp run

    !
    !
    control-plane
    !
    !
    line con 0
    line aux 0
    line vty 0 4
    password xxxxxxxxxxxxxxxxxxxxxx
    login
    !
    scheduler allocate 20000 1000
    end

    Thank you in advance!

  • #2
    Re: How to configure Remote Desktop Connection on Cisco 2811 Router

    Remote Desktop is not the most secure way to connect, but you basically need a NAT rule for the server IP and open up a port for it. Unless you want 8 zillion hack attempts per month, configure it to use some random port number other than the default.

    Comment


    • #3
      Re: How to configure Remote Desktop Connection on Cisco 2811 Router

      Hi picofly >2) When browsing on the internet am experiencing TTL Expired on Transit on some websites using the cisco router configs below. Can you please provide a screen shot when things are working and when they are aren't (ttl expired)? You may have some kind of routing issue because the "TTL Expired on Transit" means your router couldn't forward the packet because the TTL is set to 1. When that happens the router will decrement the TTL to 0 and send an ICMP message back to the sender. > 3) I need to share the internet from this Cisco 2811 router to another Cisco 1841 router in our office connected through serial interface that has point to point connection only. Are you trying to have a redundant setup? A network diagram and further explanation on point 3. Ryan

      Comment


      • #4
        Re: How to configure Remote Desktop Connection on Cisco 2811 Router

        * 1 Open your browser window and type the IP address of the router in your address bar. This opens a window for the username and password needed for access to configure the router.

        * 2 Click the "Applications and Gaming" tab on the opening screen. This opens a window with a list of ports of which you can open for access on your network.

        * 3 Type "Remote Desktop" in the application textbox.

        * 4 Enter "3389" in the "Start" and "Stop" port ranges. This port number is specific to the remote desktop application.

        * 5 Leave the value of "Both" in the protocol listbox.

        * 6 Type the IP address of the internal machine on your network. The IP address is the machine running remote desktop. When traffic from the Internet reaches the router, it forwards the request to this IP address.

        * 7 Check the "Enabled" checkbox and click "Save Settings."

        * 8 Close the browser window.

        Comment

        Working...
        X