Announcement

Collapse
No announcement yet.

Problem with SLA dual ISP failover

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem with SLA dual ISP failover

    hi There

    I am trying to set up an 1841 with dual ISP failover however it seems not to be working correctly and Im a bit stuck as to why. With a route in place of "ip route 0.0.0.0 0.0.0.0 xxx.xxx.xxx.xxx" all works fine, as soon as I delete that and add "ip route 0.0.0.0 0.0.0.0 xxx.xxx.xxx.xxx track 1" everything goes down and I am unable to ping 4.2.2.2 from int f0/0. I must be setting up the IP SLA incorectly ???? thanks in advance for any help. here is my config:-

    ip sla monitor 1
    type echo protocol ipIcmpEcho 4.2.2.2 source-interface FastEthernet0/0
    timeout 500
    frequency 10
    ip sla monitor schedule 1 life forever start-time now
    !
    !

    !
    !
    track 1 rtr 1 reachability
    !
    !
    !
    !
    interface FastEthernet0/0
    description WAN1
    ip address xxx.xxx.xxx.xxx 255.255.255.248
    ip nat outside
    ip virtual-reassembly
    duplex auto
    speed auto
    !
    interface FastEthernet0/1
    description WAN2
    ip address yyy.yyy.yyy.yyy 255.255.255.252
    ip nat outside
    ip virtual-reassembly
    speed 100
    full-duplex
    !
    interface FastEthernet0/0/0
    duplex full
    speed 100
    !
    interface FastEthernet0/0/1
    !
    interface FastEthernet0/0/2
    !
    interface FastEthernet0/0/3
    !
    interface Vlan1
    description LAN
    ip address aaa.aaa.aaa.aaa 255.255.255.0
    ip nat inside
    ip virtual-reassembly
    !
    ip route 0.0.0.0 0.0.0.0 xxx.xxx.xxx.25 track 1
    ip route 0.0.0.0 0.0.0.0 yyy.yyy.yyy.37 10
    !
    !
    ip http server
    ip http authentication local
    ip http secure-server
    ip http secure-port 4443
    ip http timeout-policy idle 60 life 86400 requests 10000
    ip nat inside source list 1 interface FastEthernet0/0 overload
    ip nat inside source list 2 interface FastEthernet0/1 overload

    access-list 1 remark SDM_ACL Category=2
    access-list 1 permit aaa.aaa.aaa.aaa 0.0.0.255
    access-list 2 remark Internet access list 2
    access-list 2 permit aaa.aaa.aaa.aaa 0.0.0.255
    access-list 60 permit aaa.aaa.aaa.53

    !
    !
    !
    control-plane
    !
    !

    !
    line con 0
    password 7 2041212312312321321313123112
    line aux 0
    line vty 0 4
    password 7 02161232312313213123
    login local
    rotary 1
    transport preferred ssh
    transport input telnet
    line vty 5
    password 7 123123123123123
    login local





    Gordon

  • #2
    Re: Problem with SLA dual ISP failover

    I could be wrong, but you seem to only have IP SLA 1
    but you may need IP SLA 2 as well, else it has nothing to fail over to
    Please do show your appreciation to those who assist you by leaving Rep Point https://www.petri.com/forums/core/im.../icon_beer.gif

    Comment


    • #3
      Re: Problem with SLA dual ISP failover

      thanks for the reply. That wasn't the problem, changed the NATing slightly and works great now.

      Comment

      Working...
      X