Announcement

Collapse
No announcement yet.

Question: Wake on Lan

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Question: Wake on Lan

    hey, i have a question about wake on lan:

    i only use cisco layer 2 switch and i tried Wake on lan but nothing happends so i searched and the result was that you only can use a cisco layer 3 switch to configure Wake on lan.

    is this true? im a little bit a noob about the cisco stuff

  • #2
    Re: Question: Wake on Lan

    Link to your source?

    What are you using to WOL and what are you doing with it?

    Certainly works fine for me on L2 switches, albeit not from Cisco but I'd be very surprised if their switches block WOL traffic.
    Gareth Howells

    BSc (Hons), MBCS, MCP, MCDST, ICCE

    Any advice is given in good faith and without warranty.

    Please give reputation points if somebody has helped you.

    "For by now I could have stretched out my hand and struck you and your people with a plague that would have wiped you off the Earth." (Exodus 9:15) - I could kill you with my thumb.

    "Everything that lives and moves will be food for you." (Genesis 9:3) - For every animal you don't eat, I'm going to eat three.

    Comment


    • #3
      Re: Question: Wake on Lan

      Cisco switches do support wol traffic on layer 2 switches by default. On layers 3 switches you need to configure ip directed broadcast to let the wol traffic route between subnets.
      gerth

      MCITP sa, ea & va, [email protected]

      Comment


      • #4
        Re: Question: Wake on Lan

        The "magic packet" initiates the wake-on process. It is broadcast, a L2 specific packet so it should work in any subnet despite of the involved L2 switches .
        Configuring inter subnets WOL requires the Subnet Distribution Broadcast to work properly.
        More about this on: http://en.wikipedia.org/wiki/Wake-on-LAN

        Make sure that your motherboard and NIC support WOL.
        Br,
        Csaba
        Regards,
        Csaba Papp
        MCSA+messaging, MCSE, CCNA
        ...............................
        Remember to give credit where credit is due and leave reputation points where appropriate
        .................................

        Comment


        • #5
          Re: Question: Wake on Lan

          Sorry for the late reply...

          I use different tools like mc-wol.exe, fog(multicast software that can wake on lan), free wake on lan tool,.... but they al work if my desktop is connected to the other desktop with a ethernet cable

          example: desktop-----------------cable--------------desktop

          this works perfectly to wake on lan the other desktop

          but when i do it with a cisco catalyst layer 2 switch, its like nothing happends...

          i think that the switches blocks by default the wol packet.

          im doing it for bc it's a project that i have to wake on lan all the desktops from my work and putting a multicast image to it.

          if there are configuration to settle on the cisco layer 2 switch, where can i find it because i couldn't found it....

          Comment


          • #6
            Re: Question: Wake on Lan

            Have you tested the WOL with a simple non-managed switch? Can you post a running config of the cisco switch (without sensitive information)
            gerth

            MCITP sa, ea & va, [email protected]

            Comment


            • #7
              Re: Question: Wake on Lan

              if i tested with a non managed switch: No we only have cisco switches to test on it

              and the configuration (I actually didnt configure anything on the switch) because i dont know what i should configure on the cisco layer 2 switch:



              !
              version 12.2
              no service pad
              service timestamps debug uptime
              service timestamps log uptime
              no service password-encryption
              !
              hostname Switch
              !
              !
              no aaa new-model
              ip subnet-zero
              !
              !
              !
              !
              no file verify auto
              spanning-tree mode pvst
              spanning-tree extend system-id
              !
              vlan internal allocation policy ascending
              !
              interface FastEthernet0/1

              !
              interface FastEthernet0/2

              !
              interface FastEthernet0/3

              !
              interface FastEthernet0/4

              !
              interface FastEthernet0/5

              !
              interface FastEthernet0/6

              !
              interface FastEthernet0/7

              !
              interface FastEthernet0/8

              !
              interface FastEthernet0/9

              !
              interface FastEthernet0/10

              !
              interface FastEthernet0/11

              !
              interface FastEthernet0/12

              !
              interface FastEthernet0/13

              !
              interface FastEthernet0/14

              !
              interface FastEthernet0/15

              !
              interface FastEthernet0/16

              !
              interface FastEthernet0/17

              !
              interface FastEthernet0/18

              !
              interface FastEthernet0/19

              !
              interface FastEthernet0/20

              !
              interface FastEthernet0/21

              !
              interface FastEthernet0/22

              !
              interface FastEthernet0/23

              !
              interface FastEthernet0/24

              !
              interface GigabitEthernet0/1
              !
              interface GigabitEthernet0/2

              !
              interface Vlan1
              no ip address
              no ip route-cache
              !

              ip http server
              !
              control-plane
              !
              !
              line con 0
              line vty 0 4
              no login
              line vty 5 15
              no login
              !
              end

              Comment


              • #8
                Re: Question: Wake on Lan

                Configure a vlan on the switch and test the WoL within this segment

                conf t
                vlan 10
                name WOL
                exit
                int range fa0/1 - 5
                switchport access vlan 10
                no shut
                end
                wr m

                The above command lines configure a vlan on your switch and add the first 5 ports member to it. Connect your testing environment to these ports and try WoL

                Br,
                Csaba
                Regards,
                Csaba Papp
                MCSA+messaging, MCSE, CCNA
                ...............................
                Remember to give credit where credit is due and leave reputation points where appropriate
                .................................

                Comment

                Working...
                X