Announcement

Collapse
No announcement yet.

Cisco 857 config help

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cisco 857 config help

    Hello,

    I have a Cisco 857 ADSL router which i am currently trying to setup for my UK internet provider BeThere (which is similar to O2). We currently use a Speedtouch router and would like to move over to the Cisco.

    This current config allocates IP addresses to computers plugged in to the ethernet ports, but i cannot get any internet connection. I can login to the router using a serial terminal connection, and connect through the SDM gui.

    When connected to the phone line none of the ADSL lights light up at all (CD/RXD/TXD).

    I have a single static IP address (which i have replaced as 11.11.11.11 in the config example)
    Bethere uses:
    VPI=0
    VCI=101
    RFC1483 Routing with AAL5SNAP encapsulation

    Here is the info of the router:
    Cisco IOS Software - (C850-ADVSECURITYK9-M), Version 12.4(15)T7
    ROM: System Bootstrap Version 12.3(8r)YI4,
    System image file is "flash:c850-advsecurityk9-mz.124-15.T7.bin"

    Any help getting this up and running would be great.

    Here is the current config:

    Code:
    version 12.4
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    hostname Cisco857
    boot-start-marker
    boot-end-marker
    logging buffered 51200 warnings
    no aaa new-model
    dot11 syslog
    !
    no ip dhcp use vrf connected
    ip dhcp excluded-address 192.168.1.254
    ip dhcp excluded-address 192.168.1.10 192.168.1.100
    ip dhcp pool sdm-pool
    import all
    network 192.168.1.0 255.255.255.0
    default-router 192.168.1.254
    dns-server 87.194.255.154 87.194.255.155
    lease 0 2
    ip cef
    ip domain name LocalDomain
    ip name-server 87.194.255.154
    ip name-server 87.194.255.155
    !
    username admin privilege 15 secret 0 password
    archive
    log config
    hidekeys
    !
    interface ATM0
    no ip address
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    no atm ilmi-keepalive
    dsl enable-training-log
    !
    interface ATM0.1 point-to-point
    description LinktoBe
    ip address 11.11.11.11 255.255.248.0
    ip pim sparse-dense-mode
    ip nat outside
    ip virtual-reassembly
    atm route-bridged ip
    pvc 0/101
    oam-pvc manage
    encapsulation aal5snap
    !
    interface FastEthernet0
    interface FastEthernet1
    interface FastEthernet2
    interface FastEthernet3
    !
    interface Vlan1
    description Vlan1
    ip address 192.168.1.254 255.255.255.0
    ip nat inside
    ip virtual-reassembly
    ip tcp adjust-mss 1452
    !
    ip forward-protocol nd
    ip route 0.0.0.0 0.0.0.0 11.11.11.11
    ip http server
    ip http access-class 23
    ip http authentication local
    ip http secure-server
    ip http timeout-policy idle 60 life 86400 requests 10000
    ip nat inside source list 100 interface ATM0.1 overload
    !
    access-list 100 remark SDM_ACL Category=2
    access-list 100 permit ip 192.168.1.0 0.0.0.255 any
    no cdp run
    control-plane
    line con 0
    login local
    no modem enable
    line aux 0
    line vty 0 4
    access-class 23 in
    privilege level 15
    login local
    transport input telnet ssh
    !
    scheduler max-task-time 5000
    Many thanks
    Last edited by caterhamvc; 24th March 2011, 13:57.

  • #2
    Re: Cisco 857 config help

    could you post output of show dsl please ?\

    I also suspect, for ADSL, you may need a dialer0 interface... ?
    Please do show your appreciation to those who assist you by leaving Rep Point https://www.petri.com/forums/core/im.../icon_beer.gif

    Comment


    • #3
      Re: Cisco 857 config help

      Code:
      Cisco857#show dsl
      % Incomplete command.
      so i tried this...

      Code:
      Cisco857#show dsl interface
      ATM0
      Alcatel 20190 chipset information
      
      Line has not yet been activated.
      
      Modem Status:    Down (DMTDSL_STOP)
      DSL Mode:        Unknown
      Interrupts:      4124 (0 spurious)
      PHY Access Err:  0
      Activations:     0
      LED Status:      OFF
      LED On Time:     500
      LED Off Time:    500
      Init FW:         init_AMR-3.0.014_no_bist.bin
      Operation FW:    AMR-3.0.014.bin
      FW Source:       embedded
      
      Training log enabled, but not collected yet. Because
      there have been no state transitions since log was enabled.
      You can force a state transition through shut/no shut.
      If shut/no shut is already done, please wait for few seconds
      for the transition to take place and retry "show dsl"
      I think you may be right about needing a dialer, i copied most of the this from another config (search google for cisco 877 bethere static and its the first result) which does not have a dialer section so i may be missing something important!.

      What is the best way to create a dialer interface?

      Comment


      • #4
        Re: Cisco 857 config help

        looks like your line isn't activated.
        Do you have another device you can try ?
        Please do show your appreciation to those who assist you by leaving Rep Point https://www.petri.com/forums/core/im.../icon_beer.gif

        Comment


        • #5
          Re: Cisco 857 config help

          Yes, our broadband works fine with our speedtouch router. The cisco is second hand, so i am not sure if it actually works. Would the ADSL lights usually show some signs of life regardless of the config?

          Comment


          • #6
            Re: Cisco 857 config help

            yes - cd should be light up, or at least flashing madly while it tries to train up

            maybe if you can't get the adsl to work, you could put the speedtouch into bridge mode, and use it just as a modem on the cisco router?

            try also,
            conf t
            int dsl
            shut
            no shut
            ^z

            i'm not sure if that'll work though
            Last edited by tehcamel; 24th March 2011, 21:14.
            Please do show your appreciation to those who assist you by leaving Rep Point https://www.petri.com/forums/core/im.../icon_beer.gif

            Comment

            Working...
            X