Announcement

Collapse
No announcement yet.

Collisions between 2 switches

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Collisions between 2 switches

    Hi,

    I'm having this issue I cannot seem to resolve by my own. Here's the deal. All equipment is Cisco unless stated...

    My ISP supplied me a FO Internet connection via a L3 switch. Port 1 connects to their equipment and Port 2, to mine. After calling the ISP, Port 2 is set at 10/Full.

    Port 2 of the ISP switches connect to my switch port 18. Settings are auto/auto because anything else disables to the port.

    a lot of collsions occur between these 2 ports, about 10% packet loss..I tried a regular patch cable and now, a crossover is connected in between as suggested by the ISP technician



    here's the rest of the port's config

    interface GigabitEthernet0/18
    description VIDEO-RT-V254
    switchport access vlan 1101
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 254
    switchport mode access
    macro description cisco-switch
    auto qos voip trust
    spanning-tree link-type point-to-point


    they are 2 other port on that switch which are on VLAN 254 as it splits the Internet between 2 devices (a cisco 1811w and a fortinet 200a).

    here's the port 22 that goes to fortinet

    interface GigabitEthernet0/22
    description FORTI-14-V254
    switchport access vlan 254
    switchport mode access

    and port 21 that goes to the router (not really a pix btw)

    interface GigabitEthernet0/21
    description VIDEO-PIX-FE0-V254
    switchport access vlan 254
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 254
    switchport mode trunk
    switchport nonegotiate



    any ideas?

  • #2
    Re: Collisions between 2 switches

    Collisions are always caused by a duplex mismatch. One port is communicating full-duplex and the other is communicating half-duplex, hence the collisions. You need to check the ports on both sides of the link and see what the duplex settings are. If they've been negotiated on both ends confirm that they've both negotiated either half-duplex or full-duplex. If either of the links is a GB port then it should be full-duplex and GB doesn't use half-duplex. Also confirm the negotiated speed on both ends of the link. Also, make sure both sides are configured the same, either hard-coded or auto-negotiate but not one of each.

    Comment


    • #3
      Re: Collisions between 2 switches

      If ISP set the port to 10/full, then I would try on the Cisco side

      speed 10
      duplex full

      Try with both the normal, and the cross-over cable.
      gerth

      MCITP sa, ea & va, [email protected]

      Comment


      • #4
        Re: Collisions between 2 switches

        setting the port at 10/full on the switch put the port in disabled mode.

        I downloaded Cisco Network Assistant and found the solution when playing with the port's settings

        There's a option called Port Fast : enabled when static access
        It added the 2 lines to the config of the port

        no mdix auto
        spanning-tree portfast

        after that, I got to set the speed and duplex to 10/full


        case closed!

        Comment


        • #5
          Re: Collisions between 2 switches

          Portfast has to do with the network loop detection. All access ports on a Cisco switch are usually configured with the portfast setting. Trunk ports without portfast. But if you connect the trunk port to a host, you configure portfast trunk

          Good to here you found the solution.
          gerth

          MCITP sa, ea & va, [email protected]

          Comment

          Working...
          X