Announcement

Collapse
No announcement yet.

I can't ping to internet from router

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • I can't ping to internet from router

    Hello,

    I could ping from my router to pc and from pc to router.
    But i can't ping from any device to internet

    Here is my sh run

    Current configuration : 1532 bytes
    !
    version 12.2
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname DOTO-R1
    !
    enable secret 5 $1$pgGu$0NZyoHuybx5Xy74gxKEiS1
    !
    ip subnet-zero
    !
    !
    ip dhcp excluded-address 192.168.50.1 192.168.50.99
    ip dhcp excluded-address 192.168.50.200 192.168.50.254
    ip dhcp excluded-address 192.168.51.1 192.168.51.99
    ip dhcp excluded-address 192.168.51.200 192.168.51.254
    !
    ip dhcp pool 192.168.51.0/24
    network 192.168.51.0 255.255.255.0
    default-router 192.168.51.1
    !
    ip dhcp pool 192.168.50.1/24
    network 192.168.50.0 255.255.255.0
    default-router 192.168.50.1
    !
    !
    controller E1 0/0
    !
    !
    !
    interface FastEthernet0/0
    ip address 192.168.1.2 255.255.255.0
    ip nat outside
    duplex auto
    speed auto
    !
    interface FastEthernet0/1
    description SERVERS
    ip address 192.168.52.1 255.255.255.0
    duplex auto
    speed auto
    !
    interface Ethernet1/0
    description DOTO
    ip address 192.168.50.1 255.255.255.0
    full-duplex
    !
    interface Ethernet1/1
    description JH KADEE
    ip address 192.168.53.1 255.255.255.252
    full-duplex
    !
    interface Ethernet1/2
    description WIFI
    ip address 192.168.51.1 255.255.255.0
    full-duplex
    !
    interface Ethernet1/3
    description full access
    ip address 192.168.54.1 255.255.255.252
    half-duplex
    !
    router rip
    network 192.168.50.0
    network 192.168.51.0
    network 192.168.52.0
    network 192.168.53.0
    network 192.168.54.0
    !
    ip default-gateway 192.168.1.1
    ip classless
    ip route 0.0.0.0 0.0.0.0 FastEthernet0/0
    no ip http server
    !
    !
    line con 0
    line aux 0
    line vty 0 4
    login
    !
    end

    The route is connected to a linksys router

    my sh ip route is:
    DOTO-R1#sh ip route
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
    i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
    * - candidate default, U - per-user static route, o - ODR
    P - periodic downloaded static route

    Gateway of last resort is 0.0.0.0 to network 0.0.0.0

    C 192.168.1.0/24 is directly connected, FastEthernet0/0
    S* 0.0.0.0/0 is directly connected, FastEthernet0/0
    DOTO-R1#

    thx

  • #2
    Re: I can't ping to internet from router

    Gateway of last resort is 0.0.0.0 to network 0.0.0.0

    Suggests to me you aren't properly routing to a default gateway
    Please do show your appreciation to those who assist you by leaving Rep Point https://www.petri.com/forums/core/im.../icon_beer.gif

    Comment


    • #3
      Re: I can't ping to internet from router

      i(ve tried to type the commands

      ip route 0.0.0.0 0.0.0.0 Fa0/0 (correct? )

      so normaly if the router don't know where is the network, ho will send it to Fa0/0
      In my case is this the linksys router that is connected to the internet.
      with ip address 192.168.1.1

      do you know what's the wright command?

      Comment


      • #4
        Re: I can't ping to internet from router

        If your design goal is to have this router NAT prior to the Linksys device (which is also going to NAT), then your configuration is missing a couple of key entries

        1) You have "ip nat outside" on the interface that connects to the Linksys device (f0/0), but you do NOT have the corresponding "ip nat inside" on the other interfaces.

        2) Add the PAT/overload statement necessary to define which networks to NAT.

        Something like:
        Code:
        int f0/1
         ip nat inside
         
        int e1/0
         ip nat inside
         
        int e1/1
         ip nat inside
         
        int e1/2
         ip nat inside
         
        int e1/3
         ip nat inside
         
        int e1/4
         ip nat inside
         
        ip access-list extended NAT-2-INTERNET
        remark Define the internal netblocks to be NAT'd (permit) to Internet
        permit ip 192.168.50.0 0.0.0.255 any
        permit ip 192.168.51.0 0.0.0.255 any
        permit ip 192.168.52.0 0.0.0.255 any
        permit ip 192.168.53.0 0.0.0.255 any
        permit ip 192.168.54.0 0.0.0.255 any
         
        ip nat inside source list NAT-2-INTERNET interface FastEthernet0/0 overload
        If your default gateway IP is static (Linksys), then I would suggest specifying it in your configuration instead of specifying the interface. Also, the "ip default-gateway" command is useless when routing is enabled. I would remove it from the configuration.
        Code:
        no ip default-gateway f0/0
        no ip route 0.0.0.0 0.0.0.0 f0/0
        ip route 0.0.0.0 0.0.0.0 192.168.1.1

        Comment


        • #5
          Re: I can't ping to internet from router

          Hello,

          I can't ping from the 192.168.50.0/24 network on Cisco Router 1. The router is connected with network 192.168.1.0 to a linksys router.
          I also can't ping from the linksys router to a IP address that is connected to the cisco router.

          sh run output
          ---------------------------------------------------------------------
          Version:1.0StartHTML:0000000168EndHTML:0000005892S tartFragment:0000000468EndFragment:0000005875
          DOTO-R1#sh run
          Building configuration...

          Current configuration : 1853 bytes
          !
          ! Last configuration change at 20:29:20UTC Tue Feb 1 2011
          !
          version 12.2
          service timestamps debug uptime
          service timestamps log uptime
          no service password-encryption
          !
          hostname DOTO-R1
          !
          enable secret 5$1$pgGu$0NZyoHuybx5Xy74gxKEiS1
          !
          ip subnet-zero
          ip host-routing
          !
          !
          ip dhcp excluded-address 192.168.50.1192.168.50.99
          ip dhcp excluded-address 192.168.50.200192.168.50.254
          ip dhcp excluded-address 192.168.51.1192.168.51.99
          ip dhcp excluded-address 192.168.51.200192.168.51.254
          !
          ip dhcp pool 192.168.51.0/24
          network 192.168.51.0 255.255.255.0
          default-router 192.168.51.1
          !
          ip dhcp pool 192.168.50.1/24
          network 192.168.50.0 255.255.255.0
          default-router 192.168.50.1
          !
          !
          controller E1 0/0
          !
          !
          !
          interface FastEthernet0/0
          ip address 192.168.1.2 255.255.255.0
          duplex auto
          speed auto
          !
          interface FastEthernet0/1
          description SERVERS
          ip address 192.168.52.1 255.255.255.0
          duplex auto
          speed auto
          !
          interface Ethernet1/0
          description DOTO
          ip address 192.168.50.1 255.255.255.0
          full-duplex
          !
          interface Ethernet1/1
          description JH KADEE
          ip address 192.168.53.1255.255.255.252
          full-duplex
          !
          interface Ethernet1/2
          description WIFI
          ip address 192.168.51.1 255.255.255.0
          full-duplex
          !
          interface Ethernet1/3
          description full access
          ip address 192.168.54.1255.255.255.252
          half-duplex
          !
          router rip
          network 192.168.50.0
          network 192.168.51.0
          network 192.168.52.0
          network 192.168.53.0
          network 192.168.54.0
          !
          ip classless
          ip route 0.0.0.0 0.0.0.0 192.168.1.1
          ip http server
          !
          !
          ip access-list extended WAN
          permit ip 192.168.50.0 0.0.0.255 any
          permit ip 192.168.51.0 0.0.0.255 any
          permit ip 192.168.52.0 0.0.0.255 any
          permit ip 192.168.53.0 0.0.0.255 any
          permit ip 192.168.54.0 0.0.0.255 any
          permit ip any any
          !
          line con 0
          line aux 0
          line vty 0 3
          password dodentocht
          login
          line vty 4
          password Appel.Sap
          login
          !
          end
          --------------------------------------------------------------------------------------------------------------
          SH IP INTERF BRIEF
          -------------------------------------------------------------------------------------------------------------
          Version:1.0StartHTML:0000000168EndHTML:0000001611S tartFragment:0000000468EndFragment:0000001594
          DOTO-R1#sh ip interf br
          Interface IP-Address OK? Method Status Prot
          ocol
          FastEthernet0/0 192.168.1.2 YES NVRAM up up

          FastEthernet0/1 192.168.52.1 YES NVRAM up down

          Ethernet1/0 192.168.50.1 YES NVRAM up up

          Ethernet1/1 192.168.53.1 YES NVRAM up down

          Ethernet1/2 192.168.51.1 YES NVRAM up down

          Ethernet1/3 192.168.54.1 YES NVRAM up down

          ----------------------------------------------------------------------------------------------------------------------------------------------------------
          SH VER
          --------------------------
          Version:1.0StartHTML:0000000168EndHTML:0000002558S tartFragment:0000000468EndFragment:0000002541
          DOTO-R1#sh version
          Cisco Internetwork Operating SystemSoftware
          IOS (tm) C2600 Software (C2600-I-M),Version 12.2(12j), RELEASE SOFTWARE (fc3)
          Copyright (c) 1986-2004 by ciscoSystems, Inc.
          Compiled Fri 04-Jun-04 22:13 by hqluong
          Image text-base: 0x8000808C, data-base:0x809E349C

          ROM: System Bootstrap, Version 12.2(8r)[cmong 8r], RELEASE SOFTWARE (fc1)

          DOTO-R1 uptime is 23 minutes
          System returned to ROM by reload
          System image file is"flash:c2600-i-mz.122-12j.bin"

          cisco 2621XM (MPC860P) processor(revision 0x400) with 125952K/5120K bytes of me
          mory.
          Processor board ID JHY0847K0SX(2553656217)
          M860 processor: part number 5, mask 2
          Channelized E1, Version 1.0.
          Bridging software.
          X.25 software, Version 3.0.0.
          Primary Rate ISDN software, Version1.1.
          4 Ethernet/IEEE 802.3 interface(s)
          2 FastEthernet/IEEE 802.3 interface(s)
          1 Channelized E1/PRI port(s)
          32K bytes of non-volatile configurationmemory.
          32768K bytes of processor board Systemflash (Read/Write)

          Configuration register is 0x2102

          ----------------------------------------
          SH IP ROUTE:


          Version:1.0StartHTML:0000000168EndHTML:0000001701S tartFragment:0000000468EndFragment:0000001684
          DOTO-R1#sh ip route
          Codes: C - connected, S - static, I -IGRP, R - RIP, M - mobile, B - BGP
          D - EIGRP, EX - EIGRP external,O - OSPF, IA - OSPF inter area
          N1 - OSPF NSSA external type 1,N2 - OSPF NSSA external type 2
          E1 - OSPF external type 1, E2 -OSPF external type 2, E - EGP
          i - IS-IS, L1 - IS-IS level-1,L2 - IS-IS level-2, ia - IS-IS inter area
          * - candidate default, U -per-user static route, o - ODR
          P - periodic downloaded staticroute

          Gateway of last resort is 192.168.1.1to network 0.0.0.0

          C 192.168.50.0/24 is directlyconnected, Ethernet1/0
          C 192.168.1.0/24 is directlyconnected, FastEthernet0/0
          S* 0.0.0.0/0 [1/0] via 192.168.1.1

          I have to use a second router to set up PPoE
          After the linksys is the wan.

          Comment

          Working...
          X