Announcement

Collapse
No announcement yet.

Port will not stay up

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Port will not stay up

    Hello

    I have a Cisco Catalyst 3508G-XL-EN, with a firmware of 12.0(5.1)XW Maintenance Interim. I have been able to get it to pass traffic through the GBICs, except for one line. This is an ethernet cable plugged into a WS-G5482 GBIC Transceiver. No matter which port I plug it into, once I put in the no shutdown command the port will go up and then down immediately. Would there be something in the Maintenance Interim that could be stopping this, or is there something else I need to do to make the port stay up.

  • #2
    Have you looked at Spanning Tree status? It could be that this ethernet port is involved in a logical loop, and the Spanning Tree protocol is doing what it's supposed to-shut the port down to prevent a broadcast storm.
    *RicklesP*
    MSCA (2003/XP), Security+, CCNA

    ** Remember: credit where credit is due, and reputation points as appropriate **

    Comment


    • #3
      Sorry for not replying to your message, I did not get an email notifying me. The problem appears to be caused by the fact the firmware is a Maintenance Interim type, and not a released version. I have setup another 3508G, which has release firmware, and the port works with the WS-G5482 adapter. My new problem is that a VM that tries to connect to the internet through the switch cannot, (the other VMs using the switch can access the internet). I believe that a VLAN is being blocked, but when I do a sh spanning-tree summary, both the old switch and the new one have the VLAN as blocked. The VM had no problem getting to the internet on the old switch. Is there something else I can check to see where the VLAN is stopping?

      Comment


      • #4
        Is this VM on a different VLAN than the others? Is anything else on that same VLAN having any issues? Can any other devices connect to this problem VM from their VLANs? A diagram of how your networking is set up would help. Don't worry about '...too much detail...', more is usually better if you're not sure.
        *RicklesP*
        MSCA (2003/XP), Security+, CCNA

        ** Remember: credit where credit is due, and reputation points as appropriate **

        Comment


        • #5
          I'll get you a diagram, but the VM is on its own VLAN. The other VMs on the server are on different VLANs, but not having the same issue (or any). No other device can connect to the VM, but it can be pinged from a network monitoring device.

          Comment


          • #6
            Does your router have an address in the same VLAN? If not, where is the default gateway address that's in this VM's NIC? It sounds like you're missing something with respect to routing in & out of that VLAN.
            *RicklesP*
            MSCA (2003/XP), Security+, CCNA

            ** Remember: credit where credit is due, and reputation points as appropriate **

            Comment


            • #7
              The gateway on the VM NIC is in the router. The interesting thing is, that when I put the cables back onto the old original switch, the problem goes away. I have checked to make sure the config of both switches is the same. There must be something buried deep that is causing the problem.

              Comment


              • #8
                Here is the diagram.
                Attached Files

                Comment


                • #9
                  Silly question-do you have all the vlans defined in the new switch? Log into the switch and issue 'sh vlans'. If VLAN 140 is defined in the local VLAN table you should see it listed. Assuming you have the VM's NIC set with VLAN tagging for 140, the switch won't know what to do with that packet if it doesn't know about that VLAN number in it's own database.
                  *RicklesP*
                  MSCA (2003/XP), Security+, CCNA

                  ** Remember: credit where credit is due, and reputation points as appropriate **

                  Comment


                  • #10
                    Yes, the sh vlans does have the VLAN 140 in it.

                    Comment


                    • #11
                      Re-reading these posts while looking at your drawing, I have to assume that the switch is doing the inter-vlan routing, or is there a router device that's not in the drawing? Where's the link to the Internet? With respect to the old switch working vs the new switch not, if the switches aren't the routing point, then there's a link to the router as well as the trunk to the HyperVisor. If plugging that trunk into the switch is what forces VLAN 140 to be blocked, there's some sort of loop involved. Still assuming the router is something else, let's try this:
                      *-unplug the hyper-v trunk from the switch
                      *-unplug the link to the router/internet access
                      *-plug the hyper-v trunk into the switch
                      *-check status of VLAN 140

                      If the VLAN stays unblocked, the problem is some setting conflict between the new switch and the router. While it's all in this config, yes your internet will be unavailable. But if the VLAN isn't blocked, then now you have something concrete to check up on. But you also admit in your second post that both switches show that VLAN as blocked, even tho with the old switch, the VM in that VLAN can reach the I'net. Something is definitely weird, here. Can you post the switch configs here?
                      *RicklesP*
                      MSCA (2003/XP), Security+, CCNA

                      ** Remember: credit where credit is due, and reputation points as appropriate **

                      Comment


                      • #12
                        This is the original switch config:

                        clock timezone EST -5
                        clock summer-time EDT recurring
                        !
                        no spanning-tree vlan 255
                        no spanning-tree vlan 147
                        no spanning-tree vlan 401
                        no spanning-tree vlan 402
                        no spanning-tree vlan 501
                        no spanning-tree vlan 502
                        no spanning-tree vlan 503
                        no spanning-tree vlan 603
                        no spanning-tree vlan 1001
                        no spanning-tree vlan 301
                        no spanning-tree vlan 400
                        no spanning-tree vlan 500
                        no spanning-tree vlan 530
                        ip subnet-zero
                        !
                        !
                        !
                        interface GigabitEthernet0/1
                        description HE WAN Direct
                        switchport access vlan 500
                        no cdp enable
                        !
                        interface GigabitEthernet0/2
                        description VLAN uplink to S255 gi0/1
                        duplex full
                        no negotiation auto
                        switchport trunk encapsulation dot1q
                        switchport mode trunk
                        no cdp enable
                        !
                        interface GigabitEthernet0/3
                        description New WDM Transition Networks to S115 G0/1
                        duplex full
                        no negotiation auto
                        switchport trunk encapsulation dot1q
                        switchport mode trunk
                        no cdp enable
                        !
                        interface GigabitEthernet0/4
                        description AIX GIG Link VMware Server
                        switchport access vlan 115
                        no cdp enable
                        !
                        interface GigabitEthernet0/5
                        description TAG Vlan to Centrex ETH1
                        switchport access vlan 15
                        no cdp enable
                        !
                        interface GigabitEthernet0/6
                        description Trunk to A61 NOC Cisco 3512
                        switchport trunk encapsulation dot1q
                        switchport mode trunk
                        no cdp enable
                        !
                        interface GigabitEthernet0/7
                        description Uplink to Toolshed 3508 Gig 7
                        switchport trunk encapsulation dot1q
                        switchport mode trunk
                        no cdp enable
                        !
                        interface GigabitEthernet0/8
                        description WSSI Trunk
                        switchport trunk encapsulation dot1q
                        switchport mode trunk
                        no cdp enable
                        !
                        interface VLAN1
                        ip address
                        no ip directed-broadcast
                        no ip route-cache
                        !
                        G0/7 is the trunk to the switch that leads out to the internet. G0/6 goes eventually to the router. This switch and the others it connects to are in different buildings.

                        Here is the problem switch:

                        clock timezone EST -5
                        clock summer-time EDT recurring
                        !
                        no spanning-tree vlan 255
                        no spanning-tree vlan 147
                        no spanning-tree vlan 401
                        no spanning-tree vlan 402
                        no spanning-tree vlan 501
                        no spanning-tree vlan 502
                        no spanning-tree vlan 503
                        no spanning-tree vlan 603
                        no spanning-tree vlan 1001
                        no spanning-tree vlan 301
                        no spanning-tree vlan 400
                        no spanning-tree vlan 500
                        no spanning-tree vlan 530
                        ip subnet-zero
                        !
                        !
                        !
                        interface GigabitEthernet0/1
                        description HE WAN Direct
                        switchport access vlan 500
                        no cdp enable
                        !
                        interface GigabitEthernet0/2
                        description VLAN uplink to S255 gi0/1
                        duplex full
                        no negotiation auto
                        switchport trunk encapsulation dot1q
                        switchport mode trunk
                        no cdp enable
                        !
                        interface GigabitEthernet0/3
                        description New WDM Transition Networks to S115 G0/1
                        duplex full
                        no negotiation auto
                        switchport trunk encapsulation dot1q
                        switchport mode trunk
                        no cdp enable
                        !
                        interface GigabitEthernet0/4
                        description AIX GIG Link VMware Server
                        switchport access vlan 115
                        no cdp enable
                        !
                        interface GigabitEthernet0/5
                        description TAG Vlan to Centrex ETH1
                        switchport access vlan 15
                        no cdp enable
                        !
                        interface GigabitEthernet0/6
                        description Trunk to A61 NOC Cisco 3512
                        switchport trunk encapsulation dot1q
                        switchport mode trunk
                        no cdp enable
                        !
                        interface GigabitEthernet0/7
                        description Uplink to Toolshed 3508 Gig 7
                        switchport trunk encapsulation dot1q
                        switchport mode trunk
                        no cdp enable
                        !
                        interface GigabitEthernet0/8
                        description WSSI Trunk
                        switchport trunk encapsulation dot1q
                        switchport mode trunk
                        no cdp enable
                        !
                        interface VLAN1
                        ip address
                        no ip directed-broadcast
                        no ip route-cache
                        !

                        It is setup exactly the same as the "old" switch. It will probably be the weekend before I can try your suggestion.

                        Comment

                        Working...
                        X