Announcement

Collapse
No announcement yet.

No Internet on Cisco 880 Router

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • No Internet on Cisco 880 Router

    Hi,

    I've recently bought a Cisco 887 router/modem.

    Now I have a problem with accessing the internet from my LAN-clients.

    I've setup the Dialer (WAN tests are OK). I also get a WAN-IP from my ISP. My internal LAN is also working good.

    Now is my problem that I cannot get internet on the LAN-clients.

    Maybe i've forget something to setup, but I do not have any idea what is missing in the configuration.

  • #2
    Re: No Internet on Cisco 880 Router

    It would help if you post a clean (passwords, etc .. removed) config.
    CCNA, Network+

    Comment


    • #3
      Re: No Internet on Cisco 880 Router

      so from the router, you can bring up the internet interface, and ping google.,com
      and from the router, you can ping the LAN.

      correct?

      Without seeing your configuration, it sounds to me like either the NAT entries, or routing ACLs, are missing.
      Please do show your appreciation to those who assist you by leaving Rep Point https://www.petri.com/forums/core/im.../icon_beer.gif

      Comment


      • #4
        Re: No Internet on Cisco 880 Router

        Originally posted by tehcamel View Post
        so from the router, you can bring up the internet interface, and ping google.,com
        and from the router, you can ping the LAN.

        correct?

        Without seeing your configuration, it sounds to me like either the NAT entries, or routing ACLs, are missing.
        That's right.

        I also think that it has something to do with ACL or NAT. But I don't have any idea how to set that up.

        I will post my configuration asap.

        Configuration:

        Building configuration...
        Current configuration : 5758 bytes
        !
        ! Last configuration change at 09:59:46 Berlin Tue Oct 19 2010 by admin
        ! NVRAM config last updated at 09:59:47 Berlin Tue Oct 19 2010 by admin
        !
        version 15.1
        no service pad
        service timestamps debug datetime msec
        service timestamps log datetime msec
        no service password-encryption
        !
        hostname cisco887
        !
        boot-start-marker
        boot-end-marker
        !
        logging buffered 51200 warnings
        !
        no aaa new-model
        memory-size iomem 10
        clock timezone Berlin 1
        clock summer-time Berlin date Mar 30 2003 2:00 Oct 26 2003 3:00
        !
        ip source-route
        !
        !
        ip dhcp excluded-address 10.10.10.1
        !
        ip dhcp pool ccp-pool
        import all
        network 10.10.10.0 255.255.255.248
        default-router 10.10.10.1
        lease 0 2
        !
        !
        ip cef
        no ip domain lookup
        ip domain name x-ecosolar.com
        no ipv6 cef
        !
        !
        !
        template adsl
        !
        license udi pid CISCO887-K9 sn FCZ1434926G
        !
        !
        username admin privilege 15 secret 5 $1$jFzL$CzyyfrjddDxXydlTjgIAk/
        !
        !
        interface BRI0
        no ip address
        encapsulation hdlc
        shutdown
        isdn termination multidrop
        !
        interface ATM0
        no ip address
        load-interval 30
        no atm ilmi-keepalive
        pvc 8/48
        encapsulation aal5mux ppp dialer
        dialer pool-member 1
        !
        interface FastEthernet0
        !
        interface FastEthernet1
        !
        interface FastEthernet2
        !
        interface FastEthernet3
        !
        interface Vlan1
        description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$
        ip address 10.10.10.1 255.255.255.248
        ip tcp adjust-mss 1452
        !
        interface Dialer0
        ip address negotiated
        no ip unreachables
        ip nat outside
        ip virtual-reassembly
        encapsulation ppp
        dialer pool 1
        dialer idle-timeout 0
        dialer-group 1
        ppp pap sent-username ******** password 0 ********
        no cdp enable
        !
        ip forward-protocol nd
        ip http server
        ip http access-class 23
        ip http authentication local
        ip http secure-server
        ip http timeout-policy idle 60 life 86400 requests 10000
        !
        ip nat inside source list 100 interface Dialer0 overload
        ip route 0.0.0.0 0.0.0.0 Dialer0
        !
        access-list 23 permit 10.10.10.0 0.0.0.7
        access-list 100 permit ip 0.0.0.0 255.255.255.0 any
        dialer-list 1 protocol ip permit
        no cdp run
        !
        control-plane
        !
        line con 0
        login local
        no modem enable
        line aux 0
        line vty 0 4
        access-class 23 in
        privilege level 15
        login local
        transport input telnet ssh
        !
        ntp update-calendar
        ntp server 129.6.15.28 prefer source Dialer0
        end
        Last edited by toostje_85; 19th October 2010, 09:09.

        Comment


        • #5
          Re: No Internet on Cisco 880 Router

          On your Vlan1 interface you are missing

          ip nat inside
          and
          ip nat enable


          Take a look at my sample config for an 877

          http://jimwillsher.blogspot.com/2009...77-config.html


          Jim

          Comment


          • #6
            Re: No Internet on Cisco 880 Router

            Originally posted by jimwillsher View Post
            On your Vlan1 interface you are missing

            ip nat inside
            and
            ip nat enable


            Take a look at my sample config for an 877

            http://jimwillsher.blogspot.com/2009...77-config.html


            Jim
            Hi Jim,

            I saw your configuration, after some adjustments I cannot get browse with the clients on the internet. The dialer is online and can ping to, for example google.com.

            What am I doing wrong?

            Comment


            • #7
              Re: No Internet on Cisco 880 Router

              ok, so you can ping and you can resolve DNS (it sounds ike it, anyway). Can you post your full config again?


              Jim

              Comment


              • #8
                Re: No Internet on Cisco 880 Router

                Originally posted by jimwillsher View Post
                ok, so you can ping and you can resolve DNS (it sounds ike it, anyway). Can you post your full config again?


                Jim
                Finally my Cisco router and clients are connected to the internet. After a while studying your configuration and some others configuration, I understood working of the router.

                Thanks for your help.

                In the attachtment you will find my "working" configuration. I don't know if it's secured enough.
                Attached Files

                Comment

                Working...
                X