Announcement

Collapse
No announcement yet.

issue with 2960 multiple vlan with trunk port

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • issue with 2960 multiple vlan with trunk port

    Hi all,

    I am currently stuck in a problem I think it's not too hard to solve by experts but obviously not a newbie like me.

    Here is my situation. We have a firewall with two ports which both has DHCP turned on

    Port 0/0 ip 10.10.10.1 DHCP 10.10.10.50-.100
    Port 0/4 ip 10.20.10.1 DHCP 10.20.10.50-.100

    Port 0/0 is connected to Gil1/0/13 on Cisco 2960
    Port 0/4 is connected to Gil1/0/14 on Cisco 2960

    Vlan settings on Cisco 2960 switch

    I have created VLAN 2 which includes port Gil1/0/14 to 18.


    VLAN Name Status Ports
    ---- -------------------------------- --------- -------------------------------
    1 default active Gi1/0/1, Gi1/0/2, Gi1/0/3
    Gi1/0/4, Gi1/0/5, Gi1/0/6
    Gi1/0/7, Gi1/0/8, Gi1/0/9
    Gi1/0/10, Gi1/0/11, Gi1/0/12
    Gi1/0/13, Gi1/0/14, Gi1/0/15
    Gi1/0/16, Gi1/0/17, Gi1/0/18
    Gi1/0/19, Gi1/0/20, Gi1/0/21
    Gi1/0/22, Gi1/0/23, Gi1/0/24
    Gi1/0/25, Gi1/0/26, Gi1/0/27
    Gi1/0/28
    2 Voice active Gi1/0/14, Gi1/0/15, Gi1/0/16
    Gi1/0/17, Gi1/0/18


    problem here is that for some reason I cannot remove the port Gi1/0/14 from VLAN 1 so the DHCP is fighting each other. The aim is that I have VLAN 1 for data and VLAN 2 for voice as phone will be plugged into port 15 to 18 and PC will be connected to the phone.

    Please advise if there is anything I'm missing

  • #2
    Re: issue with 2960 multiple vlan with trunk port

    Can you post the config?

    And the interface status?
    Code:
    switch#sh int status
    CCNA, Network+

    Comment


    • #3
      Re: issue with 2960 multiple vlan with trunk port

      Sure

      Switch#sh int status

      Port Name Status Vlan Duplex Speed Type
      Gi1/0/1 connected 1 a-full a-1000 10/100/1000Ba
      seTX
      Gi1/0/2 connected 1 a-full a-100 10/100/1000Ba
      seTX
      Gi1/0/3 connected 1 a-full a-100 10/100/1000Ba
      seTX
      Gi1/0/4 notconnect 1 auto auto 10/100/1000Ba
      seTX
      Gi1/0/5 notconnect 1 auto auto 10/100/1000Ba
      seTX
      Gi1/0/6 notconnect 1 auto auto 10/100/1000Ba
      seTX
      Gi1/0/7 notconnect 1 auto auto 10/100/1000Ba
      seTX
      Gi1/0/8 connected 1 a-full a-1000 10/100/1000Ba
      seTX
      Gi1/0/9 connected 1 a-full a-100 10/100/1000Ba
      seTX
      Gi1/0/10 connected 1 a-full a-100 10/100/1000Ba
      seTX
      Gi1/0/11 connected 1 a-full a-100 10/100/1000Ba
      seTX
      Gi1/0/12 connected 1 a-full a-100 10/100/1000Ba
      seTX
      Gi1/0/13 connected 1 a-full a-100 10/100/1000Ba
      seTX
      Gi1/0/14 connected 1 a-full a-100 10/100/1000Ba
      seTX
      Gi1/0/15 notconnect 1 auto auto 10/100/1000Ba
      seTX
      Gi1/0/16 notconnect 1 auto auto 10/100/1000Ba
      seTX
      Gi1/0/17 connected 1 a-full a-1000 10/100/1000Ba
      seTX
      Gi1/0/18 notconnect 1 auto auto 10/100/1000Ba
      seTX
      Gi1/0/19 notconnect 1 auto auto 10/100/1000Ba
      seTX
      Gi1/0/20 notconnect 1 auto auto 10/100/1000Ba
      seTX
      Gi1/0/21 notconnect 1 auto auto 10/100/1000Ba
      seTX
      Gi1/0/22 notconnect 1 auto auto 10/100/1000Ba
      seTX
      Gi1/0/23 notconnect 1 auto auto 10/100/1000Ba
      seTX

      Port Name Status Vlan Duplex Speed Type
      Gi1/0/24 notconnect 1 auto auto 10/100/1000Ba
      seTX
      Gi1/0/25 notconnect 1 auto auto Not Present
      Gi1/0/26 notconnect 1 auto auto Not Present
      Gi1/0/27 notconnect 1 auto auto Not Present
      Gi1/0/28 notconnect 1 auto auto Not Present
      Fa0 disabled routed auto auto 10/100BaseTX

      Comment


      • #4
        Re: issue with 2960 multiple vlan with trunk port

        Can you post the switch config also?

        My sh int status looks like this:
        Code:
        switch#sh int status
        Port      Name               Status       Vlan       Duplex  Speed Type
        Gi1/0/1                      connected    2          a-full  a-100 10/100/1000BaseTX
        Gi1/0/2                      connected    2          a-full a-1000 10/100/1000BaseTX
        Gi1/0/3                      connected    2          a-full a-1000 10/100/1000BaseTX
        Gi1/0/4                      connected    2          a-full a-1000 10/100/1000BaseTX
        Gi1/0/5                      connected    2          a-full a-1000 10/100/1000BaseTX
        Gi1/0/6                      connected    2          a-half  a-100 10/100/1000BaseTX
        Gi1/0/7                      connected    2          a-full a-1000 10/100/1000BaseTX
        Gi1/0/8                      connected    2          a-full a-1000 10/100/1000BaseTX
        Gi1/0/9                      connected    3          a-full a-1000 10/100/1000BaseTX
        Gi1/0/10                     connected    2          a-full a-1000 10/100/1000BaseTX
        Gi1/0/11                     connected    2          a-full a-1000 10/100/1000BaseTX
        Gi1/0/12                     connected    2          a-full a-1000 10/100/1000BaseTX
        Gi1/0/13                     connected    2          a-full a-1000 10/100/1000BaseTX
        Gi1/0/14                     notconnect   3            auto   auto 10/100/1000BaseTX
        Gi1/0/15                     connected    2          a-full  a-100 10/100/1000BaseTX
        Gi1/0/16                     connected    2          a-full  a-100 10/100/1000BaseTX
        Gi1/0/17                     connected    2          a-full  a-100 10/100/1000BaseTX
        Gi1/0/18                     notconnect   2            auto   auto 10/100/1000BaseTX
        Gi1/0/19                     connected    2          a-full a-1000 10/100/1000BaseTX
        Gi1/0/20                     notconnect   2            auto   auto 10/100/1000BaseTX
        Gi1/0/21                     connected    2          a-full  a-100 10/100/1000BaseTX
        Gi1/0/22                     notconnect   3            auto   auto 10/100/1000BaseTX
        Gi1/0/23                     connected    2          a-full a-1000 10/100/1000BaseTX
        Gi1/0/24  Trunk to 2821      connected    trunk      a-full a-1000 10/100/1000BaseTX
        Gi1/0/25                     notconnect   1            auto   auto Not Present
        Gi1/0/26                     connected    trunk      a-full a-1000 1000BaseSX SFP
        Gi1/0/27                     connected    trunk      a-full a-1000 1000BaseLX SFP
        Gi1/0/28                     connected    trunk      a-full a-1000 1000BaseSX SFP
        Are those ports are supposed to be "trunks"?
        CCNA, Network+

        Comment


        • #5
          Re: issue with 2960 multiple vlan with trunk port

          This is the configuration

          ************************************************** ***************

          Current configuration : 2305 bytes
          !
          version 12.2
          no service pad
          service timestamps debug datetime msec
          service timestamps log datetime msec
          no service password-encryption
          !
          hostname Switch
          !
          boot-start-marker
          boot-end-marker
          !
          enable secret 5 $1$pH1k$j0dosLP6hrfcIryF3Tyk6/
          enable password
          !
          !
          !
          no aaa new-model
          switch 1 provision ws-c2960s-24ts-l
          authentication mac-move permit
          ip subnet-zero
          !
          !
          !
          !
          !
          spanning-tree mode pvst
          spanning-tree etherchannel guard misconfig
          spanning-tree extend system-id
          !
          !
          !
          !
          vlan internal allocation policy ascending
          !
          !
          !
          interface FastEthernet0
          no ip address
          shutdown
          !
          interface GigabitEthernet1/0/1
          switchport mode trunk
          switchport voice vlan 2
          spanning-tree portfast
          !
          interface GigabitEthernet1/0/2
          switchport mode trunk
          switchport voice vlan 2
          spanning-tree portfast
          !
          interface GigabitEthernet1/0/3
          switchport mode trunk
          switchport voice vlan 2
          spanning-tree portfast
          !
          interface GigabitEthernet1/0/4
          !
          interface GigabitEthernet1/0/5
          !
          interface GigabitEthernet1/0/6
          !
          interface GigabitEthernet1/0/7
          !
          interface GigabitEthernet1/0/8
          !
          interface GigabitEthernet1/0/9
          !
          interface GigabitEthernet1/0/10
          !
          interface GigabitEthernet1/0/11
          !
          interface GigabitEthernet1/0/12
          !
          interface GigabitEthernet1/0/13
          !
          interface GigabitEthernet1/0/14
          switchport voice vlan 2
          spanning-tree portfast
          !
          interface GigabitEthernet1/0/15
          switchport mode trunk
          switchport voice vlan 2
          spanning-tree portfast
          !
          interface GigabitEthernet1/0/16
          switchport mode trunk
          switchport voice vlan 2
          spanning-tree portfast
          !
          interface GigabitEthernet1/0/17
          switchport mode trunk
          switchport voice vlan 2
          spanning-tree portfast
          !
          interface GigabitEthernet1/0/18
          switchport mode trunk
          switchport voice vlan 2
          spanning-tree portfast
          !
          interface GigabitEthernet1/0/19
          !
          interface GigabitEthernet1/0/20
          !
          interface GigabitEthernet1/0/21
          !
          interface GigabitEthernet1/0/22
          !
          interface GigabitEthernet1/0/23
          !
          interface GigabitEthernet1/0/24
          !
          interface GigabitEthernet1/0/25
          !
          interface GigabitEthernet1/0/26
          !
          interface GigabitEthernet1/0/27
          !
          interface GigabitEthernet1/0/28
          !
          interface Vlan1
          ip address 10.10.1.222 255.255.255.0
          !
          ip http server
          ip http secure-server
          ip sla enable reaction-alerts
          !
          !
          line con 0
          line vty 0 4
          password
          login
          line vty 5 15
          password
          login
          !
          end

          ************************************************** ***************

          this is updated interface status

          ************************************************** ***************


          Port Name Status Vlan Duplex Speed Type
          Gi1/0/1 connected trunk a-full a-1000 10/100/1000Ba
          seTX
          Gi1/0/2 connected trunk a-full a-100 10/100/1000Ba
          seTX
          Gi1/0/3 connected trunk a-full a-100 10/100/1000Ba
          seTX
          Gi1/0/4 notconnect 1 auto auto 10/100/1000Ba
          seTX
          Gi1/0/5 notconnect 1 auto auto 10/100/1000Ba
          seTX
          Gi1/0/6 notconnect 1 auto auto 10/100/1000Ba
          seTX
          Gi1/0/7 notconnect 1 auto auto 10/100/1000Ba
          seTX
          Gi1/0/8 connected 1 a-full a-1000 10/100/1000Ba
          seTX
          Gi1/0/9 connected 1 a-full a-100 10/100/1000Ba
          seTX
          Gi1/0/10 connected 1 a-full a-100 10/100/1000Ba
          seTX
          Gi1/0/11 connected 1 a-full a-100 10/100/1000Ba
          seTX
          Gi1/0/12 connected 1 a-full a-100 10/100/1000Ba
          seTX
          Gi1/0/13 connected 1 a-full a-100 10/100/1000Ba
          seTX
          Gi1/0/14 connected 1 a-full a-100 10/100/1000Ba
          seTX
          Gi1/0/15 notconnect 1 auto auto 10/100/1000Ba
          seTX
          Gi1/0/16 notconnect 1 auto auto 10/100/1000Ba
          seTX
          Gi1/0/17 connected trunk a-full a-1000 10/100/1000Ba
          seTX
          Gi1/0/18 notconnect 1 auto auto 10/100/1000Ba
          seTX
          Gi1/0/19 notconnect 1 auto auto 10/100/1000Ba
          seTX
          Gi1/0/20 notconnect 1 auto auto 10/100/1000Ba
          seTX
          Gi1/0/21 notconnect 1 auto auto 10/100/1000Ba
          seTX
          Gi1/0/22 notconnect 1 auto auto 10/100/1000Ba
          seTX
          Gi1/0/23 notconnect 1 auto auto 10/100/1000Ba
          seTX
          Gi1/0/24 notconnect 1 auto auto 10/100/1000Ba
          seTX
          Gi1/0/25 notconnect 1 auto auto Not Present
          Gi1/0/26 notconnect 1 auto auto Not Present
          Gi1/0/27 notconnect 1 auto auto Not Present
          Gi1/0/28 notconnect 1 auto auto Not Present
          Fa0 disabled routed auto auto 10/100BaseTX

          ************************************************** ***************

          I have tried

          configure terminal
          interface Gi1/0/14
          switchport voice vlan 2
          end

          to change it to just vlan 2 and not to stay in vlan 1 but no luck
          Last edited by lucifer82; 15th October 2010, 10:54.

          Comment


          • #6
            Re: issue with 2960 multiple vlan with trunk port

            Try adding this:

            Code:
            switch(config)#int gi 1/0/14
            switch(config-int)#switchport mode access
            switch(config-int)#switchport access vlan 2
            Just to help: https://learningnetwork.cisco.com/message/54838
            CCNA, Network+

            Comment

            Working...
            X