Announcement

Collapse
No announcement yet.

Cisco 1811 Router Can Ping Gateway, But Can't Ping Outside From Client

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cisco 1811 Router Can Ping Gateway, But Can't Ping Outside From Client

    HI,


    On my 1811 router, the client gets a DHCP address, I can ping the router from the client, but i can't ping outside. I can ping outside from the router, [ping 8.8.8.8 source outside], no problems. Been working on it for 2 days, and researching but can't seem to find anything to help.

    I have the exact same 1811, used the same config[which is in production right now]. Only diffrence between the production one and the one i'm using now is the ip route, and that i am not using ip nat command on the interface. But i have tried it with and without.

    The production one, i'm routing to an ASA, this one i'm routing straight to the ISP's gateway

    Pretty sure i didn't leave anything out.

    Thanks

    ******Also, the weird thing is, everytime i unplug from router and back in, the computer gets an Windows IP Conflict. The 1811 in production does the same thing. There is nothing connected to the router but this pc???????


    Here is my config below


    *Jun 24 18:45:53.727: %SYS-5-CONFIG_I: Configured from console by consolesh run
    Building configuration...

    Current configuration : 1785 bytes
    !
    ! Last configuration change at 18:45:53 UTC Fri Jun 24 2016
    !
    version 15.1
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Router
    !
    boot-start-marker
    boot system tftp c181x-advipservicesk9-mz.151-3.T.bin 10.1.16.6
    boot system rom
    boot-end-marker
    !
    !
    !
    aaa new-model
    !
    !
    !
    !
    !
    !
    !
    aaa session-id common
    !
    crypto pki token default removal timeout 0
    !
    !
    dot11 syslog
    ip source-route
    !
    !
    no ip dhcp conflict logging
    ip dhcp excluded-address 10.1.22.1 10.1.22.99
    !
    ip dhcp pool test-pool
    network 10.1.22.0 255.255.255.0
    default-router 10.1.22.1
    dns-server 75.75.75.75 75.75.76.76
    !
    !
    !
    ip cef
    no ipv6 cef
    !
    multilink bundle-name authenticated
    !
    !
    !
    license udi pid CISCO1811/K9
    username admin privilege 15 password 0 password
    username cisco password 0 cisco
    !
    !
    ip ssh version 1
    !
    !
    !
    !
    !
    !
    !
    interface FastEthernet0
    description outside
    ip address xx.xx.xx.xx 255.255.255.248
    ip nat outside
    ip virtual-reassembly in
    duplex auto
    speed auto
    !
    interface FastEthernet1
    description inside
    ip address 10.1.22.1 255.255.255.0
    ip nat inside
    ip virtual-reassembly in
    duplex auto
    speed auto
    !
    interface FastEthernet2
    !
    interface FastEthernet3
    !
    interface FastEthernet4
    !
    interface FastEthernet5
    !
    interface FastEthernet6
    !
    interface FastEthernet7
    !
    interface FastEthernet8
    !
    interface FastEthernet9
    !
    interface Vlan1
    no ip address
    !
    interface Async1
    no ip address
    encapsulation slip
    !
    ip forward-protocol nd
    no ip http server
    no ip http secure-server
    !
    !
    ip route 0.0.0.0 0.0.0.0 xx.xx.xx.xx
    !
    logging esm config
    !
    !
    !
    !
    !
    !
    !
    control-plane
    !
    !
    !
    line con 0
    line 1
    modem InOut
    stopbits 1
    speed 115200
    flowcontrol hardware
    line aux 0
    line vty 0 4
    transport input ssh
    !
    end

    Router#
    Router#
    Router#
    Router#
    Last edited by Kobe 310; 24th June 2016, 20:35.

  • #2
    Based on your problem description and the config shown, you have the ip nat inside/outside on the interfaces, but have not configured what needs to be nat'd

    ​Try adding something like

    ip access-list extended TRAFFIC-2-NAT
    remark Specify all networks to NAT inside-2-outside
    permit ip 10.1.22.0 0.0.0.255 any


    ip nat inside source list TRAFFIC-2-NAT interface FastEthernet0 overload


    Comment


    • #3
      Awesome, it worked, thank you very much!!!! WOW, i would have been another week trying to figure that out.

      But now i'm confused, i don't have the ip nat inside/outside, or the command that you gave me on my other 1811 and it's been working for a couple years. wonder why. Is it because i have an ASA behind the 1811, and my ip route is pointing to a private address on the outside of the ASA instead of going straight to a modem pointing to the outside public gateway address?

      Comment

      Working...
      X