Announcement

Collapse
No announcement yet.

[Frame-Relay] Physical vs. Sub-Int/MultiPoint vs Sub-Int/PointToPoint

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Frame-Relay] Physical vs. Sub-Int/MultiPoint vs Sub-Int/PointToPoint

    Hello all (and sorry for my english),

    After reading lot of stuff about Frame-Relay, I want to summarize the question of the Interfaces (physical / subinterfaces) / (multipoint / point to point)

    If someone can validate/correct the following:
    1. 1) Frame Relay with Physical interface:
    - Multipoint (default): Using when all the DCE share the same network
    - Can't be point to point
      • Mappage (DLCI/IP) can be:
    - dynamic/ with Inverse ARP (default)
    - statique: using "frame-relay map ip a.b.c.d dlci"

    first question: In dynamic configuration, when should we use the "frame-relay interface-dlci xxx" command?
    Because this command assigns a DLCI to a specified FR interface or subinterface BUT DLCI are learn by Inverse ARP so I don't understand why/when we should use this command
    1. Frame Relay with sub-interfaces point to point
      • Each point to point must have his own subnet
      • No dynamic or static mapping necessary because point-to-point interface has only one possible destination - the other end of the point-to-point connection. So the "frame-relay interface-dlci xxx" indicate the single DLCI that will be used by this interface.
    2. Frame Relay with sub-interfaces multipoint
    • all the DCE share the same network
    • Can be dynamic (inverse arp / frame-relay interface-dlci xxx command)
    • static (no inverse arp / "frame-relay map ip a.b.c.d dlci" command)
    Am I right?
    Someone can explain me when do we MUST use frame-relay interface dlci 123 in dynamic configuration mode?

    Thanks in advance.

  • #2
    Re: [Frame-Relay] Physical vs. Sub-Int/MultiPoint vs Sub-Int/PointToPoint

    You use the frame-relay interface-dlci command on point to point links:


    int s1/0
    encap frame

    int s1/0.1 point-to-point
    ip address " "
    frame-relay interface-dlci " "

    There is no need for L3 to L2 resolution on point to point links as there can be only 1 possible endpoint. However on multipoint interfaces (default for main interface in frame-relay) you do need layer3 to layer 2 resolution for the endpoints. In a hub and spoke environment the hub is the only router with direct layer 2 connectivty to the spokes, so you will need either static mappings or use inverse arp. The spokes only have layer2 connectivity to the hub. If you want spoke to spoke connectivity you need to use static mappings for the other spokes as inverse arp messages are not passed on by the hub. This holds true for multipoint subinterfaces and main serial interfaces. There is no "all nodes broadcast" address in Frame relay like there is in ethernet (ARP).

    In my opinion for multipoint interfaces use static mappings as inverse arp can be unreliable.
    CCNA, CCNA-Security, CCNP
    CCIE Security (In Progress)

    Comment


    • #3
      Re: [Frame-Relay] Physical vs. Sub-Int/MultiPoint vs Sub-Int/PointToPoint

      Thanks for your answer.

      But in dynamic/multipoint configuration (without spoke-to-spoke communication), do I need to specify the DLCI "with frame-relay interface-dlci" command? with physical interface or subinterface?

      According to Cisco:
      For point-to-point subinterfaces, the destination is presumed to be known and is identified or implied in the frame-relay interface-dlci command. For multipoint subinterfaces, the destinations can be dynamically resolved through the use of Frame Relay Inverse ARP or can be statically mapped through the use of the frame-relay map command.
      - So I must use "dlci-relay interface-dlci" command in point to point to specify wich DLCI to use. I have not the choice.

      - "For multipoint subinterfaces, the destinations can be dynamically resolved through the use of Frame Relay Inverse ARP " so "Frame Relay Inverse ARP" means "nothing to do" or "by using the dlci-relay interface-dlci command"?

      Thanks in advance

      Comment


      • #4
        Re: [Frame-Relay] Physical vs. Sub-Int/MultiPoint vs Sub-Int/PointToPoint

        If its a point to point link create a subinterface and change the interface type to point to point. You can use the interface-dlci on main interface but typically its used on the sub interface. Correct it is required on the sub interface and you will notice you cant use static mappiings on the sub point-to-point interface. The command just tells the router "okay to get anywhere use this dlci"

        int s0/0
        encap frame

        int s0/0.1 point-to-point
        ip address " "
        frame-relay interface-dlci " "


        Yes inverse arp is automatic L2 to L3 resolution. Each side sends inverse arp requests and responds with replies. The config is minimal. Technically inverse arp doesnt start until an ip address is assigned to the interface.

        interface s0/0
        encapsualtion frame-relay
        ip address " "
        CCNA, CCNA-Security, CCNP
        CCIE Security (In Progress)

        Comment


        • #5
          Re: [Frame-Relay] Physical vs. Sub-Int/MultiPoint vs Sub-Int/PointToPoint

          Thanks Auglan,

          1) OK for multipoint physical interface, so can we say that with or without "frame-relay interface-dlci", no matter, result is the same.

          2) But is it true for multipoint sub-interface too? I tried with Packet Tracer and it's appear that I have to specify DLCI with the "frame-relay interface-dlci xxx" command.

          Why Inverse ARP don't learn DLCI number like multipoint physical interface?

          Configuration example:

          a) Multipoint sub-interface without "frame-relay interface dlci": not working
          interface Serial0/1/0
          no ip address
          encapsulation frame-relay
          !
          interface Serial0/1/0.102 multipoint
          ip address 10.0.0.1 255.0.0.0


          Router#sh frame-relay map
          Router#
          b) Multipoint sub-interface with "frame-relay interface dlci": working
          interface Serial0/1/0
          no ip address
          encapsulation frame-relay
          !
          interface Serial0/1/0.102 multipoint
          ip address 10.0.0.1 255.0.0.0
          frame-relay interface-dlci 103
          frame-relay interface-dlci 102

          Router#sh frame-relay map
          Serial0/1/0.102 (up): ip 10.0.0.2 dlci 102, dynamic, broadcast, CISCO, status defined, active
          Serial0/1/0.102 (up): ip 10.0.0.3 dlci 103, dynamic, broadcast, CISCO, status defined, active
          c) Multipoint physical interface without "frame-relay interface dlci": working
          interface Serial0/1/0
          no ip address
          encapsulation frame-relay
          !
          interface Serial0/1/0.102 multipoint
          ip address 10.0.0.1 255.0.0.0[


          Router#sh frame-relay map
          Serial0/1/0 (up): ip 10.0.0.2 dlci 102, dynamic, broadcast, CISCO, status defined, active
          Serial0/1/0 (up): ip 10.0.0.3 dlci 103, dynamic, broadcast, CISCO, status defined, active
          Inverse ARP with multipoint sub-interface and Inverse ARP with multipoint physical interface don't work in the same way.

          Comment


          • #6
            Re: [Frame-Relay] Physical vs. Sub-Int/MultiPoint vs Sub-Int/PointToPoint

            I think I found the answer:

            By default, the Cisco IOS software allocates all unassigned DLCIs advertised by the Frame Relay switch to the physical interface on the router.
            That's why, I have to specify DLCI number to the sub-interface instead of physical interface! (I suppose)

            Comment


            • #7
              Re: [Frame-Relay] Physical vs. Sub-Int/MultiPoint vs Sub-Int/PointToPoint

              Yes that is true. Thats why its always good to shutdown the main interface before the ip address and encap is defined as you could end up with unwanted mappings if using the main physical interface. Correct no dlci's are assigned to the sub interface by default.
              CCNA, CCNA-Security, CCNP
              CCIE Security (In Progress)

              Comment

              Working...
              X