Announcement

Collapse
No announcement yet.

Connecting 2 lan to one interface

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Connecting 2 lan to one interface

    Hi !


    How can i connect to Lan to one Interface(fe0/0)
    I have Fe0/0= 10.50.50.1 255.255.255.224
    and Fe0/1 is in use with sat link and serial also use in other link,
    I have also 2960 TCL 24 port.
    and my lan are 10.139.10.0/24 and 10.50.14.0 255.255.255.224

    Any body can help about it .

    Best rgd's

  • #2
    Re: Connecting 2 lan to one interface

    You can create subinterfaces off of the fe0/0 to do intervlan routing. Depends on the platform and the IOS your running. Lookup "router on a stick" . You will find many examples.
    CCNA, CCNA-Security, CCNP
    CCIE Security (In Progress)

    Comment


    • #3
      Re: Connecting 2 lan to one interface

      Funny you should ask this question as I kinda of answered it in another forum. I have pasted a typical router on a stick config in my reply in the other forum. I have repasted this sample IOS config here:

      Settings on the 2600
      [the DCHP Server section - partial shown]
      !
      ip dhcp pool vlan1
      network 192.168.0.0 255.255.255.0
      domain-name network.lan
      dns-server [DNS address here]
      default-router 172.16.0.1
      !
      ip dhcp pool vlan2
      network 192.168.1.0 255.255.255.0
      domain-name network.lan
      dns-server [DNS addressess here]
      default-router 172.17.0.1
      !
      !
      [interface settings]
      !
      interface FastEthernet0/1.1
      encapsulation dot1Q 1 native
      ip address 192.16.0.1 255.255.255.0
      ip nat inside
      !
      interface FastEthernet0/1.2
      encapsulation dot1Q 2
      ip address 192.168.1.1 255.255.255.0
      ip nat inside

      Setting for the 2950 port that you'll use for trunking
      !
      !
      interface FastEthernet0/1
      description This Trunk goes to the router!
      switchport mode trunk
      !

      Comment


      • #4
        Re: Connecting 2 lan to one interface

        Hello hazhir,

        Like Auglan was saying it depends on the ios version of your router. If your router supports Intervlan, you can do it as follows:

        interface FastEthernet0/0
        ip address 10.50.50.1 255.255.255.224
        no shut
        ip route-cache same-interface
        !
        interface FastEthernet0/0.1
        encapsulation dot1Q 2 ( which correspond to vlan 2 )
        ip address 10.139.10.1 255.255.255.0
        ip helper-address (IP of DHCP Server)
        !
        interface FastEthernet0/0.2
        encapsulation dot1Q 3
        ip address 10.50.14.1 255.255.255.0
        ip helper-address (IP of DHCP Server)
        !

        I hope this help.

        Comment

        Working...
        X