Announcement

Collapse
No announcement yet.

Configuration of Cisco 2811 router with nme-16es-1g-p switch module

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Configuration of Cisco 2811 router with nme-16es-1g-p switch module

    Hello,

    I'm trying to configure a cisco 2811 router with a nme-16es-1g-p switch integrated. I already configured the router, pppoe settings, dhcp, NAT, wireless. The clients that are connected via wireless can get to the internet
    I also configured the integrated switch. When I try to connect a client with the switch ports the client doesn't get an IP. I configured a DHCP pool in the switch and is still the same issue.
    Can you please tell me if I'm missing something here?
    I can post the config if its needed.

    Thank you,

    Erga

  • #2
    Re: Configuration of Cisco 2811 router with nme-16es-1g-p switch module

    Yeah post the config please.
    CCNA, CCNA-Security, CCNP
    CCIE Security (In Progress)

    Comment


    • #3
      Re: Configuration of Cisco 2811 router with nme-16es-1g-p switch module

      Ok, here are both configs


      --------------- The router --------------------


      !
      version 12.4
      service timestamps debug datetime msec
      service timestamps log datetime msec
      service password-encryption
      !
      hostname XXXXXXXXXX
      !
      boot-start-marker
      boot-end-marker
      !
      enable secret 5 XXXXXXXXXXXXXXXXXXXXXXXXXX
      !
      aaa new-model
      dot11 syslog
      !
      dot11 ssid XXXXXX
      authentication open
      guest-mode
      !
      !
      !
      ip cef
      no ip dhcp use vrf connected
      !
      ip dhcp pool XXXXXXXXXX
      import all
      network 192.168.20.0 255.255.255.192
      default-router 192.168.20.1
      dns-server 8.8.8.8
      !
      !
      ip domain name domain.local
      !
      multilink bundle-name authenticated
      !
      vpdn enable
      !
      vpdn-group 1
      request-dialin
      protocol pppoe
      l2tp tunnel receive-window 1024
      !
      !
      voice-card 0
      no dspfarm
      !
      !
      username XXXXXXX privilege 15 password 7 XXXXXXXXXXXXX
      !
      !
      archive
      log config
      hidekeys
      !
      !

      bba-group pppoe global
      !
      !
      interface FastEthernet0/0
      ip address 192.168.25.1 255.255.255.240
      ip virtual-reassembly
      no ip mroute-cache
      duplex auto
      speed auto
      !
      interface FastEthernet0/1
      no ip address
      no ip mroute-cache
      duplex auto
      speed auto
      pppoe enable group global
      pppoe-client dial-pool-number 1
      !
      interface Dot11Radio0/0/0
      ip address 192.168.20.1 255.255.255.192
      ip nat inside
      ip virtual-reassembly
      !
      encryption key 1 size 40bit 7 XXXXXXXXX transmit-key
      encryption mode wep mandatory
      !
      ssid XXXXXXXX
      !
      speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
      station-role root
      !
      interface GigabitEthernet1/0
      ip address 192.168.20.65 255.255.255.192
      !
      interface Dialer1
      ip address negotiated
      ip mtu 1492
      ip nat outside
      ip virtual-reassembly
      encapsulation ppp
      ip tcp adjust-mss 1452
      no ip mroute-cache
      dialer pool 1
      dialer-group 1
      no cdp enable
      ppp authentication chap pap callin
      ppp chap hostname XXXXXXX
      ppp chap password 7 XXXXXXXXXXXXXXX
      ppp pap sent-username XXXXXXXX password 7 XXXXXXXXXXXXX
      ppp ipcp dns request accept
      ppp ipcp route default
      ppp ipcp address accept
      !
      ip forward-protocol nd
      ip route 0.0.0.0 0.0.0.0 FastEthernet0/1
      ip route 172.168.20.0 255.255.255.0 192.168.20.66
      !
      !
      ip http server
      ip http secure-server
      ip nat inside source list 10 interface Dialer1 overload
      !
      access-list 10 permit 192.168.20.0 0.0.0.255
      dialer-list 1 protocol ip permit
      !

      control-plane
      !
      !
      line con 0
      line aux 0
      line 66
      no activation-character
      no exec
      transport preferred none
      transport input all
      transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
      line vty 0 4
      transport input ssh
      !
      scheduler allocate 20000 1000
      !
      end



      --------------- The Switch module ---------------------

      version 12.2
      no service pad
      service timestamps debug uptime
      service timestamps log uptime
      no service password-encryption
      !
      hostname XXXXXXXXXXXXX
      !
      !
      no aaa new-model
      system mtu routing 1500
      ip subnet-zero
      ip routing
      !
      ip dhcp pool XXXXXXXXXXX
      import all
      network 192.168.20.0 255.255.255.192
      default-router 192.168.20.1
      dns-server 8.8.8.8
      !
      ip dhcp-server 192.168.20.1
      !
      no file verify auto
      spanning-tree mode pvst
      spanning-tree extend system-id
      !
      vlan internal allocation policy ascending
      !
      interface FastEthernet1/0/1
      !
      interface FastEthernet1/0/2
      !
      interface FastEthernet1/0/3
      !
      interface FastEthernet1/0/4
      !
      interface FastEthernet1/0/5
      !
      interface FastEthernet1/0/6
      !
      interface FastEthernet1/0/7
      !
      interface FastEthernet1/0/8
      !
      interface FastEthernet1/0/9
      !
      interface FastEthernet1/0/10
      !
      interface FastEthernet1/0/11
      !
      interface FastEthernet1/0/12
      !
      interface FastEthernet1/0/13
      !
      interface FastEthernet1/0/14
      !
      interface FastEthernet1/0/15
      !
      interface FastEthernet1/0/16
      !
      interface GigabitEthernet1/0/1
      !
      interface GigabitEthernet1/0/2
      no switchport
      ip address 192.168.20.66 255.255.255.192
      !
      interface Vlan1
      ip address dhcp
      ip helper-address 192.168.20.1
      !
      ip default-gateway 192.168.20.1
      ip classless
      ip route 0.0.0.0 0.0.0.0 192.168.20.65
      ip http server
      !
      !
      control-plane
      !
      !
      line con 0
      exec-timeout 30 0
      password XXXXXXXX
      line vty 0 4
      exec-timeout 30 0
      password XXXXXXXX
      login
      line vty 5 15
      login
      !
      end


      Thank you in advance,

      Erga

      Comment


      • #4
        Re: Configuration of Cisco 2811 router with nme-16es-1g-p switch module

        Why do you have the same dhcp pools configured on the switch module and the router? I would just use the dhcp pool on the router. Also whey are you using dhcp on the VLAN 1 interface? I would statically assign that interface an ip address. You also have the ip default-gateway configured on the switch module and you have ip routing enabled. Ip default-gateway should only be used when ip routing is disabled.

        You also have the command ip dhcp-server 192.168.20.1 and the ip helper-address configured. The ip dhcp-server command only forwards bootp broadcast whereas the helper-address fowards a few other ports along with bootp. So I would stick with the ip helper-address.



        Also do a show ip dhcp binding on the router and debug ip dhcp server events or ip dhcp server packet.

        Also just verify you can ping successfully between the router and the swtich

        ping x.x.x.x source vlan 1
        Last edited by auglan; 23rd June 2010, 14:08.
        CCNA, CCNA-Security, CCNP
        CCIE Security (In Progress)

        Comment


        • #5
          Re: Configuration of Cisco 2811 router with nme-16es-1g-p switch module

          I have both pools in the switch and the router because I was testing different versions.
          I think the problem might be physical, I'm not sure though. I set static IP on the computer and still can't ping the switch or the router from the client. Meanwhile from the switch I can ping the client connected via wireless, and they're in different subnets so its not a routing issue. When I run show ip int brief the interface is up. Is the first time I'm working with an integrated switch module. From what I saw online this switch is used for PoE phones. Is there any port setting I should change.


          ip route 172.168.20.0 255.255.255.0 192.168.20.66 - this is the route from the router to the switch

          thanks

          Comment


          • #6
            Re: Configuration of Cisco 2811 router with nme-16es-1g-p switch module

            ip route 172.168.20.0 255.255.255.0 192.168.20.66 - this is the route from the router to the switch


            Okay if this is the route from the router to the switch which interface is assigned the 172.168.20.0 network? Im assuming this is a typo as 172.168.0.0 is not an RFC 1918 address (private addressing)

            Are your wirless clients pulling the ip from the router or the switch? You can verify by show ip dhcp binding on either device.
            CCNA, CCNA-Security, CCNP
            CCIE Security (In Progress)

            Comment


            • #7
              Re: Configuration of Cisco 2811 router with nme-16es-1g-p switch module

              Can you ping from the switch to the router?
              CCNA, CCNA-Security, CCNP
              CCIE Security (In Progress)

              Comment


              • #8
                Re: Configuration of Cisco 2811 router with nme-16es-1g-p switch module

                ip route 172.168.20.0 255.255.255.0 192.168.20.66 - this is a typo
                It should be ip route 192.168.20.0 255.255.255.0 192.168.20.66

                The wireless clients are pulling the IP from the router

                And I can ping from the switch, I can ping 192.168.20.1 and I can ping the wireless clients

                Also from the router I can ping 192.168.20.66

                Comment


                • #9
                  Re: Configuration of Cisco 2811 router with nme-16es-1g-p switch module

                  Ok so you want your lan clients to get dhcp from the same range as the wireless clients? If you do that to me it looks like you will have that 192.168.20.0/26 network seperated by another subnet. The router knows that 192.168.20.0 is directly connected as an interface with an ip in that range is assigned. So if the router thinks that 192.168.20.0 is directly connected there could be a problem if hosts on the switch are also on that same subnet in regards on how the router routes. Being that the connected route is more specific then the static route longest match routing is going to win.

                  On the router do a :

                  sh ip route 192.168.20.0 and post that
                  CCNA, CCNA-Security, CCNP
                  CCIE Security (In Progress)

                  Comment


                  • #10
                    Re: Configuration of Cisco 2811 router with nme-16es-1g-p switch module

                    Here is the result of show ip route:

                    XXXXXXXX#show ip route
                    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
                    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
                    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
                    E1 - OSPF external type 1, E2 - OSPF external type 2
                    i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
                    ia - IS-IS inter area, * - candidate default, U - per-user static route
                    o - ODR, P - periodic downloaded static route

                    Gateway of last resort is XXX.XXX.XX.XX to network 0.0.0.0

                    192.168.25.0/28 is subnetted, 1 subnets
                    C 192.168.25.0 is directly connected, FastEthernet0/0
                    192.168.20.0/24 is variably subnetted, 3 subnets, 2 masks
                    C 192.168.20.64/26 is directly connected, GigabitEthernet1/0
                    C 192.168.20.0/26 is directly connected, Dot11Radio0/0/0
                    S 192.168.20.0/24 [1/0] via 192.168.20.66
                    XX.0.0.0/32 is subnetted, 2 subnets
                    C XXX.XXX.XXX.XXX is directly connected, Dialer1
                    C XX.XX.XX.XX is directly connected, Dialer1
                    S* 0.0.0.0/0 [1/0] via XX.XXX.XXX.XXX


                    Thanks!

                    Comment


                    • #11
                      Re: Configuration of Cisco 2811 router with nme-16es-1g-p switch module

                      C 192.168.20.0/26 is directly connected, Dot11Radio0/0/0
                      S 192.168.20.0/24 [1/0] via 192.168.20.66

                      As you can see the connected route is a longer match (/26 vs /24) in the RIB so routing isnt going to work correctly going to hosts on the same subnet on the switch.

                      The best thing to do is create a new subnet for lan hosts with a new dhcp pool then you shouldnt have any issues.
                      CCNA, CCNA-Security, CCNP
                      CCIE Security (In Progress)

                      Comment


                      • #12
                        Re: Configuration of Cisco 2811 router with nme-16es-1g-p switch module

                        I tried and still the same issue.

                        I have another 2811 router with the switch module integrated, but without the wireless. Here I was able to make it work by connecting the Fastethernet0/0 port with gigabitethernet1/0 with a straight cable. In this case the F0/0 port had the 192.168.20.1 IP address. I know the switch and the router are supposed to communicate through the gig1/0 port, but it wasnt' working. And to say the truth, I don't know why it works when I connect the ports with the cable. And even though the switch and the router are in different subnets, the LAN clients pull the IP from the dhcp pool on the router and are able to get to the internet.

                        I will try this on Monday with the router with the wireless card and see what happens. I will to put the 192.168.20.1 IP address on the F0/0 port. And since F0/0, Dot11Radio0/0/0 and Gig1/0 can't have the IPs in the same range, I will try to put them in different subnets

                        Comment


                        • #13
                          Re: Configuration of Cisco 2811 router with nme-16es-1g-p switch module

                          If you think it could be a hardware issue I would give Tac a call as well. Also may want to try looking at the configuration guide for that module.


                          So you did create a new subnet on the switch with a new dhcp pool and it still didnt work? Make sure if you did do that to put a route back to the switch on the router. Where you able to ping from the host to the router at least? That will tell you if routing is working. The reason its working with no wireless is that now the 192.168.20.0 subnet isnt directly connected so it knows how to route it back to the switch. Before when that interface was in that subnet it was trying to resolve the next hop out that interface instead of the interface connected to the switch. If you did a debug ip packet you would probably see "encapsulation failed" messages, meaning its trying to resolve layer 3 to layer 2 out its own interface.
                          Last edited by auglan; 25th June 2010, 12:55.
                          CCNA, CCNA-Security, CCNP
                          CCIE Security (In Progress)

                          Comment


                          • #14
                            Re: Configuration of Cisco 2811 router with nme-16es-1g-p switch module

                            I followed this guide for the configuration:

                            http://www.cisco.com/en/US/products/...80810449.shtml

                            Still didn't work. From the switch I can ping wireless clients. And I can ping interfaces from the switch to the router and router to the switch. That should mean the switch and the router are communicating. From the client connected to the switch I can't ping the switch or the router. Even with manual IP. Also tried with different cable and NIC, again, so the problem is not at that end. I will try the scenario with the cable on Monday.

                            Comment


                            • #15
                              Re: Configuration of Cisco 2811 router with nme-16es-1g-p switch module

                              If you can ping from switch to router, yes routing is working between the two. Try moving the dchp pool for the lan clients down to the switch or you could even statically assign the host an ip with the "correct" gateway and test from there. Running wireshark on the host wont hurt either. Try sourcing the ping from the vlan 1 interface to the router and see if that goes through. Posting an updated config would be a good idea as well. You first need to resolve the routing issues before you make any changes. If routing is working then work on the dhcp issues etc. What are you setting your hosts gateway as, when assigning a static? Im also assuming you changed the the wired hosts subnet as if you didnt Ive already explained why its not working.
                              Last edited by auglan; 25th June 2010, 13:08.
                              CCNA, CCNA-Security, CCNP
                              CCIE Security (In Progress)

                              Comment

                              Working...
                              X