Announcement

Collapse
No announcement yet.

Cisco 2651 w/ wic-1adsl config pointers

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cisco 2651 w/ wic-1adsl config pointers

    My first post
    I have a cisco 2651 with a wic-1adsl that I want to replace my existing provider supplied modem and linksys router. I am not a total stranger to Cisco routers but must admit it has been about 10 years since I worked with them on a regular basis (IOS's change a lot in that many years) I have searched the forum for a step by step but nothing was found... I currently have 12.3.1 installed (waiting for a memory upgrade to update to 12.3.26 as I only have 64m) the ATM interface is active

    A couple particulars to my setup. I have a /29 (255.255.255.24 from my provider and am looking to utilize the range using nat and private address space on the inside

    Anyone have a sh run they can post to help me on my journey?

    Thanks!

  • #2
    Re: Cisco 2651 w/ wic-1adsl config pointers

    This link will help you get started:

    https://www.cisco.com/en/US/tech/tk1...ples_list.html
    CCNA, CCNA-Security, CCNP
    CCIE Security (In Progress)

    Comment


    • #3
      Re: Cisco 2651 w/ wic-1adsl config pointers

      auglan,

      Thanks for the link, that helped a lot. When I try to connect, it doesn't when I do a show int dialer1, i get the following
      Bound to:
      Virtual-Access2 is up, line potocol is down

      here is my config
      C2651#
      C2651#sh run
      Building configuration...
      Current configuration : 1592 bytes
      !
      version 12.3
      service timestamps debug datetime msec
      service timestamps log datetime msec
      no service password-encryption
      !
      hostname C2651
      !
      no logging console
      enable secret 5 $1$frux$hI7F0TDJLVfgdNBlFqexk1
      enable password XXXXXXXXXX
      !
      ip subnet-zero
      ip cef
      !
      !
      ip name-server XXX.XXX.XXX.XXX
      ip name-server XXX.XXX.XXX.XXX
      !
      vpdn enable
      !
      vpdn-group pppoe
      request-dialin
      protocol pppoe
      !
      !
      !
      !
      !
      !
      !
      !
      !
      !
      no voice hpi capture buffer
      no voice hpi capture destination
      !
      !
      !
      !
      !
      !
      interface ATM0/0
      no ip address
      no atm ilmi-keepalive
      pvc 0/38
      encapsulation aal5mux ppp dialer
      dialer pool-member 1
      !
      bundle-enable
      dsl operating-mode auto
      !
      interface FastEthernet0/0
      ip address XXX.XXX.XXX.XXX 255.255.255.0
      ip nat inside
      ip tcp adjust-mss 1452
      speed auto
      full-duplex
      !
      interface FastEthernet0/1
      no ip address
      shutdown
      duplex auto
      speed auto
      !
      interface Dialer1
      mtu 1492
      ip address XXX.XXX.XXX.XXX 255.255.255.248
      no ip redirects
      no ip proxy-arp
      ip nat outside
      encapsulation ppp
      dialer pool 1
      dialer-group 1
      no cdp enable
      ppp authentication chap callin
      ppp chap hostname [email protected]
      ppp chap password 0 XXXXXXXX
      ppp pap sent-username [email protected] password 0 XXXXXXXXX
      !
      ip nat pool mpool XXX.XXX.XXX.XXX XXX.XXX.XXX.XXX netmask 255.255.255.248
      ip nat inside source list 1 pool mpool overload
      ip http server
      ip classless
      ip route 0.0.0.0 0.0.0.0 Dialer1 permanent
      !
      !
      access-list 1 permit XXX.XXX.XXX.XXX 0.0.0.255
      !
      snmp-server community public RO
      snmp-server enable traps tty
      !
      !
      !
      !
      !
      !
      line con 0
      line aux 0
      line vty 0 4
      password XXXXXXXXX
      login
      !
      !
      !
      end
      C2651#


      Any Ideas?

      Comment


      • #4
        Re: Cisco 2651 w/ wic-1adsl config pointers

        Problem solved!

        My goofy telco company (Qwest) here in Arizona uses 0/32 for the PVC instead of 0/38. I only beat my head against the wall for a few hours (it felt kinda nice to shake up the grey matter a little)

        Comment


        • #5
          Re: Cisco 2651 w/ wic-1adsl config pointers

          Ok glad to hear you got it going. Just remember anytime you see the line protocol down it means you have a layer 2 issue (encapsulation issue, incorrect frame relay dlci or in your case the ATM pvc)
          CCNA, CCNA-Security, CCNP
          CCIE Security (In Progress)

          Comment

          Working...
          X