Announcement

Collapse
No announcement yet.

Config 2 units of Cisco 2811 to ping each other via WAN

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Config 2 units of Cisco 2811 to ping each other via WAN

    Hi all! First of all, I'm a sales guy and have no knowledge about Cisco router config whatsoever.

    The reason I'm posting here is to seek for assistance to help my client to config this 2811 router to communicate with each other via WAN.

    This is the scenario:
    There are 2 units of Cisco 2811 routers; 1 at Site A and the other at Site B.
    Site A and Site B are connected with a 2Mbps leased line. In order for these 2 sites to communicate, first we have to setup these routers so that the communication link is up? no?

    My client has never config this Cisco router for this purpose even though he is CCNA certified?!??! gosh... My main objective here is to help him config the routers so that router A could ping router B, and the internal LAN config is none of my biz at this point in time.

    I've obtained the following config from a friend of mine but is yet to be tested. Can anyone please help to verify whether the config script below is workable?

    -------FOR SITE A---------

    hostname KPOC-HLA
    !
    !
    ip subnet-zero
    !
    !
    !
    interface FA0/0
    description ** To WAN - KLCC **
    ip address 192.168.3.250 255.255.0.0
    duplex full
    speed auto
    no ip directed-broadcast
    !
    interface FA0/1
    description ** To Local Area Network **
    no ip address
    no ip directed-broadcast
    shutdown
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 0.0.0.0
    ip route 192.168.0.0 255.255.0.0 192.168.52.250
    !
    !
    line con 0
    transport input none
    line vty 0 4
    !
    end


    ------FOR SITE B------------

    hostname KPOC-KLCC
    !
    !
    ip subnet-zero
    !
    !
    !
    interface FA0/0
    description ** To WAN - HLA **
    ip address 192.168.52.250 255.255.0.0
    duplex full
    speed auto
    no ip directed-broadcast
    !
    interface FA0/1
    description ** To Local Area Network **
    no ip address
    no ip directed-broadcast
    shutdown
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 0.0.0.0
    ip route 192.168.0.0 255.255.0.0 192.168.3.250
    !
    !
    line con 0
    transport input none
    line vty 0 4
    !
    end

    -----------------------------------------------

    I really need someone's help to get this link up and running ASAP or else I'll be doomed!

    Thanks a lot guys!

  • #2
    Re: Config 2 units of Cisco 2811 to ping each other via WAN

    Well if this is just a point-to-point link you should have both interfaces on the same subnet. You can use a /30 subnet for the wan side. What type of leased lilne. Since your using ethernet i presume its a Metro Ethernet circuit. Once you get connected across the link , then you can either setup static routes or run a routing protocol between the routers to share their internal subnets.
    CCNA, CCNA-Security, CCNP
    CCIE Security (In Progress)

    Comment


    • #3
      Re: Config 2 units of Cisco 2811 to ping each other via WAN

      yes it's a point to point leased link via metro-e circuit. so do you mean that the script that i've shared here earlier is ok? maybe just a tweak to the subnet will do?
      cheers

      Comment


      • #4
        Re: Config 2 units of Cisco 2811 to ping each other via WAN

        First thing you should do is change the wan interfaces to be on the same subnet.

        Example:

        192.168.1.0/30

        That subnet will give you 2 usable ip addresses for your wan interfaces

        192.168.1.0 - network
        192.168.1.1 - first usable - Wan A
        192.168.1.2 - second usable - Wan B
        192.168.1.3 - Broadcast

        Adjust accordingly.

        Then just verify connectivity with the remote endpoints.

        You may also want to check with the provider of the circuit. Depending what they are running in the cloud (MPLS etc) they may require a peering between your edge router and SP device. So you may need to be on a common subnet with them on both ends. The above is an example of a ptp connection between 2 directly connected devices but in your case you have to take into account how the SP is passing data through the cloud.
        CCNA, CCNA-Security, CCNP
        CCIE Security (In Progress)

        Comment


        • #5
          Re: Config 2 units of Cisco 2811 to ping each other via WAN

          thanks auglan for your feedback. now i'll need to check with my client whether he has successfully configured the routers or not. i really appreciate your help

          Comment

          Working...
          X