Announcement

Collapse
No announcement yet.

Adding subnet to PIX 501 network

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Adding subnet to PIX 501 network

    I am looking for some configuration help with a Cisco PIX 501 version 6.3(3). It is currently set up with IP 192.168.1.1 and a subnet mask of 255.255.255.0, and all clients are have IP addresses in the 192.168.1.xxx range. All clients are connecting via an unmanaged switch to the PIX, which in turn connects to the internet.

    I am trying to accomplish two things. FIRST, I am trying to add an internal client with an IP address of 192.168.10.10, and allow that client to access everything (both internal and external). I also want to be able to RDP to this client from the internet. SECOND, once I accomplish this, I would like to prohibit the new client from accessing the server at 192.168.1.10 (and vice verse).

    I have made an attempt to do this, but so far, no luck. So far, I have done the following:
    - added (via the PDM) an inside host/network of 192.168.10.0 255.255.255.0
    - added (via the PDM) an Access Rule allowing port 3389 to make it through to the client at 192.168.10.10
    - changed (via the PDM) the inside interface to a subnet of 255.255.0.0 (was 255.255.255.0)
    - added (via telnet) route inside 192.168.10.0 255.255.255.0 192.168.1.1 1.
    Finally, I changed the IP on this client to 192.168.10.10, but left the gateway as 192.168.1.1. (I didn't start to try to limit access for this client to the server at 192.168.1.10, as I still haven't accomplished my first goal.) The current PIX config is detailed below.

    I cannot RDP to this client, nor can I ping this client from any other computer on the 192.168.1.xxx subnet. I must have configured something wrong, just not sure what it is. Thanks for your help.

    void# wr t
    Building configuration...
    : Saved
    :
    PIX Version 6.3(3)
    interface ethernet0 auto
    interface ethernet1 100full
    nameif ethernet0 outside security0
    nameif ethernet1 inside security100
    enable password [omitted] encrypted
    passwd [omitted] encrypted
    hostname void
    domain-name ciscopix.com
    fixup protocol dns maximum-length 512
    fixup protocol ftp 21
    fixup protocol h323 h225 1720
    fixup protocol h323 ras 1718-1719
    fixup protocol http 80
    fixup protocol rsh 514
    fixup protocol rtsp 554
    fixup protocol sip 5060
    fixup protocol sip udp 5060
    fixup protocol skinny 2000
    fixup protocol smtp 25
    fixup protocol sqlnet 1521
    fixup protocol tftp 69
    names
    name 192.168.1.11 Server2010
    access-list outside-in permit tcp any interface outside eq 3389
    access-list outside-in permit tcp any interface outside eq 5900
    access-list outside-in permit tcp any interface outside eq smtp
    access-list outside-in permit tcp any interface outside eq www
    access-list outside-in permit tcp any interface outside eq https
    access-list outside-in permit tcp any interface outside eq pop3
    access-list outside-in permit tcp any interface outside eq ftp
    access-list outside-in permit icmp any any echo
    access-list inside_outbound_nat0_acl permit ip any 192.168.1.48 255.255.255.240
    access-list outside_cryptomap_dyn_20 permit ip any 192.168.1.48 255.255.255.240
    access-list splittunnel permit ip 192.168.1.0 255.255.255.0 any
    pager lines 24
    mtu outside 1500
    mtu inside 1500
    ip address outside 192.168.2.162 255.255.255.0
    ip address inside 192.168.1.1 255.255.0.0
    ip audit info action alarm
    ip audit attack action alarm
    ip local pool vpnpool 192.168.1.50-192.168.1.60
    pdm location 192.168.1.100 255.255.255.255 inside
    pdm location 192.168.1.200 255.255.255.255 inside
    pdm location 192.168.0.0 255.255.0.0 inside
    pdm location 192.168.1.111 255.255.255.255 inside
    pdm location 192.168.1.10 255.255.255.255 inside
    pdm location 192.168.10.0 255.255.255.0 inside
    pdm location 192.168.10.10 255.255.255.255 inside
    pdm location 192.168.1.0 255.255.255.0 inside
    pdm logging informational 100
    pdm history enable
    arp timeout 14400
    global (outside) 1 interface
    nat (inside) 0 access-list inside_outbound_nat0_acl
    nat (inside) 1 0.0.0.0 0.0.0.0 0 0
    static (inside,outside) tcp interface 5900 192.168.1.200 5900 netmask 255.255.255.255 0 0
    static (inside,outside) tcp interface 3389 192.168.10.10 3389 netmask 255.255.255.255 0 0
    static (inside,outside) tcp interface smtp 192.168.1.10 smtp netmask 255.255.255.255 0 0
    static (inside,outside) tcp interface www 192.168.1.10 www netmask 255.255.255.255 0 0
    static (inside,outside) tcp interface https 192.168.1.10 https netmask 255.255.255.255 0 0
    static (inside,outside) tcp interface pop3 192.168.1.10 pop3 netmask 255.255.255.255 0 0
    static (inside,outside) tcp interface ftp 192.168.1.10 ftp netmask 255.255.255.255 0 0
    access-group outside-in in interface outside
    route outside 0.0.0.0 0.0.0.0 192.168.2.253 1
    route outside xxx.xxx.0.0 255.255.0.0 66.166.39.221 1
    route inside 192.168.10.0 255.255.255.0 192.168.1.1 1
    route outside xxx.xxx.104.0 255.255.254.0 66.166.39.221 1
    route outside xxx.xxx.176.0 255.255.248.0 66.166.39.221 1
    route outside xxx.xxx.246.0 255.255.255.0 66.166.39.221 1
    route outside xxx.xxx.161.0 255.255.255.0 66.166.39.221 1
    timeout xlate 0:05:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
    timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
    timeout uauth 0:05:00 absolute
    aaa-server TACACS+ protocol tacacs+
    aaa-server RADIUS protocol radius
    aaa-server LOCAL protocol local
    http server enable
    http 192.168.1.0 255.255.255.0 inside
    http 192.168.0.0 255.255.0.0 inside
    no snmp-server location
    no snmp-server contact
    snmp-server community public
    no snmp-server enable traps
    floodguard enable
    sysopt connection permit-ipsec
    sysopt ipsec pl-compatible
    crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
    crypto dynamic-map outside_dyn_map 20 match address outside_cryptomap_dyn_20
    crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-MD5
    crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
    crypto map outside_map interface outside
    isakmp enable outside
    isakmp policy 20 authentication rsa-sig
    isakmp policy 20 encryption des
    isakmp policy 20 hash sha
    isakmp policy 20 group 1
    isakmp policy 20 lifetime 86400
    isakmp policy 40 authentication pre-share
    isakmp policy 40 encryption 3des
    isakmp policy 40 hash md5
    isakmp policy 40 group 2
    isakmp policy 40 lifetime 86400
    vpngroup vpngroup idle-time 1800
    vpngroup aravpn address-pool vpnpool
    vpngroup aravpn dns-server 192.168.1.10 206.141.192.60
    vpngroup aravpn wins-server 192.168.1.10
    vpngroup aravpn default-domain mydomain.local
    vpngroup aravpn split-tunnel splittunnel
    vpngroup aravpn idle-time 1800
    vpngroup aravpn password ********
    telnet 192.168.0.0 255.255.0.0 inside
    telnet timeout 5
    ssh timeout 5
    console timeout 0
    dhcpd address 192.168.1.101-192.168.1.109 inside
    dhcpd dns 192.168.1.10 64.105.189.26
    dhcpd wins 192.168.1.10
    dhcpd lease 3600
    dhcpd ping_timeout 750
    dhcpd domain mydomain.local
    dhcpd auto_config outside
    dhcpd enable inside
    terminal width 80
    Cryptochecksum:
    : end
    [OK]
    void#

  • #2
    Re: Adding subnet to PIX 501 network

    Sorry, I mis-stated one fact in my summary above, and I think it is probably important. The outside port on the PIX does not connect directly to the internet, it connects to another internal router over which I have no control. The PIX has an outside IP of 192.168.2.162. No machines on the 192.168.1.xxx network (or 192.168.10.xxx) need to access any resources on the 192.168.2.xxx network. When data leaves the outbound port on the PIX, it is destined for the internet.

    Comment


    • #3
      Re: Adding subnet to PIX 501 network

      If your adding another subnet you will need to create a new vlan for that subnet. Since its an unmanaged switch I doubt it supports adding vlans etc.

      If you have a spare ethernet interface on the pix you could ip that with your new subnet and then trunk to a different switch. The better solution would be to get a managed switch, create your 2 vlans and run a "router" on a stick configuration to the pix. IE make a dot1q trunk to the pix for intervlan routing.

      Seeing its a pix 501 it prolly only has one internal interace so the second option wont work. So the only real option is to get a managed switch, create your vlans, setup dot1q trunk to pix. Or get a router with the firewall feature set and do the same thing. Another option would be a L3 switch to handle the intervlan routing.

      The pix needs to know how to route between the 2 subnets.
      Last edited by auglan; 22nd April 2010, 18:08.
      CCNA, CCNA-Security, CCNP
      CCIE Security (In Progress)

      Comment

      Working...
      X