Announcement

Collapse
No announcement yet.

port forwarding on cisco router 3845 and 1841 (WAS: Hello all need help :))

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • port forwarding on cisco router 3845 and 1841 (WAS: Hello all need help :))

    Hello all im new, i just want to ask for help about port forwarding on cisco router 3845 and 1841, im using a static ip address but its a pppoe type this is my configuration on my router, i want to view port 8888 its my DVR while im not at the office, its a survaillance camera. can you help me it dosent seem to be working. what config would i add or do. many thanks

    CONFIG:

    Current configuration : 1517 bytes
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname CISCO1841
    !
    boot-start-marker
    boot-end-marker
    !
    enable secret 5 $1$mu1x$CMb95/a0gerL2sKkjX72q0
    !
    no aaa new-model
    !
    resource policy
    !
    mmi polling-interval 60
    no mmi auto-configure
    no mmi pvc
    mmi snmp-timeout 180
    ip subnet-zero
    ip cef
    !
    !
    no ip dhcp use vrf connected
    ip dhcp excluded-address 192.168.10.0 192.168.10.99
    !
    ip dhcp pool mypool
    network 192.168.10.0 255.255.255.0
    default-router 192.168.10.2
    dns-server 158.69.254.14 158.69.254.15
    !
    !
    vpdn enable
    vpdn ip udp ignore checksum
    !
    vpdn-group pppoe
    request-dialin
    protocol pppoe
    !
    !
    !
    !
    !
    interface FastEthernet0/1
    no ip address
    duplex auto
    speed auto
    pppoe enable
    pppoe-client dial-pool-number 1
    !
    interface FastEthernet0/0
    ip address 192.168.10.2 255.255.255.0
    ip nat inside
    ip tcp adjust-mss 1452
    duplex auto
    speed auto
    !
    interface Dialer1
    mtu 1492
    ip address 158.69.142.54 255.255.255.0
    ip nat outside
    encapsulation ppp
    dialer pool 1
    ppp authentication chap pap callin
    ppp chap hostname 27061111
    ppp chap password 0 196581111
    ppp pap sent-username 27061111 password 0 196581111
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 Dialer1
    !
    ip http server
    ip nat inside source list 1 interface Dialer1 overload
    ip nat inside source static tcp 192.168.10.25 8888 interface Dialer1 8888
    !
    access-list 1 permit 192.168.10.0 0.0.0.255
    !
    control-plane
    !
    !
    line con 0
    line aux 0
    line vty 0 4
    login
    !
    end
    Last edited by nekaratal; 21st April 2010, 06:50.

  • #2
    Re: Hello all need help

    ip access-list extended ALLOW_8888
    permit tcp any "your public ip" eq 8888
    permit ip any any

    interface dialer 1
    ip access-group ALLOW_8888 in

    This allows tcp traffic destined to port 8888 inbound and the ip any any permits everything else so adjust accordingly.


    Your static nat statement will handle the translation to the local ip address
    Last edited by auglan; 21st April 2010, 14:21.
    CCNA, CCNA-Security, CCNP
    CCIE Security (In Progress)

    Comment


    • #3
      Re: Hello all need help

      nekaratal,

      In future posts can you please ensure the title is something relevant to the post.

      Thanks

      Michael
      Michael Armstrong
      www.m80arm.co.uk
      MCITP: EA, MCTS, MCSE 2003, MCSA 2003: Messaging, CCA, VCP 3.5, 4, 5, VCAP5-DCD, VCAP5-DCA, ITIL, MCP, PGP Certified Technician

      ** Remember to give credit where credit is due and leave reputation points sigpic where appropriate **

      Comment


      • #4
        Re: port forwarding on cisco router 3845 and 1841 (WAS: Hello all need help )

        thank you very much all, its working now, sorry if i post wrong title i want to edit it but i cant seem to find the edit button, and i dont want to double post. sorry again. hope you all have a great day, many thanks

        Comment

        Working...
        X