Announcement

Collapse
No announcement yet.

Router on a Stick Trunk Config DHCP failing

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Router on a Stick Trunk Config DHCP failing

    I am trying to roll up all our DHCP Servers to 2 servers in the process of doing this I found that the DHCP negotiation is failing if it goes across this trunk between a 2600 and 3550

    The Swichport Config

    interface FastEthernet0/35
    description Uplink to Router
    switchport trunk encapsulation dot1q
    switchport trunk native vlan 5
    switchport trunk allowed vlan 5,10,15,20,200
    switchport mode trunk
    switchport nonegotiate



    the router config

    interface FastEthernet0/1
    no ip address
    ip virtual-reassembly
    no ip route-cache cef
    no ip route-cache
    duplex auto
    speed auto
    !
    interface FastEthernet0/1.1
    encapsulation dot1Q 10
    ip address 192.168.10.1 255.255.255.0
    no ip route-cache
    !
    interface FastEthernet0/1.2
    encapsulation dot1Q 15
    ip address 192.168.15.1 255.255.255.0
    ip virtual-reassembly
    no ip route-cache
    no cdp enable
    !
    interface FastEthernet0/1.3
    description HR
    encapsulation dot1Q 30
    ip address 192.168.30.1 255.255.255.0
    ip virtual-reassembly
    no ip route-cache
    !
    interface FastEthernet0/1.4
    description Accounting
    encapsulation dot1Q 20
    ip address 192.168.20.1 255.255.255.0
    ip access-group 120 in
    ip virtual-reassembly
    no ip route-cache
    !
    interface FastEthernet0/1.5
    description OLD NETWORK
    encapsulation dot1Q 5 native
    ip address 192.168.250.1 255.255.255.0
    ip helper-address 192.168.20.231
    ip virtual-reassembly
    no ip route-cache
    !
    interface FastEthernet0/1.6
    description TestNetwork
    encapsulation dot1Q 200
    ip address 192.168.200.1 255.255.255.0
    ip virtual-reassembly
    no ip route-cache

  • #2
    Re: Router on a Stick Trunk Config DHCP failing

    Try adding the "ip helper-address 192.168.20.231" to the rest of the sub-interfaces. You only have it on FastEthernet 0/1.5
    CCNA, Network+

    Comment

    Working...
    X