Announcement

Collapse
No announcement yet.

cisco 1841 adsl

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • cisco 1841 adsl

    hello
    i have new cisco 1841 router 2 interfaces
    and i am connected to adsl line with static ip from my isp
    what should i do to configure my router to connect to internet with adsl account

    thanks golan

  • #2
    Re: cisco 1841 adsl

    Usually, a cisco router is not so simple to configure... I put here a sample configuration that may work with a static IP... You have to change the MTU and the encapsulation... But it may work if you adapt a little:

    version 12.4
    no service pad
    service tcp-keepalives-in
    service tcp-keepalives-out
    service timestamps debug datetime msec localtime show-timezone
    service timestamps log datetime msec localtime show-timezone
    service password-encryption
    service udp-small-servers
    service tcp-small-servers
    service sequence-numbers
    !
    hostname router
    !
    boot-start-marker
    boot-end-marker
    !
    security authentication failure rate 3 log
    security passwords min-length 6
    logging count
    logging buffered 51200 informational
    logging console critical
    enable secret 5 xxxxxxxxxxxxxxxxxxxxxxxxxxx
    !
    no aaa new-model
    !
    resource policy
    !
    clock timezone pctime 1
    clock summer-time PCTime date Mar 29 2008 2:00 Oct 25 2008 3:00
    ip gratuitous-arps
    ip cef
    !
    !
    !
    !
    ip finger
    ip tcp synwait-time 10
    ip domain name router.com
    ip name-server 80.58.0.33
    ip name-server 80.58.32.97
    ip ssh time-out 60
    ip ssh authentication-retries 2
    ip inspect audit-trail
    !
    !
    !
    username xxxxxxx privilege 15 secret 5 xxxxxxxxxxxxxxxxxxxxxxxxxxxx
    !
    !
    !
    !
    !
    !
    interface ATM0
    no ip address
    ip mask-reply
    ip directed-broadcast
    ip route-cache flow
    no atm ilmi-keepalive
    dsl operating-mode auto
    !
    interface ATM0.1 point-to-point
    ip address "your IP address from provider" 255.255.255.0
    ip mask-reply
    ip directed-broadcast
    no snmp trap link-status
    pvc 8/32
    encapsulation aal5snap
    !
    !
    interface FastEthernet0
    !
    interface FastEthernet1
    !
    interface FastEthernet2
    !
    interface FastEthernet3
    !
    !
    ip route 0.0.0.0 0.0.0.0 ATM0.1
    !
    !
    ip http server
    ip http authentication local
    no ip http secure-server
    ip http timeout-policy idle 60 life 86400 requests 10000
    !
    logging history debugging
    logging "your internal IP address"

    no cdp run
    !
    !
    !
    !
    control-plane
    !
    banner login ^CAuthorized access only!
    Disconnect INMEDIATELY if you are not an authorized user^C
    !
    line con 0
    login local
    no modem enable
    transport output telnet
    line aux 0
    login local
    transport output telnet
    line vty 0 4
    privilege level 15
    login local
    transport input telnet ssh
    !
    scheduler max-task-time 5000
    scheduler allocate 4000 1000
    scheduler interval 500
    ntp server 150.214.94.5
    !
    webvpn context Default_context
    ssl authenticate verify all
    !
    no inservice
    !
    !
    webvpn context default-context
    ssl authenticate verify all
    !
    no inservice
    !
    end


    Good Luck

    Comment

    Working...
    X