Announcement

Collapse
No announcement yet.

Stumped beyond belief - WCCP

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Stumped beyond belief - WCCP

    hey all,

    so you guys have immensely helped me in the past, so i thought i'd propose this situation to you all, maybe it will boggle your mind as much as mine



    i'm setting up redirection via WCCP on IOS (using GNS3 for now). everything works PERFECTLY when using IOS 12.0(4) and the configuration on my linux box. however, when i change to ANY IOS version above 12.0(4), WCCP does not work correctly: the packets are forwarded to the cache engine, but nothing shows up on the GRE interface, only the eth0 interface sees the GRE-encapsulated packets.

    why? how? an earlier IOS 12.0(4) version works, but any and all newer ones dont? since it works with one IOS version and not another, i'm assuming it must be some IOS configuration change that I need to make. but ive tried everything, and am epically stumped.

    12.0(4) running-config (the working one):

    Current configuration:
    !
    version 12.0
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname Router
    !
    !
    ip subnet-zero
    ip wccp web-cache
    ip name-server 209.183.205.35
    !
    !
    !
    !
    !
    !
    !
    interface FastEthernet0/0
    ip address 192.168.9.1 255.255.255.0
    no ip directed-broadcast
    !
    interface FastEthernet1/0
    ip address 192.168.0.5 255.255.255.0
    no ip directed-broadcast
    !
    interface FastEthernet2/0
    ip address 192.168.1.142 255.255.255.0
    no ip directed-broadcast
    ip wccp web-cache redirect out
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 192.168.1.1
    no ip http server
    !
    !
    line con 0
    transport input none
    line aux 0
    line vty 0 4
    !
    end



    12.4(13b) running-config (a random IOS version that doesnt work, similar to all others):
    Current configuration : 813 bytes
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Router
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    memory-size iomem 5
    ip wccp web-cache
    no ip cef
    !
    !
    !
    !
    ip name-server 209.183.205.35
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    interface FastEthernet0/0
    ip address 192.168.9.1 255.255.255.0
    duplex auto
    speed auto
    !
    interface FastEthernet0/1
    ip address 192.168.0.5 255.255.255.0
    duplex auto
    speed auto
    !
    interface FastEthernet1/0
    ip address 192.168.1.149 255.255.255.0
    ip wccp web-cache redirect out
    duplex auto
    speed auto
    !
    !
    ip route 0.0.0.0 0.0.0.0 192.168.1.1
    !
    !
    no ip http server
    no ip http secure-server
    !
    !
    !
    !
    !
    control-plane
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    line con 0
    line aux 0
    line vty 0 4
    !
    !
    end



    NOTES:
    a) both the old and new IOS versions are using WCCPv2, so thats not an issue
    b) noticed the old working IOS has IP CEF disabled by default, so made sure to do so on the new IOS versions, no luck
    c) essentially i copied the EXACT running-configs, as much as possible, from the old IOS to the new IOS versions; still no luck
    d) old, working IOS: eth0 interface on the linux box sees the GRE-encapsulated packet, wccp1 interface (the GRE interface) on the linux box sees the decapsulated packets, iptables then forwards them to the correct application (squid)
    e) new, non-working IOS: eth0 interface on the linux box sees the GRE-encapsulated packet, wccp1 interface sees NOTHING




    i can't figure this out for the life of me. any help would be appreciated, i figured i would let some of you read this and mess with your mind as well as mine

    thanks in advance for any input!

  • #2
    Re: Stumped beyond belief - WCCP

    Hi nick.milako,

    This is quite the mind bender. If you go off the hunch that a the newer versions above 12.0(4) are adding extra commands, can you check the size of the config file when it is working with just 12.0(4) and then again with a newer version? If they are different try using a diff utility and compare the changes.

    That's my $.02

    Ryan

    Comment

    Working...
    X