Announcement

Collapse
No announcement yet.

Cisco router: WAN connection succeeded but not able to access to internet

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cisco router: WAN connection succeeded but not able to access to internet

    WAN connection succeeded but not able to access to internet.

    Router settings:

    router#sh run
    Building configuration...

    Current configuration : 2403 bytes
    !
    version 12.2
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname router
    !
    boot system flash c3640-ik8s-mz.122-11.T10.bin
    enable secret 5 $1$kMCC$syen.xDNh5LXlv.ZJCXu1.
    enable password password
    !
    ip subnet-zero
    !
    !
    ip domain name cisco_dhcp
    ip name-server 192.168.0.1
    ip dhcp excluded-address 192.168.0.1 192.168.0.25
    !
    ip dhcp pool dpool1
    import all
    network 192.168.0.0 255.255.255.0
    default-router 192.168.0.1
    dns-server 192.168.0.1
    !
    vpdn enable
    !
    vpdn-group 1
    request-dialin
    protocol pppoe
    !
    !
    !
    !
    voice call carrier capacity active
    !
    !
    !
    !
    !
    !
    !
    !
    !
    mta receive maximum-recipients 0
    !
    !
    !
    !
    interface Ethernet0/0
    description ADSL LAN Interface
    ip address 192.168.0.3 255.255.255.0
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip nat inside
    no ip mroute-cache
    half-duplex
    no cdp enable
    !
    interface Ethernet0/1
    description ADSL WAN Interface
    no ip address
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip accounting output-packets
    ip nat outside
    no ip mroute-cache
    half-duplex
    pppoe enable
    pppoe-client dial-pool-number 1
    no cdp enable
    !
    interface Dialer1
    description ADSL WAN Dialer
    mtu 1492
    ip address negotiated
    no ip unreachables
    ip nat outside
    encapsulation ppp
    ip route-cache flow
    no ip mroute-cache
    dialer pool 1
    dialer-group 1
    no cdp enable
    ppp authentication chap callin
    ppp chap hostname ****@streamyx
    ppp chap password 0 *****
    ppp pap sent-username ***** password 0 *****
    ppp ipcp dns request accept
    ppp ipcp address accept
    !
    router rip
    version 2
    passive-interface Ethernet0/1
    network 192.168.0.0
    network 192.168.1.0
    !
    ip default-gateway 219.93.218.177
    ip nat inside source list 1 interface Ethernet0/1 overload
    ip nat inside source list 10 interface Dialer1 overload
    ip classless
    ip route 0.0.0.0 0.0.0.0 Dialer1
    ip route 0.0.0.0 0.0.0.0 Ethernet0/1
    ip route 0.0.0.0 0.0.0.0 Ethernet0/0
    no ip http server
    !
    !
    access-list 1 permit 192.168.0.0 0.0.0.255
    access-list 1 permit 0.0.0.0 192.168.0.255
    access-list 1 permit 0.0.0.0 255.255.255.0
    access-list 10 permit 10.10.10.0 0.0.0.255
    dialer-list 1 protocol ip permit
    no cdp run
    !
    snmp-server community public RO
    snmp-server enable traps tty
    call rsvp-sync
    !
    !
    mgcp profile default
    !
    dial-peer cor custom
    !
    !
    !
    !
    !
    line con 0
    line aux 0
    line vty 0 4
    password password
    login
    !
    !
    end


    PPP negotiation DEBUG:
    VPDN event DEBUG:

    *Mar 1 04:14:59.358: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/
    1, changed state to up
    *Mar 1 04:15:25.918: Sending PADI: Interface = Ethernet0/1
    *Mar 1 04:15:25.918: padi timer expired
    *Mar 1 04:15:25.930: PPPoE 0: I PADO L:0002.16e9.3cc2 R:0090.1aa0.63c6 Et0/1
    *Mar 1 04:15:27.930: PPPOE: we've got our pado and the pado timer went off
    *Mar 1 04:15:27.930: OUT PADR from PPPoE tunnel
    *Mar 1 04:15:28.034: PPPoE 5465: I PADS L:0002.16e9.3cc2 R:0090.1aa0.63c6 Et0/1

    *Mar 1 04:15:28.034: IN PADS from PPPoE tunnel
    *Mar 1 04:15:28.034: Vi1 PPP: Phase is DOWN, Setup
    *Mar 1 04:15:28.034: %DIALER-6-BIND: Interface Vi1 bound to profile Di1
    *Mar 1 04:15:28.034: PPPoE: Virtual Access interface obtained.
    *Mar 1 04:15:28.038: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state t
    o up
    *Mar 1 04:15:28.038: Vi1 PPP: Treating connection as a callout
    *Mar 1 04:15:28.038: Vi1 PPP: Phase is ESTABLISHING, Active Open
    *Mar 1 04:15:28.038: Vi1 PPP: No remote authentication for call-out
    *Mar 1 04:15:28.038: Vi1 LCP: O CONFREQ [Closed] id 1 len 14
    *Mar 1 04:15:28.038: Vi1 LCP: MRU 1492 (0x010405D4)
    *Mar 1 04:15:28.038: Vi1 LCP: MagicNumber 0x0300CD1A (0x05060300CD1A)
    *Mar 1 04:15:28.162: Vi1 LCP: I CONFREQ [REQsent] id 234 len 18
    *Mar 1 04:15:28.162: Vi1 LCP: MRU 1492 (0x010405D4)
    *Mar 1 04:15:28.162: Vi1 LCP: AuthProto PAP (0x0304C023)
    *Mar 1 04:15:28.162: Vi1 LCP: MagicNumber 0x12A8A6B7 (0x050612A8A6B7)
    *Mar 1 04:15:28.162: Vi1 LCP: O CONFACK [REQsent] id 234 len 18
    *Mar 1 04:15:28.162: Vi1 LCP: MRU 1492 (0x010405D4)
    *Mar 1 04:15:28.162: Vi1 LCP: AuthProto PAP (0x0304C023)
    *Mar 1 04:15:28.162: Vi1 LCP: MagicNumber 0x12A8A6B7 (0x050612A8A6B7)
    *Mar 1 04:15:28.162: Vi1 LCP: I CONFACK [ACKsent] id 1 len 14
    *Mar 1 04:15:28.162: Vi1 LCP: MRU 1492 (0x010405D4)
    *Mar 1 04:15:28.162: Vi1 LCP: MagicNumber 0x0300CD1A (0x05060300CD1A)
    *Mar 1 04:15:28.166: Vi1 LCP: State is Open
    *Mar 1 04:15:28.166: Vi1 PPP: Phase is AUTHENTICATING, by the peer
    *Mar 1 04:15:28.166: Vi1 PAP: Using hostname from interface PAP
    *Mar 1 04:15:28.166: Vi1 PAP: Using password from interface PAP
    *Mar 1 04:15:28.166: Vi1 PAP: O AUTH-REQ id 1 len 30 from "[email protected]"
    *Mar 1 04:15:28.298: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/
    0, changed state to up
    *Mar 1 04:15:28.454: Vi1 PAP: I AUTH-ACK id 1 len 5
    *Mar 1 04:15:28.454: Vi1 PPP: Phase is FORWARDING, Attempting Forward
    *Mar 1 04:15:28.454: Vi1 PPP: Phase is ESTABLISHING, Finish LCP
    *Mar 1 04:15:28.454: Vi1 PPP: Phase is UP
    *Mar 1 04:15:28.454: Vi1 IPCP: O CONFREQ [Closed] id 1 len 10
    *Mar 1 04:15:28.458: Vi1 IPCP: Address 0.0.0.0 (0x030600000000)
    *Mar 1 04:15:28.470: Vi1 IPCP: I CONFNAK [REQsent] id 1 len 10
    *Mar 1 04:15:28.470: Vi1 IPCP: Address 60.51.95.90 (0x03063C335F5A)
    *Mar 1 04:15:28.470: Vi1 IPCP: O CONFREQ [REQsent] id 2 len 10
    *Mar 1 04:15:28.470: Vi1 IPCP: Address 60.51.95.90 (0x03063C335F5A)
    *Mar 1 04:15:28.482: Vi1 IPCP: I CONFACK [REQsent] id 2 len 10
    *Mar 1 04:15:28.482: Vi1 IPCP: Address 60.51.95.90 (0x03063C335F5A)
    *Mar 1 04:15:28.530: Vi1 IPCP: I CONFREQ [ACKrcvd] id 46 len 10
    *Mar 1 04:15:28.530: Vi1 IPCP: Address 219.93.218.177 (0x0306DB5DDAB1)
    *Mar 1 04:15:28.530: Vi1 IPCP: O CONFACK [ACKrcvd] id 46 len 10
    *Mar 1 04:15:28.530: Vi1 IPCP: Address 219.93.218.177 (0x0306DB5DDAB1)
    *Mar 1 04:15:28.530: Vi1 IPCP: State is Open
    *Mar 1 04:15:28.530: Di1 IPCP: Install negotiated IP interface address 60.51.95
    .90
    *Mar 1 04:15:28.534: Di1 IPCP: Install route to 219.93.218.177
    *Mar 1 04:15:28.534: Vi1 IPCP: Add link info for cef entry 219.93.218.177
    *Mar 1 04:15:29.454: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Ac
    cess1, changed state to up

  • #2
    Re: Cisco router: WAN connection succeeded but not able to access to internet

    Remove this:

    ip route 0.0.0.0 0.0.0.0 Ethernet0/1
    ip route 0.0.0.0 0.0.0.0 Ethernet0/0
    CCNA, Network+

    Comment


    • #3
      Re: Cisco router: WAN connection succeeded but not able to access to internet

      you have multiple conflicting routes configured... that's the first thing that sticks out to me

      ip route 0.0.0.0 0.0.0.0 Dialer1
      ip route 0.0.0.0 0.0.0.0 Ethernet0/1
      ip route 0.0.0.0 0.0.0.0 Ethernet0/0
      Please do show your appreciation to those who assist you by leaving Rep Point https://www.petri.com/forums/core/im.../icon_beer.gif

      Comment


      • #4
        Re: Cisco router: WAN connection succeeded but not able to access to internet

        still couldnt work

        router#sh run
        Building configuration...

        Current configuration : 2294 bytes
        !
        version 12.2
        service timestamps debug datetime msec
        service timestamps log datetime msec
        no service password-encryption
        !
        hostname router
        !
        boot system flash c3640-ik8s-mz.122-11.T10.bin
        enable secret 5 $1$kMCC$syen.xDNh5LXlv.ZJCXu1.
        enable password password
        !
        ip subnet-zero
        !
        !
        ip domain name cisco_dhcp
        ip name-server 192.168.0.1
        ip dhcp excluded-address 192.168.0.1 192.168.0.25
        !
        ip dhcp pool dpool1
        import all
        network 192.168.0.0 255.255.255.0
        default-router 192.168.0.1
        dns-server 192.168.0.1
        !
        vpdn enable
        !
        vpdn-group 1
        request-dialin
        protocol pppoe
        !
        !
        !
        !
        voice call carrier capacity active
        !
        !
        !
        !
        !
        !
        !
        !
        !
        mta receive maximum-recipients 0
        !
        !
        !
        !
        interface Ethernet0/0
        description ADSL LAN Interface
        ip address 192.168.0.3 255.255.255.0
        no ip redirects
        no ip unreachables
        no ip proxy-arp
        ip nat inside
        ip tcp adjust-mss 1452
        no ip mroute-cache
        half-duplex
        no cdp enable
        !
        interface Ethernet0/1
        description ADSL WAN Interface
        no ip address
        no ip redirects
        no ip unreachables
        no ip proxy-arp
        ip accounting output-packets
        ip nat outside
        no ip mroute-cache
        full-duplex
        pppoe enable
        pppoe-client dial-pool-number 1
        no cdp enable
        !
        interface Dialer1
        description ADSL WAN Dialer
        mtu 1492
        ip address negotiated
        no ip unreachables
        ip nat outside
        encapsulation ppp
        ip route-cache flow
        no ip mroute-cache
        dialer pool 1
        dialer-group 1
        no cdp enable
        ppp authentication chap callin
        ppp chap hostname [email protected]
        ppp chap password 0 tmnet123
        ppp pap sent-username [email protected] password 0 tmnet123
        ppp ipcp dns request accept
        ppp ipcp address accept
        !
        router rip
        version 2
        passive-interface Ethernet0/1
        network 192.168.0.0
        network 192.168.1.0
        !
        ip default-gateway 192.168.0.1
        ip nat inside source list 1 interface Ethernet0/0 overload
        ip classless
        ip route 0.0.0.0 0.0.0.0 Dialer1
        no ip http server
        !
        !
        access-list 1 permit 192.168.0.0 0.0.0.255
        access-list 1 permit 0.0.0.0 192.168.0.255
        access-list 1 permit 0.0.0.0 255.255.255.0
        access-list 10 permit 10.10.10.0 0.0.0.255
        dialer-list 1 protocol ip permit
        no cdp run
        !
        snmp-server community public RO
        snmp-server enable traps tty
        call rsvp-sync
        !
        !
        mgcp profile default
        !
        dial-peer cor custom
        !
        !
        !
        !
        !
        line con 0
        line aux 0
        line vty 0 4
        password password
        login
        !
        !
        end

        Comment


        • #5
          Re: Cisco router: WAN connection succeeded but not able to access to internet

          ip default-gateway 192.168.0.1
          what device is this ?
          Please do show your appreciation to those who assist you by leaving Rep Point https://www.petri.com/forums/core/im.../icon_beer.gif

          Comment


          • #6
            Re: Cisco router: WAN connection succeeded but not able to access to internet

            Your NAT is wrong, you're using E0/1 in your statement, it should be Dialer1. Post "sh ip int b" and "sh ip route" please.

            Comment


            • #7
              Re: Cisco router: WAN connection succeeded but not able to access to internet

              DHCP clients are receiving the option "Default gateway" with 192.168.0.3 and your green interface on router (the interface that is pointing to your LAN) has 192.168.0.1 address

              Comment


              • #8
                Re: Cisco router: WAN connection succeeded but not able to access to internet

                Originally posted by cielo View Post
                DHCP clients are receiving the option "Default gateway" with 192.168.0.3 and your green interface on router (the interface that is pointing to your LAN) has 192.168.0.1 address
                You are right, but you have it backwards. He has the "Default Gateway" as 192.168.0.1 and and his internal interface is 192.168.0.3.
                CCNA, Network+

                Comment

                Working...
                X