Announcement

Collapse
No announcement yet.

NAT to mail server not working.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • NAT to mail server not working.

    Hi There

    I am trying to set up one of my cisco routers for NAT translation to my mail server but my client con not connect and I cant see what i'm missing.

    Any help appreciated.

    Here is my config:-

    service timestamps debug uptime
    service timestamps log uptime
    service password-encryption
    !
    hostname Router101.4
    !
    enable secret 5 xxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
    !
    username gkonheiser password 7 xxxxxxxxxxxxxxxxxxxxx
    ip subnet-zero
    !
    !
    ip name-server 62.2.17.60
    ip name-server 62.2.24.162
    !
    !
    controller E1 1/0
    !
    !
    !
    interface FastEthernet0/0
    description WAN
    ip address 62.xxx.xxx.xxx 255.255.255.248
    ip nat outside
    duplex auto
    speed auto
    !
    interface FastEthernet0/1
    description LAN
    ip address 192.168.xxx.223 255.255.255.0
    ip nat inside
    speed 100
    full-duplex
    !
    ip nat inside source list 1 interface FastEthernet0/0 overload
    ip nat inside source static 192.168.xxx.xxx 62.xxx.xxx.xxx
    ip nat inside source static tcp 192.168.xxx.21 25 62.xxx.xxx.xxx 25 extendable
    ip nat inside source static tcp 192.168.xxx.21 443 62.xxx.xxx.xxx 443 extendable
    ip nat inside source static tcp 192.168.xxx.21 80 62.xxx.xxx.xxx 80 extendable
    ip classless
    ip route 0.0.0.0 0.0.0.0 62.xxx.xxx.xxx
    no ip http server
    ip pim bidir-enable
    !
    !
    access-list 1 remark Internet access list
    access-list 1 permit 192.168.xxx.0 0.0.0.255
    access-list 1 remark Internet access list
    access-list 1 remark Internet access list
    !
    line con 0
    password 7 xxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
    login
    line aux 0
    line vty 0 4
    password 7 xxxxxxxxxxxxxxxxxx
    login local
    line vty 5 15
    password 7 xxxxxxxxxxxxxxxxxxxxx
    login local
    !
    !
    end
    Last edited by Hijinxx; 19th November 2009, 16:34.

  • #2
    Re: NAT to mail server not working.

    Does http or https access work?
    CCNA, Network+

    Comment


    • #3
      Re: NAT to mail server not working.

      "ip nat inside source static 192.168.xxx.xxx 62.xxx.xxx.xx "

      I am not sure why you use the above, but remove it from your config as you are doing overload(PAT) and you do not have pool of global addresses then try the next step.


      You can try without adding "extendable" at the end of the statement. If it is added automatically then for sure you should remove the statement above and then try. Usually this is specific translation with "extendable" the config doesn't seems to need it as so your explanation does not shows any signs of its need.
      Try as follows:

      ip nat inside source static tcp 192.168.xxx.21 25 62.xxx.xxx.xxx 25
      ip nat inside source static tcp 192.168.xxx.21 443 62.xxx.xxx.xxx 443
      ip nat inside source static tcp 192.168.xxx.21 80 62.xxx.xxx.xxx 80

      Comment


      • #4
        Re: NAT to mail server not working.

        i think route-map also needs to be used in config

        Comment


        • #5
          Re: NAT to mail server not working.

          Thanks for the help. Ya that line shouldn't have been left in there, I was trying something and forgot to remove it. Will try the NAT without expendable. And will look up Route-map.

          will let you know how I got on.

          Comment


          • #6
            Re: NAT to mail server not working.

            Sorry didn't see your post Daze. No Http and Https do not work.

            Comment

            Working...
            X