Announcement

Collapse
No announcement yet.

configure EtherChannel Between Catalyst 3750G and 4507R

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • configure EtherChannel Between Catalyst 3750G and 4507R

    all slots in 4507R are full and would like to expand using 3750G stack (2 switches).
    problem I have is only gi1/0/24 and gi4/5 connect - rest does not.

    any idea why the EtherChannel does not establish with both links?

    i used this a guideline http://www.cisco.com/en/US/tech/tk38...80094647.shtml

    on3750G side configuration
    Code:
    !
    interface GigabitEthernet1/0/23
     description NWH-CORE-1 <-> NWH-CORE A EtherChannel 1
     switchport mode access
     channel-group 1 mode desirable
    end
    !
    interface GigabitEthernet1/0/24
     description NWH-CORE-1 <-> NWH-CORE B EtherChannel 1
     switchport mode access
     channel-group 1 mode desirable
    end
    !
    interface Port-channel1
     description NWH-CORE-1 <-> NWH-CORE A EtherChannel 1
     switchport mode access
    end

    on 4507R side configuration:
    Code:
    !
    interface GigabitEthernet3/5
     description NWH-CORE <-> NWH-CORE-1 A EtherChannel 31
     switchport mode access
     channel-group 31 mode desirable
    end
    !
    interface GigabitEthernet4/5
     description NWH-CORE <-> NWH-CORE-1 B EtherChannel 31
     switchport mode access
     channel-group 31 mode desirable
    end
    !
    interface Port-channel31
     description NWH-CORE <-> NWH-CORE-1 B EtherChannel 31
     switchport
     switchport mode access
    end
    Last edited by gddl630; 18th November 2009, 19:11.

  • #2
    Re: configure EtherChannel Between Catalyst 3750G and 4507R

    Have you checked the following:

    EtherChannel Configuration Guidelines and Restrictions

    If improperly configured, some EtherChannel interfaces are disabled automatically to avoid network loops and other problems. Follow these guidelines and restrictions to avoid configuration problems:

    •All Ethernet interfaces on all modules support EtherChannel (maximum of eight interfaces) with no requirement that interfaces be physically contiguous or on the same module.

    •Configure all interfaces in an EtherChannel to operate at the same speed and duplex mode.

    •Enable all interfaces in an EtherChannel. If you shut down an interface in an EtherChannel, it is treated as a link failure and its traffic is transferred to one of the remaining interfaces in the EtherChannel.

    •An EtherChannel will not form if one of the interfaces is a Switched Port Analyzer (SPAN) destination port.

    •For Layer 3 EtherChannels:

    –Assign Layer 3 addresses to the port-channel logical interface, not to the physical interfaces in the channel.

    •For Layer 2 EtherChannels:

    –Assign all interfaces in the EtherChannel to the same VLAN, or configure them as trunks.

    –If you configure an EtherChannel from trunk interfaces, verify that the trunking mode is the same on all the trunks. Interfaces in an EtherChannel with different trunk modes can have unexpected results.

    –An EtherChannel supports the same allowed range of VLANs on all the interfaces in a trunking Layer 2 EtherChannel. If the allowed range of VLANs is not the same, the interfaces do not form an EtherChannel even when set to the auto or desirable mode.

    –Interfaces with different Spanning Tree Protocol (STP) port path costs can form an EtherChannel as long they are otherwise compatibly configured. Setting different STP port path costs does not, by itself, make interfaces incompatible for the formation of an EtherChannel.

    •After you configure an EtherChannel, any configuration that you apply to the port-channel interface affects the EtherChannel; any configuration that you apply to the physical interfaces affects only the interface where you apply the configuration.

    Source:
    http://www.cisco.com/en/US/docs/swit...html#wp1020420

    Comment

    Working...
    X