No announcement yet.

ShoreTel Ascom wireless phones not talk'n to ShoreTel, 4 SOME Cisco WAP 1242G

  • Filter
  • Time
  • Show
Clear All
new posts

  • ShoreTel Ascom wireless phones not talk'n to ShoreTel, 4 SOME Cisco WAP 1242G

    We recently installed ShoreTel VoIP and the Ascom wireless phones work fine on selected Cisco WAP 1242G. But on others that are configured exactly the same:
    - Symptom 1 - they only obtain an IP, but never actually talk to ShoreTel.
    - Symptom 2 - moving from one WAP signal to another it will not resync to new WAP and obtain a new IP.
    - Symptom 3 - If it is on the same Subnet (not requiring new IP) then it 'may' migrate and use 2nd WAP.

    The WAP 1242G is connected to Cisco 3560, then to 3750 then to 6509 then down to 3750 then ShoreTel. I can have 2 WAP just feet apart on the same 3750 and the 2nd one does not work. It says "No Access" but does obtain a valid IP. Then on other WAP it will only obtain an IP if power reset, then it will get the IP and be able to talk.

    I have copied 99.9% of each config across all 1242, 3560 and 3750; still something seems to be different.

    Don't think it could be IP/DHCP related.
    - 10.8.8.x works on 2 of 3 WAP
    - 10.9.8.x works on 1 of 3 WAP
    - 10.10.8.x works on 1 of 2 WAP
    - 10.11.8.x works on 2 of 2 WAP
    - 10.12.8.x still to be fully configured (so this may be good test environment)

    - Cisco WAP AIR-AP1242AG-A-K9 - in autonomous mode
    C1240-K9W7-M, Version 12.4(10b)JDA,
    - Cisco 3750 - IPSERVICESK9-M, Version 12.2(50)SE2
    - Cisco 3560 - IPSERVICESK9-M, Version 12.2(50)SE
    - Ascom Wireless handset

    - Always get IP, some 'may' require power cycle to obtain.
    - Symptom 1 - says "No Access" but does show correct IP
    - Symptom 2 - shows full signal but does not migrate to new WAP for new IP
    ..does not ping because it has invalid IP from previous WAP
    - Display shows 100% (3 bar) signal
    - Active phones DO ping successfully
    - Transition from one WAP to another will not obtain new IP/connection
    ..power cycle will obtain new IP

    Ideas I have not completely tested yet:
    - See if they respond to PING when "No Access" with correct IP
    - See if ShoreTel sees "No Access" phones

    - Are there key settings needed for 3560/3750
    - Are there key settings for WAP 1242
    Some common Config settings on 3560/3750 (not all)
    mls qos map cos-dscp 0 8 16 26 32 46 48 56
    mls qos
    spanning-tree mode rapid-pvst
    spanning-tree etherchannel guard misconfig
    spanning-tree extend system-id
    spanning-tree vlan 4,40,44,48,56 priority 24576
    spanning-tree vlan 8,28,64 priority 28672
    3560 unique config
    interface FastEthernet0/14
    description AIR-AP1242AG
    switchport access vlan 48
    switchport trunk encapsulation dot1q
    switchport trunk native vlan 48
    switchport trunk allowed vlan 4,8,46,48
    switchport mode trunk
    switchport voice vlan 8
    mls qos trust dscp
    spanning-tree portfast
    interface Vlan8
    description Voice/VOIP Vlan
    no ip address
    3750 unique config
    interface GigabitEthernet1/0/3
    description hq-fac-3560-24PS-1 g0/1
    switchport trunk encapsulation dot1q
    switchport trunk native vlan 4
    switchport mode trunk
    mls qos trust dscp
    interface Vlan8
    description Voice/VOIP Vlan
    ip address
    ip helper-address
    no ip redirects
    standby 8 ip
    standby 8 timers 1 3
    standby 8 preempt
    router eigrp 100
    passive-interface Vlan4
    passive-interface Vlan8
    passive-interface Vlan28
    . . . . . and other vlans....
    no eigrp log-neighbor-changes

  • #2
    Cisco WAP 1242G connected to 3560 not allowing Ascom Wireless phones to connect.

    Suspect this may be a vlan or trunk issue on the 3560 or WAP 1242AG. Not sure why sometimes they get an IP but still will not connect to ShoreTel switch and send traffic.