Announcement

Collapse
No announcement yet.

policy route map on router with PPPoE and LeasedLine on FE0 FE1

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • policy route map on router with PPPoE and LeasedLine on FE0 FE1

    I am trying to route all http,https via an ADSL connection and all other traffic via a leased line.

    It is a 1801 router with Fastethernet 0 configured for pppoe. I configured this first and I am able to browse etc. Then I shut this int down and configured fastethernet1 as vlan 11 with IP provided by ISP and was able to browse etc.

    I decided to add a route policy as shown in the config and applied it on int vlan 10. I see hits happening on the adsl however not able to browse. Any advice most appreciated.

    ip cef
    no ip domain lookup
    no ipv6 cef
    !
    multilink bundle-name authenticated
    !
    vpdn enable
    !
    vpdn-group 1
    request-dialin
    protocol pppoe
    !
    !
    !
    !
    archive
    log config
    hidekeys
    !
    !
    !
    !
    !
    interface ATM0
    no ip address
    shutdown
    no atm ilmi-keepalive
    !
    interface BRI0
    no ip address
    encapsulation hdlc
    shutdown
    !
    interface FastEthernet0
    no ip address
    **** ADSL connection ***
    duplex auto
    speed auto
    pppoe enable group global
    pppoe-client dial-pool-number 1
    !
    interface FastEthernet1
    **** LEASED LINE ****
    switchport access vlan 11
    !
    interface FastEthernet2
    ****** Connected to LAN *****
    switchport access vlan 10
    !
    interface FastEthernet3
    !
    interface FastEthernet4
    !
    interface FastEthernet5
    !
    interface FastEthernet6
    !
    interface FastEthernet7
    !
    interface FastEthernet8
    !
    interface Vlan1
    no ip address
    !
    interface Vlan10
    *** LAN side ***
    ip address 11.11.11.153 255.255.255.248
    ip nat inside
    ip virtual-reassembly
    !
    interface Vlan11
    *** ISP ***
    ip address 8.11.88.55.255.255.252
    !
    interface Dialer1
    ip address negotiated
    ip nat outside
    ip virtual-reassembly
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    ppp authentication chap pap callin
    ppp pap sent-username us89801 password 7 04589237428972379834
    ppp ipcp address accept
    !
    ip forward-protocol nd
    ip route 0.0.0.0 0.0.0.0 to ISP router
    ip http server
    ip http secure-server
    !
    !
    ip nat inside source list 1 interface Dialer1 overload
    !
    ip access-list extended adsl
    permit tcp any any eq www
    permit tcp any any eq 443
    permit udp any any eq domain
    permit tcp any any eq domain
    !
    access-list 1 permit 11.11.11.152 0.0.0.8
    dialer-list 1 protocol ip permit
    !
    !
    !
    !
    route-map divert2adsl permit 10
    match ip address adsl
    set interface FastEthernet0
    !
    route-map divert2adsl permit 20
    set default interface FastEthernet1
    !
    !
    !
    control-plane
    !
    !
    line con 0
    line aux 0
    line vty 0 4

    Regards
Working...
X