Announcement

Collapse
No announcement yet.

Cisco 857W NOT WORKING - DHCP NOT WORKING? - Please help

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cisco 857W NOT WORKING - DHCP NOT WORKING? - Please help

    Hi...

    Please go easy on me as I am both New to this forum and New to Cisco Routers. (But always willing to learn.)

    I have purchased a Cisco 857W and have attempted to configure it. First I tried to use the SDM without much success. Then I used the CLI and loaded a modified version of UNCLE BOB's config off a previous post.

    I hoped that DHCP would be working and I could now connect my computer to one of the Fast Ethernet ports getting an IP address. I don't! (I just get the Limited or No Connectivity alert in windows).
    I have tried to use a fixed IP address on the PC , also with no joy!

    *The WIRELESS network is not found by windows either*

    Here is my config: ( help would be greatly appreciated )

    CISCO#show startup-config
    Using 4098 out of 131072 bytes
    !
    version 12.4
    no service pad
    service tcp-keepalives-in
    service tcp-keepalives-out
    service timestamps debug uptime
    service timestamps log uptime
    service password-encryption
    service sequence-numbers
    !
    hostname CISCO
    !
    boot-start-marker
    boot-end-marker
    !
    logging buffered 10240 debugging
    logging console critical
    !
    no aaa new-model
    !
    resource policy
    !
    clock timezone PCTime 0
    clock summer-time PCTime date Mar 30 2003 1:00 Oct 26 2003 2:00
    no ip source-route
    no ip dhcp use vrf connected
    ip dhcp excluded-address 192.168.1.1 192.168.1.99
    ip dhcp excluded-address 192.168.1.254
    !
    ip dhcp pool dhcppool
    import all
    network 192.168.1.0 255.255.255.0
    default-router 192.168.1.254
    update arp
    !
    !
    ip cef
    ip inspect name firewall tcp
    ip inspect name firewall udp
    ip inspect name firewall cuseeme
    ip inspect name firewall h323
    ip inspect name firewall rcmd
    ip inspect name firewall realaudio
    ip inspect name firewall streamworks
    ip inspect name firewall vdolive
    ip inspect name firewall sqlnet
    ip inspect name firewall tftp
    ip inspect name firewall ftp
    ip inspect name firewall icmp
    ip inspect name firewall sip
    ip inspect name firewall esmtp max-data 52428800
    ip inspect name firewall fragment maximum 256 timeout 1
    ip inspect name firewall pptp
    ip inspect name firewall rtsp
    ip tcp selective-ack
    ip tcp timestamp
    no ip bootp server
    no ip domain lookup
    ip domain name local
    !
    !
    !
    file verify auto
    !
    !
    !
    bridge irb
    !
    !
    interface ATM0
    no ip address
    shutdown
    no atm ilmi-keepalive
    dsl operating-mode auto
    !
    interface ATM0.1 point-to-point
    no snmp trap link-status
    pvc 0/100
    encapsulation aal5mux ppp dialer
    dialer pool-member 1
    !
    !
    interface FastEthernet0
    !
    interface FastEthernet1
    !
    interface FastEthernet2
    !
    interface FastEthernet3
    !
    interface Dot11Radio0
    no ip address
    shutdown
    !
    encryption mode ciphers tkip
    !
    ssid Cisco 857W
    authentication open
    authentication key-management wpa
    guest-mode
    wpa-psk ascii 7 096465253E37253021
    !
    speed basic-1.0 basic-2.0 basic-5.5 basic-6.0 basic-9.0 basic-11.0 basic-12.0 b
    asic-18.0 basic-24.0 basic-36.0 basic-48.0 basic-54.0
    station-role root
    no cdp enable
    bridge-group 1
    bridge-group 1 subscriber-loop-control
    bridge-group 1 spanning-disabled
    bridge-group 1 block-unknown-source
    no bridge-group 1 source-learning
    no bridge-group 1 unicast-flooding
    !
    interface Vlan1
    no ip address
    bridge-group 1
    bridge-group 1 spanning-disabled
    !
    interface Dialer0
    ip address negotiated
    ip access-group 101 in
    no ip redirects
    no ip unreachables
    ip inspect firewall out
    ip nat outside
    ip virtual-reassembly
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    no cdp enable
    ppp authentication chap pap callin
    ppp chap hostname ***************
    ppp chap password ***************
    ppp pap sent-username ************* password *************
    !
    interface BVI1
    ip address 192.168.1.254 255.255.255.0
    ip access-group 102 in
    ip nat inside
    ip virtual-reassembly
    !
    ip route 0.0.0.0 0.0.0.0 Dialer0
    !
    no ip http server
    no ip http secure-server
    ip nat inside source list 1 interface Dialer0 overload
    !
    access-list 1 remark The local LAN.
    access-list 1 permit 192.168.1.0 0.0.0.255
    access-list 2 remark Where management can be done from.
    access-list 2 permit 192.168.1.0 0.0.0.255
    access-list 101 remark Traffic allowed to enter the router from the Internet
    access-list 101 deny ip 0.0.0.0 0.255.255.255 any
    access-list 101 deny ip 10.0.0.0 0.255.255.255 any
    access-list 101 deny ip 127.0.0.0 0.255.255.255 any
    access-list 101 deny ip 169.254.0.0 0.0.255.255 any
    access-list 101 deny ip 172.16.0.0 0.15.255.255 any
    access-list 101 deny ip 192.0.2.0 0.0.0.255 any
    access-list 101 deny ip 192.168.0.0 0.0.255.255 any
    access-list 101 deny ip 198.18.0.0 0.1.255.255 any
    access-list 101 permit gre any any
    access-list 101 deny icmp any any echo
    access-list 101 deny ip any any log
    access-list 102 remark Traffic allowed to enterlist 102 deny udp any any eq 138
    log
    !
    control-plane
    !
    !
    line con 0
    no modem enable
    line aux 0
    line vty 0 4
    access-class 2 in
    login
    !
    scheduler max-task-time 5000
    end



    Please help!

    David

  • #2
    Re: Cisco 857W NOT WORKING - DHCP NOT WORKING? - Please help

    Your ATM0 and Dot11Radio0 interfaces are "shutdown" so you will need to enable these.

    Access-list 102 is applied to the BVI1 interface which is denying everything so you will need to remove this.

    Access-list 101 is also denying all traffic from the internet so you should amend that too. 101 should look more like this:

    access-list 101 remark Traffic allowed to enter the router from the Internet
    access-list 101 deny ip 10.0.0.0 0.255.255.255 any
    access-list 101 deny ip 127.0.0.0 0.255.255.255 any
    access-list 101 deny ip 169.254.0.0 0.0.255.255 any
    access-list 101 deny ip 172.16.0.0 0.15.255.255 any
    access-list 101 deny ip 192.168.0.0 0.0.255.255 any
    access-list 101 deny icmp any any echo
    access-list 101 permit ip any any
    access-list 101 permit gre any any
    Infrastructure Architect
    CCNA, CCNA Security, MCSE, JNCIS

    Comment


    • #3
      Re: Cisco 857W NOT WORKING - DHCP NOT WORKING? - Please help

      Thsnk you so much for replying to my thread so quick. I have made so adjustments. Does this look better now below? Should I get an IP Address leased to my PC? I will upload this config in a minute and reply with results...

      Also, I have a static IP Address with my ADSL2+ broadband that I would like to include. Where and what would I put in the config?

      Last one... I host a web server and would like all incoming port 80 and ftp trafic to be forwarded to it at 192.168.1.100. Please help....

      !
      version 12.4
      no service pad
      service tcp-keepalives-in
      service tcp-keepalives-out
      service timestamps debug uptime
      service timestamps log uptime
      service password-encryption
      service sequence-numbers
      !
      hostname CISCO
      !
      boot-start-marker
      boot-end-marker
      !
      logging buffered 10240 debugging
      logging console critical
      !
      no aaa new-model
      !
      resource policy
      !
      clock timezone PCTime 0
      clock summer-time PCTime date Mar 30 2003 1:00 Oct 26 2003 2:00
      no ip source-route
      no ip dhcp use vrf connected
      ip dhcp excluded-address 192.168.1.1 192.168.1.99
      ip dhcp excluded-address 192.168.1.254
      !
      ip dhcp pool dhcppool
      import all
      network 192.168.1.0 255.255.255.0
      default-router 192.168.1.254
      update arp
      !
      !
      ip cef
      ip inspect name firewall tcp
      ip inspect name firewall udp
      ip inspect name firewall cuseeme
      ip inspect name firewall h323
      ip inspect name firewall rcmd
      ip inspect name firewall realaudio
      ip inspect name firewall streamworks
      ip inspect name firewall vdolive
      ip inspect name firewall sqlnet
      ip inspect name firewall tftp
      ip inspect name firewall ftp
      ip inspect name firewall icmp
      ip inspect name firewall sip
      ip inspect name firewall esmtp max-data 52428800
      ip inspect name firewall fragment maximum 256 timeout 1
      ip inspect name firewall pptp
      ip inspect name firewall rtsp
      ip tcp selective-ack
      ip tcp timestamp
      no ip bootp server
      no ip domain lookup
      ip domain name local
      !
      !
      !
      file verify auto
      !
      !
      !
      bridge irb
      !
      !
      interface ATM0
      no ip address
      no shutdown
      no atm ilmi-keepalive
      dsl operating-mode auto
      !
      interface ATM0.1 point-to-point
      no snmp trap link-status
      pvc 0/100
      encapsulation aal5mux ppp dialer
      dialer pool-member 1
      !
      !
      interface FastEthernet0
      !
      interface FastEthernet1
      !
      interface FastEthernet2
      !
      interface FastEthernet3
      !
      interface Dot11Radio0
      no ip address
      no shutdown
      !
      encryption mode ciphers tkip
      !
      ssid Cisco 857W
      authentication open
      authentication key-management wpa
      guest-mode
      wpa-psk ascii 7 096465253E37253021
      !
      speed basic-1.0 basic-2.0 basic-5.5 basic-6.0 basic-9.0 basic-11.0 basic-12.0 b
      asic-18.0 basic-24.0 basic-36.0 basic-48.0 basic-54.0
      station-role root
      no cdp enable
      bridge-group 1
      bridge-group 1 subscriber-loop-control
      bridge-group 1 spanning-disabled
      bridge-group 1 block-unknown-source
      no bridge-group 1 source-learning
      no bridge-group 1 unicast-flooding
      !
      interface Vlan1
      no ip address
      bridge-group 1
      bridge-group 1 spanning-disabled
      !
      interface Dialer0
      ip address negotiated
      ip access-group 101 in
      no ip redirects
      no ip unreachables
      ip inspect firewall out
      ip nat outside
      ip virtual-reassembly
      encapsulation ppp
      dialer pool 1
      dialer-group 1
      no cdp enable
      ppp authentication chap pap callin
      ppp chap hostname ***************
      ppp chap password ***************
      ppp pap sent-username ************* password *************
      !
      interface BVI1
      ip address 192.168.1.254 255.255.255.0
      ip nat inside
      ip virtual-reassembly
      !
      ip route 0.0.0.0 0.0.0.0 Dialer0
      !
      no ip http server
      no ip http secure-server
      ip nat inside source list 1 interface Dialer0 overload
      !
      access-list 1 remark The local LAN.
      access-list 1 permit 192.168.1.0 0.0.0.255
      access-list 2 remark Where management can be done from.
      access-list 2 permit 192.168.1.0 0.0.0.255
      access-list 101 remark Traffic allowed to enter the router from the Internet
      access-list 101 remark Traffic allowed to enter the router from the Internet
      access-list 101 deny ip 10.0.0.0 0.255.255.255 any
      access-list 101 deny ip 127.0.0.0 0.255.255.255 any
      access-list 101 deny ip 169.254.0.0 0.0.255.255 any
      access-list 101 deny ip 172.16.0.0 0.15.255.255 any
      access-list 101 deny ip 192.168.0.0 0.0.255.255 any
      access-list 101 deny icmp any any echo
      access-list 101 permit ip any any
      access-list 101 permit gre any any
      access-list 102 remark Traffic allowed to enterlist 102 deny udp any any eq 138
      log
      !
      control-plane
      !
      !
      line con 0
      no modem enable
      line aux 0
      line vty 0 4
      access-class 2 in
      login
      !
      scheduler max-task-time 5000
      end

      Comment


      • #4
        Re: Cisco 857W NOT WORKING - DHCP NOT WORKING? - Please help

        Still no DHCP through Wireless (now showing) or Ethernet?
        Bridging or VLAN issue?

        Here is my current statup-config (and boot information):


        System Bootstrap, Version 12.3(8r)YI2, RELEASE SOFTWARE
        Technical Support: http://www.cisco.com/techsupport
        Copyright (c) 2005 by cisco Systems, Inc.
        C850 series (Board ID: 2-149) platform with 65536 Kbytes of main memory
        Booting flash:/c850-advsecurityk9-mz.124-6.T3.bin
        Self decompressing the image : #################################################
        ####################### [OK]
        Restricted Rights Legend
        Use, duplication, or disclosure by the Government is
        subject to restrictions as set forth in subparagraph
        (c) of the Commercial Computer Software - Restricted
        Rights clause at FAR sec. 52.227-19 and subparagraph
        (c) (1) (ii) of the Rights in Technical Data and Computer
        Software clause at DFARS sec. 252.227-7013.
        cisco Systems, Inc.
        170 West Tasman Drive
        San Jose, California 95134-1706

        Cisco IOS Software, C850 Software (C850-ADVSECURITYK9-M), Version 12.4(6)T3, REL
        EASE SOFTWARE (fc2)
        Technical Support: http://www.cisco.com/techsupport
        Copyright (c) 1986-2006 by Cisco Systems, Inc.
        Compiled Fri 21-Jul-06 20:21 by kellythw
        Image text-base: 0x8002008C, data-base: 0x812D2C10

        This product contains cryptographic features and is subject to United
        States and local country laws governing import, export, transfer and
        use. Delivery of Cisco cryptographic products does not imply
        third-party authority to import, export, distribute or use encryption.
        Importers, exporters, distributors and users are responsible for
        compliance with U.S. and local country laws. By using this product you
        agree to comply with applicable laws and regulations. If you are unable
        to comply with U.S. and local laws, return this product immediately.
        A summary of U.S. laws governing Cisco cryptographic products may be found at:
        http://www.cisco.com/wwl/export/crypto/tool/stqrg.html
        If you require further assistance please contact us by sending email to
        [email protected].
        Cisco 857W (MPC8272) processor (revision 0x200) with 59392K/6144K bytes of memor
        y.
        Processor board ID FCZ103250J5
        MPC8272 CPU Rev: Part Number 0xC, Mask Number 0x10
        4 FastEthernet interfaces
        1 ATM interface
        1 802.11 Radio
        128K bytes of non-volatile configuration memory.
        20480K bytes of processor board System flash (Intel Strataflash)
        %NAT: Error activating CNBAR on the interface Dialer0
        %NAT: Error activating CNBAR on the interface BVI1

        Press RETURN to get started!

        CISCO>enable
        CISCO#show startup-config
        Using 4822 out of 131072 bytes
        !
        version 12.4
        no service pad
        service tcp-keepalives-in
        service tcp-keepalives-out
        service timestamps debug uptime
        service timestamps log uptime
        service password-encryption
        service sequence-numbers
        !
        hostname CISCO
        !
        boot-start-marker
        boot-end-marker
        !
        logging buffered 10240 debugging
        logging console critical
        !
        no aaa new-model
        !
        resource policy
        !
        clock timezone PCTime 0
        clock summer-time PCTime date Mar 30 2003 1:00 Oct 26 2003 2:00
        no ip source-route
        no ip dhcp use vrf connected
        ip dhcp excluded-address 192.168.1.1 192.168.1.99
        ip dhcp excluded-address 192.168.1.254
        !
        ip dhcp pool dhcppool
        import all
        network 192.168.1.0 255.255.255.0
        default-router 192.168.1.254
        update arp
        !
        !
        ip cef
        ip inspect name firewall tcp
        ip inspect name firewall udp
        ip inspect name firewall cuseeme
        ip inspect name firewall h323
        ip inspect name firewall rcmd
        ip inspect name firewall realaudio
        ip inspect name firewall streamworks
        ip inspect name firewall vdolive
        ip inspect name firewall sqlnet
        ip inspect name firewall tftp
        ip inspect name firewall ftp
        ip inspect name firewall icmp
        ip inspect name firewall sip
        ip inspect name firewall esmtp max-data 52428800
        ip inspect name firewall fragment maximum 256 timeout 1
        ip inspect name firewall pptp
        ip inspect name firewall rtsp
        ip tcp selective-ack
        ip tcp timestamp
        no ip bootp server
        no ip domain lookup
        ip domain name local
        !
        !
        !
        file verify auto
        !
        !
        !
        bridge irb
        !
        !
        interface ATM0
        no ip address
        no atm ilmi-keepalive
        dsl operating-mode auto
        !
        interface ATM0.1 point-to-point
        no snmp trap link-status
        pvc 0/100
        encapsulation aal5mux ppp dialer
        dialer pool-member 1
        !
        !
        interface FastEthernet0
        !
        interface FastEthernet1
        !
        interface FastEthernet2
        !
        interface FastEthernet3
        !
        interface Dot11Radio0
        no ip address
        !
        encryption mode ciphers tkip
        !
        ssid Cisco 857W
        authentication open
        authentication key-management wpa
        guest-mode
        wpa-psk ascii 7 096465253E37253021
        !
        speed basic-1.0 basic-2.0 basic-5.5 basic-6.0 basic-9.0 basic-11.0 basic-12.0 b
        asic-18.0 basic-24.0 basic-36.0 basic-48.0 basic-54.0
        station-role root
        no cdp enable
        bridge-group 1
        bridge-group 1 subscriber-loop-control
        bridge-group 1 spanning-disabled
        bridge-group 1 block-unknown-source
        no bridge-group 1 source-learning
        no bridge-group 1 unicast-flooding
        !
        interface Vlan1
        no ip address
        bridge-group 1
        bridge-group 1 spanning-disabled
        !
        interface Dialer0
        ip address negotiated
        ip access-group 101 in
        no ip redirects
        no ip unreachables
        ip inspect firewall out
        ip nat outside
        ip virtual-reassembly
        encapsulation ppp
        dialer pool 1
        dialer-group 1
        no cdp enable
        ppp authentication chap pap callin
        ppp chap hostname ************
        ppp chap password *************
        ppp pap sent-username ********* password ****************
        !
        interface BVI1
        ip address 192.168.1.254 255.255.255.0
        ip access-group 102 in
        ip nat inside
        ip virtual-reassembly
        !
        ip route 0.0.0.0 0.0.0.0 Dialer0
        !
        no ip http server
        no ip http secure-server
        ip nat inside source list 1 interface Dialer0 overload
        !
        access-list 1 remark The local LAN.
        access-list 1 permit 192.168.1.0 0.0.0.255
        access-list 2 remark Where management can be done from.
        access-list 2 permit 192.168.1.0 0.0.0.255
        access-list 101 remark Traffic allowed to enter the router from the Internet
        access-list 101 deny ip 0.0.0.0 0.255.255.255 any
        access-list 101 deny ip 10.0.0.0 0.255.255.255 any
        access-list 101 deny ip 127.0.0.0 0.255.255.255 any
        access-list 101 deny ip 169.254.0.0 0.0.255.255 any
        access-list 101 deny ip 172.16.0.0 0.15.255.255 any
        access-list 101 deny ip 192.0.2.0 0.0.0.255 any
        access-list 101 deny ip 192.168.0.0 0.0.255.255 any
        access-list 101 deny ip 198.18.0.0 0.1.255.255 any
        access-list 101 permit gre any any
        access-list 101 deny icmp any any echo
        access-list 101 deny ip any any log
        access-list 101 remark Traffic allowed to enter the router from the Internet
        access-list 101 remark Traffic allowed to enter the router from the Internet
        access-list 101 remark Traffic allowed to enter the router from the Internet
        access-list 101 remark Traffic allowed to enter the router from the Internet
        access-list 101 permit ip any any
        access-list 101 remark Traffic allowed to enter the router from the Internet
        access-list 101 remark Traffic allowed to enter the router from the Internet
        access-list 102 remark Traffic allowed to enterlist 102 deny udp any any eq 138
        log
        access-list 102 remark Traffic allowed to enterlist 102 deny udp any any eq 138
        access-list 102 remark Traffic allowed to enterlist 102 deny udp any any eq 138
        log
        access-list 102 remark Traffic allowed to enterlist 102 deny udp any any eq 138
        log
        !
        control-plane
        !
        !
        line con 0
        no modem enable
        line aux 0
        line vty 0 4
        access-class 2 in
        login
        !
        scheduler max-task-time 5000
        end


        ********************************************

        I still need to specify my STATIC IP, DNS SERVERS and also let web trafic through to my web server at: 192.168.1.100

        Please help?

        Comment


        • #5
          Re: Cisco 857W NOT WORKING - DHCP NOT WORKING? - Please help

          please compare your config with:
          http://forums.petri.com/showthread.php?t=20841
          Marcel
          Technical Consultant
          Netherlands
          http://www.phetios.com
          http://blog.nessus.nl

          MCITP(EA, SA), MCSA/E 2003:Security, CCNA, SNAF, DCUCI, CCSA/E/E+ (R60), VCP4/5, NCDA, NCIE - SAN, NCIE - BR, EMCPE
          "No matter how secure, there is always the human factor."

          "Enjoy life today, tomorrow may never come."
          "If you're going through hell, keep going. ~Winston Churchill"

          Comment


          • #6
            Re: Cisco 857W NOT WORKING - DHCP NOT WORKING? - Please help

            You have not amended the access-lists correctly this is the reason why DHCP is not working. Do the following:

            interface BVI1
            no ip access-group 102 in

            no access-list 101
            no access-list 102

            access-list 101 remark Traffic allowed to enter the router from the Internet
            access-list 101 deny ip 10.0.0.0 0.255.255.255 any
            access-list 101 deny ip 127.0.0.0 0.255.255.255 any
            access-list 101 deny ip 169.254.0.0 0.0.255.255 any
            access-list 101 deny ip 172.16.0.0 0.15.255.255 any
            access-list 101 deny ip 192.168.0.0 0.0.255.255 any
            access-list 101 deny icmp any any echo
            access-list 101 permit ip any any
            access-list 101 permit gre any any
            Infrastructure Architect
            CCNA, CCNA Security, MCSE, JNCIS

            Comment


            • #7
              Re: Cisco 857W NOT WORKING - DHCP NOT WORKING? - Please help

              Would you be able to put that in the config so I can erase and start again by just copying one config file into the console? (obviously I will have to put my own password in etc...)

              Sorry... Really Struggling...

              Comment


              • #8
                Re: Cisco 857W NOT WORKING - DHCP NOT WORKING? - Please help

                You do not need to erase and put the whole config in again. If you just copy the lines below and then paste into your session it will make the relevant changes. Nothing else will be changed on your config apart from these lines. If you change the x.x.x.x for the relevant addresses i.e. DNS and static WAN this will be done too.

                You will need to be in global configuration mode i.e. (Router#)


                interface BVI1
                no ip access-group 102 in
                !
                no access-list 101
                no access-list 102
                !
                access-list 101 remark Traffic allowed to enter the router from the Internet
                access-list 101 deny ip 10.0.0.0 0.255.255.255 any
                access-list 101 deny ip 127.0.0.0 0.255.255.255 any
                access-list 101 deny ip 169.254.0.0 0.0.255.255 any
                access-list 101 deny ip 172.16.0.0 0.15.255.255 any
                access-list 101 deny ip 192.168.0.0 0.0.255.255 any
                access-list 101 deny icmp any any echo
                access-list 101 permit ip any any
                access-list 101 permit gre any any
                !
                interface Dialer0
                no ip address negotiated
                ip address x.x.x.x x.x.x.x (put ip address then subnet mask here)
                !
                ip name-server x.x.x.x
                Infrastructure Architect
                CCNA, CCNA Security, MCSE, JNCIS

                Comment


                • #9
                  Re: Cisco 857W NOT WORKING - DHCP NOT WORKING? - Please help

                  This is one of those tough lessons we all must learn.

                  Experienced network admins bring a new device on line one stage at a time. I.E, you bring the WAN and LAN on first. Do Not worry about security. Get things such as Web Browsing, DNS and DHCP working first. Use simple Access-Lists.

                  Once the LAN/WAN aspects are working, bring the WLAN on again with no security to confirm operations, once Browsing, DNS, DHCP are working, secure the wireless.

                  Now is the time to begin performing Global Security Configuration: Extended access-lists and such.

                  If one follows these steps, many of the configuration headaches can be avoided.

                  Access lists are one of the things that are critical to the operation and security of routers.

                  Basically, if you have not already resolved the issue by the advice offered in previous posts, I would kill all access-list entries with the exception of

                  access-list 1 permit 192.168.1.0 0.0.0.255

                  If this does not bring up the basic functionallity you are lookinf for, then look to how the VLAN and BVI interfaces are set up.

                  Just a thought.

                  Blindly copying a configuration from a forum and pasting it into your config without understanding what the config actually does is by itself a recipe for disaster. There is no guarantee that the config was correct in the first place.

                  John

                  Comment


                  • #10
                    Re: Cisco 857W NOT WORKING - DHCP NOT WORKING? - Please help

                    Hi BigDeesDad & hermeszdata...

                    ***I HAVE A BIG SMILE ON MY FACE***

                    Thanks so far for your EXPERT advice. I am now getting a DHCP address from bothe wireles and eithernet. Unfortunately I am in the office with the router and will not be able to test on the ADSL2+ connection now till monday night!

                    *Please would you help me to forward all web traffic to my web server at 192.168.1.100 (happy to use different address if needed).*

                    Here is the current config of the router: (if anything else looks wrong, please advise)

                    Config:

                    CISCO857W>enable
                    CISCO857W#show config
                    Using 3843 out of 131072 bytes
                    !
                    version 12.4
                    no service pad
                    service tcp-keepalives-in
                    service tcp-keepalives-out
                    service timestamps debug uptime
                    service timestamps log uptime
                    service password-encryption
                    service sequence-numbers
                    !
                    hostname CISCO857W
                    !
                    boot-start-marker
                    boot-end-marker
                    !
                    logging buffered 10240 debugging
                    logging console critical
                    !
                    no aaa new-model
                    !
                    resource policy
                    !
                    clock timezone PCTime 0
                    clock summer-time PCTime date Mar 30 2003 1:00 Oct 26 2003 2:00
                    no ip source-route
                    no ip dhcp use vrf connected
                    ip dhcp excluded-address 192.168.1.1 192.168.1.99
                    ip dhcp excluded-address 192.168.1.254
                    !
                    ip dhcp pool dhcppool
                    import all
                    network 192.168.1.0 255.255.255.0
                    default-router 192.168.1.254
                    update arp
                    !
                    !
                    ip cef
                    ip inspect name firewall tcp
                    ip inspect name firewall udp
                    ip inspect name firewall cuseeme
                    ip inspect name firewall h323
                    ip inspect name firewall rcmd
                    ip inspect name firewall realaudio
                    ip inspect name firewall streamworks
                    ip inspect name firewall vdolive
                    ip inspect name firewall sqlnet
                    ip inspect name firewall tftp
                    ip inspect name firewall ftp
                    ip inspect name firewall icmp
                    ip inspect name firewall sip
                    ip inspect name firewall esmtp max-data 52428800
                    ip inspect name firewall fragment maximum 256 timeout 1
                    ip inspect name firewall pptp
                    ip inspect name firewall rtsp
                    ip tcp selective-ack
                    ip tcp timestamp
                    no ip bootp server
                    no ip domain lookup
                    ip domain name local
                    ip name-server 87.194.0.66
                    ip name-server 87.194.0.67
                    !
                    !
                    !
                    file verify auto
                    !
                    !
                    !
                    bridge irb
                    !
                    !
                    interface ATM0
                    no ip address
                    no atm ilmi-keepalive
                    dsl operating-mode auto
                    !
                    interface ATM0.1 point-to-point
                    no snmp trap link-status
                    pvc 0/100
                    encapsulation aal5mux ppp dialer
                    dialer pool-member 1
                    !
                    !
                    interface FastEthernet0
                    !
                    interface FastEthernet1
                    !
                    interface FastEthernet2
                    !
                    interface FastEthernet3
                    !
                    interface Dot11Radio0
                    no ip address
                    !
                    encryption mode ciphers tkip
                    !
                    ssid Cisco 857W
                    authentication open
                    authentication key-management wpa
                    guest-mode
                    wpa-psk ascii 7 08711D1E5B495647465B59
                    !
                    speed basic-1.0 basic-2.0 basic-5.5 basic-6.0 basic-9.0 basic-11.0 basic-12.0 b
                    asic-18.0 basic-24.0 basic-36.0 basic-48.0 basic-54.0
                    station-role root
                    no cdp enable
                    bridge-group 1
                    bridge-group 1 subscriber-loop-control
                    bridge-group 1 spanning-disabled
                    bridge-group 1 block-unknown-source
                    no bridge-group 1 source-learning
                    no bridge-group 1 unicast-flooding
                    !
                    interface Vlan1
                    no ip address
                    bridge-group 1
                    bridge-group 1 spanning-disabled
                    !
                    interface Dialer0
                    ip address 87.194.149.104 255.255.248.0
                    ip access-group 101 in
                    no ip redirects
                    no ip unreachables
                    ip inspect firewall out
                    ip nat outside
                    ip virtual-reassembly
                    encapsulation ppp
                    dialer pool 1
                    dialer-group 1
                    no cdp enable
                    ppp authentication chap pap callin
                    ppp chap hostname **************
                    ppp chap password **************
                    ppp pap sent-username ************** password **************
                    !
                    interface BVI1
                    ip address 192.168.1.254 255.255.255.0
                    ip nat inside
                    ip virtual-reassembly
                    !
                    ip route 0.0.0.0 0.0.0.0 Dialer0
                    !
                    no ip http server
                    no ip http secure-server
                    ip nat inside source list 1 interface Dialer0 overload
                    !
                    access-list 1 remark The local LAN.
                    access-list 1 permit 192.168.1.0 0.0.0.255
                    access-list 101 remark Traffic allowed to enter the router from the Internet
                    access-list 101 deny ip 10.0.0.0 0.255.255.255 any
                    access-list 101 deny ip 127.0.0.0 0.255.255.255 any
                    access-list 101 deny ip 169.254.0.0 0.0.255.255 any
                    access-list 101 deny ip 172.16.0.0 0.15.255.255 any
                    access-list 101 deny ip 192.168.0.0 0.0.255.255 any
                    access-list 101 deny icmp any any echo
                    access-list 101 permit ip any any
                    access-list 101 permit gre any any
                    dialer-list 1 protocol ip permit
                    !
                    control-plane
                    !
                    bridge 1 route ip
                    !
                    line con 0
                    no modem enable
                    line aux 0
                    line vty 0 4
                    access-class 2 in
                    login
                    !
                    scheduler max-task-time 5000
                    end

                    Comment


                    • #11
                      Re: Cisco 857W NOT WORKING - DHCP NOT WORKING? - Please help

                      Ok.... NO INTERNET CONNECTION

                      CD Light is solid... PPP Light is off....

                      Please would someone look at the config below and help. I now have wireless and wired connection with DHCP addresses. (Wired DHCP seems to be a little problematic though...)

                      The router does not seem to be connecting to the internet. I am with O2 and it is an ADSL2+ connection.

                      What wrong with my config?

                      (Below - Last Post)
                      Last edited by hotwiredc; 9th November 2009, 21:49.

                      Comment

                      Working...
                      X