Announcement

Collapse
No announcement yet.

How to create vlans on cisco router 1841

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • How to create vlans on cisco router 1841

    good morning

    i have cisco 1841 router with slot 0 hwic card
    can you explain me please how to create vlan and separte all 4 port to each vlan
    the reason . i need on each port diffrent ip address


    thanks

    golan

  • #2
    Re: vlan cisco 1841

    conf t
    int vlan <number>
    ip address 192.168.x.1 255.255.255.0
    Description What ever you want

    interface FastEthernet x/x/x
    switchport access vlan <number>
    switchport mode access


    Repeat this as required.

    Let me know if it works for you.

    Comment


    • #3
      Re: How to create vlans on cisco router 1841

      thanks
      i will check it in couple of days and will let you know .

      golan

      Comment


      • #4
        Re: How to create vlans on cisco router 1841

        at my router i have only one vlan

        here attach my sh config


        -----------------------------------------------------------------------
        Cisco Router and Security Device Manager (SDM) is installed on this device.
        This feature requires the one-time use of the username "cisco"
        with the password "cisco". The default username and password have a privilege level of 15.

        Please change these publicly known initial credentials using SDM or the IOS CLI.
        Here are the Cisco IOS commands.

        username <myuser> privilege 15 secret 0 <mypassword>
        no username cisco

        Replace <myuser> and <mypassword> with the username and password you want to use.

        For more information about SDM please follow the instructions in the QUICK START
        GUIDE for your router or go to http://www.cisco.com/go/sdm
        -----------------------------------------------------------------------


        User Access Verification

        Username: golan
        Password:
        % Password expiration warning.
        -----------------------------------------------------------------------

        Cisco Router and Security Device Manager (SDM) is installed on this device and
        it provides the default username "cisco" for one-time use. If you have already
        used the username "cisco" to login to the router and your IOS image supports the
        "one-time" user option, then this username has already expired. You will not be
        able to login to the router with this username after you exit this session.

        It is strongly suggested that you create a new username with a privilege level
        of 15 using the following command.

        username <myuser> privilege 15 secret 0 <mypassword>

        Replace <myuser> and <mypassword> with the username and password you want to
        use.

        -----------------------------------------------------------------------

        MplsFrankfurt#
        MplsFrankfurt#
        MplsFrankfurt#sh run
        Building configuration...

        Current configuration : 3035 bytes
        !
        version 12.4
        service timestamps debug datetime msec
        service timestamps log datetime msec
        no service password-encryption
        !
        hostname MplsFrankfurt
        !
        boot-start-marker
        boot-end-marker
        !
        logging buffered 51200 warnings
        !
        no aaa new-model
        ip cef
        !
        !
        !
        !
        ip domain name yourdomain.com
        multilink bundle-name authenticated
        !
        !
        username golan privilege 15 secret 5 $1$7MTH$AnKXY7ylzfr3roEA3O69N/
        archive
        log config
        hidekeys
        !
        !
        !
        !
        !
        interface FastEthernet0/0
        description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-FE 0$
        ip address 10.128.88.193 255.255.255.240
        duplex auto
        speed auto
        !
        interface FastEthernet0/1
        ip address 10.128.12.6 255.255.255.252
        duplex auto
        speed auto
        !
        interface FastEthernet0/1/0
        !
        interface FastEthernet0/1/1
        !
        interface FastEthernet0/1/2
        !
        interface FastEthernet0/1/3
        !
        interface Vlan1
        no ip address
        shutdown
        !
        ip forward-protocol nd
        ip route 10.128.88.208 255.255.255.240 10.128.12.5
        !
        !
        ip http server
        ip http access-class 23
        ip http authentication local
        ip http timeout-policy idle 60 life 86400 requests 10000
        !
        access-list 23 permit 10.128.88.0
        access-list 23 permit 10.10.10.0 0.0.0.7
        !
        !
        control-plane
        !
        banner exec ^C
        % Password expiration warning.
        -----------------------------------------------------------------------

        Cisco Router and Security Device Manager (SDM) is installed on this device and
        it provides the default username "cisco" for one-time use. If you have already
        used the username "cisco" to login to the router and your IOS image supports the
        "one-time" user option, then this username has already expired. You will not be
        able to login to the router with this username after you exit this session.

        It is strongly suggested that you create a new username with a privilege level
        of 15 using the following command.

        username <myuser> privilege 15 secret 0 <mypassword>

        Replace <myuser> and <mypassword> with the username and password you want to
        use.

        -----------------------------------------------------------------------
        ^C
        banner login ^C
        -----------------------------------------------------------------------
        Cisco Router and Security Device Manager (SDM) is installed on this device.
        This feature requires the one-time use of the username "cisco"
        with the password "cisco". The default username and password have a privilege level of 15.

        Please change these publicly known initial credentials using SDM or the IOS CLI.
        Here are the Cisco IOS commands.

        username <myuser> privilege 15 secret 0 <mypassword>
        no username cisco

        Replace <myuser> and <mypassword> with the username and password you want to use.

        For more information about SDM please follow the instructions in the QUICK START
        GUIDE for your router or go to http://www.cisco.com/go/sdm
        -----------------------------------------------------------------------
        ^C
        !
        line con 0
        login local
        line aux 0
        line vty 0 4
        privilege level 15
        login local
        transport input telnet
        line vty 5 15
        access-class 23 in
        privilege level 15
        login local
        transport input telnet
        !
        scheduler allocate 20000 1000
        end

        MplsFrankfurt#

        just to explain again
        i want to be able to connect to any port on my HWIC card and assign him ip diffrent ip address

        thanks golan

        Comment


        • #5
          Re: How to create vlans on cisco router 1841

          interface Vlan1
          ip address 192.168.1.1
          no shutdown
          !
          interface Vlan2
          ip address 192.168.2.1
          no shutdown
          !
          interface Vlan3
          ip address 192.168.3.1
          no shutdown
          !
          interface Vlan4
          ip address 192.168.4.1
          no shutdown
          !
          interface FastEthernet0/1/0
          #By default memebr of VLAN1
          !
          interface FastEthernet0/1/1
          switchport access vlan 2
          switchport mode access
          !
          interface FastEthernet0/1/2
          switchport access vlan 3
          switchport mode access
          !
          interface FastEthernet0/1/3
          switchport access vlan 4
          switchport mode access


          You may need to add to the VLAN database but latest IOS's I have used handle that for you.

          Comment


          • #6
            Re: How to create vlans on cisco router 1841

            thanks for your quick help
            so i need to thats :
            #conf t
            and the same line above ?
            interface Vlan1
            ip address 192.168.1.1
            no shutdown
            !
            interface Vlan2
            ip address 192.168.2.1
            no shutdown
            !
            interface Vlan3
            ip address 192.168.3.1
            no shutdown
            !
            interface Vlan4
            ip address 192.168.4.1
            no shutdown
            !
            interface FastEthernet0/1/0
            #By default memebr of VLAN1
            !
            interface FastEthernet0/1/1
            switchport access vlan 2
            switchport mode access
            !
            interface FastEthernet0/1/2
            switchport access vlan 3
            switchport mode access
            !
            interface FastEthernet0/1/3
            switchport access vlan 4
            switchport mode access

            Comment


            • #7
              Re: How to create vlans on cisco router 1841

              yeah that should do you.

              You don't have to use those addresses if you don't want.

              Comment


              • #8
                Re: How to create vlans on cisco router 1841

                thanks
                i am connecting media converter from single mode fobre to rj45 to connect my router 1841
                do i need to set someting ?
                my router support only 10/100 mbs /


                golan

                Comment


                • #9
                  Re: How to create vlans on cisco router 1841

                  Try without setting anything see if it works. If not you may need to set duplex, and speed, all depends on the convertor.

                  If I've help please give me reputation points

                  Comment


                  • #10
                    Re: How to create vlans on cisco router 1841

                    how can i give reputaion points ?
                    if 10 is the max .so i give 11

                    thanks

                    Comment


                    • #11
                      Re: How to create vlans on cisco router 1841

                      Thin its the ying yang top right

                      Comment

                      Working...
                      X