Announcement

Collapse
No announcement yet.

Newbie needs help with cisco 837 reconfigure - no internet access

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Newbie needs help with cisco 837 reconfigure - no internet access

    Hi All,
    I have a Cisco 837 that has been merrily providing a VPN to another site for a few years, and was locked down to ONLY allow vpn traffic. It is now trying to be just a router again! All I need is internet access - nothing inbound.
    I do not have a lot of knowledge of Cisco IOS, and the web interface is disabled - I tried enabling it but there is no level 15 password configured.

    The config is below - can anyone see what I am doing wrong?? (I bet it is something simple!) I have XXX'ed out the passwords and user names to protect the guilty.

    The ISP says that the router is connecting and they can see the PPP user logged on, I am betting on a NAT command being awry but my searches so far have been fruitless...

    Thanks in advance,
    Aaron

    Building configuration...
    Current configuration : 1860 bytes
    !
    ! Last configuration change at 10:49:09 BST Tue Oct 20 2009
    ! NVRAM config last updated at 10:49:17 BST Tue Oct 20 2009
    !
    version 12.3
    no service pad
    service telnet-zeroidle
    service timestamps debug datetime localtime show-timezone
    service timestamps log datetime localtime show-timezone
    service password-encryption
    !
    hostname ROUTER
    !
    enable secret 5 XXXXXXXXXXXX
    !
    clock timezone GMT 0
    clock summer-time BST recurring last Sun Mar 1:00 last Sun Oct 1:00
    no aaa new-model
    ip subnet-zero
    !
    no ip bootp server
    ip audit po max-events 100
    ip ssh break-string
    no ftp-server write-enable
    !
    !
    !
    !
    !
    !
    interface Ethernet0
    ip address X.X.X.X 255.255.255.0
    ip nat inside
    no cdp enable
    hold-queue 100 out
    !
    interface ATM0
    no ip address
    no atm ilmi-keepalive
    pvc 0 0/38
    encapsulation aal5mux ppp dialer
    dialer pool-member 1
    !
    dsl operating-mode auto
    dsl power-cutback 0
    !
    interface Dialer0
    ip address X.X.X.X 255.255.255.0
    ip nat outside
    encapsulation ppp
    no ip split-horizon
    dialer pool 1
    dialer-group 1
    no cdp enable
    ppp pap sent-username XXXXXX password 7 XXXXXX
    !
    ip nat inside source list 1 interface Dialer0 overload
    ip classless
    ip route 0.0.0.0 0.0.0.0 Dialer0
    no ip http server
    no ip http secure-server
    !
    dialer-list 1 protocol ip permit
    no cdp run
    banner motd ^C
    Unauthorised ACCESS TO, AND (ab)use of, this router is strictly prohibited.
    ^C
    !
    line con 0
    password 7 XXXXXX
    login
    no modem enable
    transport preferred all
    transport output all
    line aux 0
    transport preferred all
    transport output all
    line vty 0 4
    access-class 2 in
    exec-timeout 0 0
    password 7 XXXXXX
    login
    rotary 2
    transport preferred all
    transport input all
    transport output all
    !
    scheduler max-task-time 5000
    sntp server 130.88.202.49
    sntp server 130.88.200.98
    sntp server 130.88.200.6
    !
    end

  • #2
    Re: Newbie needs help with cisco 837 reconfigure - no internet access

    You have not configured access-list 1 so there is nothing to match against NAT source-list 1
    Infrastructure Architect
    CCNA, CCNA Security, MCSE, JNCIS

    Comment


    • #3
      Re: Newbie needs help with cisco 837 reconfigure - no internet access

      Ah nuts! It was there earlier - honest! I will put it back and post the result.
      Thanks for the reply!
      Aaron

      Comment


      • #4
        Re: Newbie needs help with cisco 837 reconfigure - no internet access

        Thanks BigDeesDad - that was the one.
        I'll go back to Microsoft work now
        Aaron

        Comment


        • #5
          Re: Newbie needs help with cisco 837 reconfigure - no internet access

          No probs mate, it happens to us all
          Infrastructure Architect
          CCNA, CCNA Security, MCSE, JNCIS

          Comment

          Working...
          X