Announcement

Collapse
No announcement yet.

cleaning out all vlan config from 2950

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • cleaning out all vlan config from 2950

    Hello all,
    I recently built a router/switch lab at home and wanted to wipe out all the config info from the devices, the routers seemed easy enough (3x2611) however the 2950 seems to be giving me some trouble. I did the following to return it back to defualt factory settings:
    Code:
    SW2950>en
    Password:
    SW2950#write erase
    Erasing the nvram filesystem will remove all files! Continue? [confirm]
    [OK]
    Erase of nvram: complete
    SW2950#
    SW2950#delete flash:vlan.dat
    Delete filename [vlan.dat]? y
    Delete flash:y? [confirm]y
    %Error deleting flash:y (No such file or directory)
    SW2950#reload
    
    System configuration has been modified. Save? [yes/no]: n
    Proceed with reload? [confirm]
    
    1d02h: %SYS-5-RELOAD: Reload requested
    So it states that there is no Vlan.dat, however when i show run I get the following
    Code:
    Switch#show run
    Building configuration...
    
    Current configuration : 1067 bytes
    !
    version 12.1
    no service pad
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname Switch
    !
    !
    !
    vlan 2
     name DC80004C
    !
    vlan 3
     name DC80005C
    !
    vlan 4
     name SPARE
    !
    vlan 5
     name SPARE1
    !
    vlan 29
     name DC80004C_P2P
    !
    vlan 62
     name DC80004C_SECURE
    !
    vlan 63
    !
    vlan 122
     name DC80004C_COMPLIMENTARY
    ip subnet-zero
    vtp domain TMO
    vtp mode transparent
    !
    spanning-tree extend system-id
    !
    !
    interface FastEthernet0/1
     no ip address
    !
    interface FastEthernet0/2
     no ip address
    !
    interface FastEthernet0/3
     no ip address
    !
    interface FastEthernet0/4
     no ip address
    !
    interface FastEthernet0/5
     no ip address
    !
    interface FastEthernet0/6
     no ip address
    !
    interface FastEthernet0/7
     no ip address
    !
    interface FastEthernet0/8
     no ip address
    !
    interface FastEthernet0/9
     no ip address
    !
    interface FastEthernet0/10
     no ip address
    !
    interface FastEthernet0/11
     no ip address
    !
    interface FastEthernet0/12
     no ip address
    !
    interface Vlan1
     no ip address
     no ip route-cache
     shutdown
    !
    ip http server
    !
    !
    line con 0
    line vty 5 15
    !
    end
    Any ideas or suggestions?

  • #2
    Re: cleaning out all vlan config from 2950

    Try erasing your startup config then reload your device that should take care of that..

    otherwise you can just run

    no vlan 2
    no vlan 3
    no vlan 4
    no vlan 5
    no vlan 29
    no vlan 62
    no vlan 63
    no vlan 122
    no vtp domain TMO
    no vtp mode transparent

    and that should pretty much set you back to default
    Daniel Frei
    -Windows Operations Server Administrator
    -Exchange Guru
    -Cisco Fanatic
    -SharePoint Hippie
    -Volkswagen Enthusiast

    www.lazynetworkadmin.com

    Comment


    • #3
      Re: cleaning out all vlan config from 2950

      The delete flash:vlan.dat should have been successful as long as the file has not been renamed from the default.

      Do a show flash and confirm the name of the vlan database before you try and delete.
      Infrastructure Architect
      CCNA, CCNA Security, MCSE, JNCIS

      Comment


      • #4
        Re: cleaning out all vlan config from 2950

        Awesome, thanks guys for the advise! I will give it a shot when i get home!

        Comment


        • #5
          Re: cleaning out all vlan config from 2950

          Great I was finally able to delete the Vlan.dat, it was because i was answering y to the confirm question. Thanks for the advice.

          another question when i do show flash I also see these files:

          Code:
          Switch>show flash
          
          Directory of flash:/
          
              3  -rwx         269   Jan 01 1970 00:01:31  env_vars
              4  -rwx     2664051   Mar 01 1993 00:04:37  c2950-i6q4l2-mz.121-11.EA1.bin
              5  -rwx          48   Aug 12 2008 22:13:25  private-config.text
          Now i know the .bin file is my ios, but what about the other two, should I delete them as well and also how to I read that text file?

          Comment


          • #6
            Re: cleaning out all vlan config from 2950

            env_vars is where the system settings are stored (MTU etc). You can delete this file and on reboot the system will be at default values.

            private-config.text is where the crypto private keys are stored. This file cannot be viewed but you can delete it.
            Infrastructure Architect
            CCNA, CCNA Security, MCSE, JNCIS

            Comment

            Working...
            X