Announcement

Collapse
No announcement yet.

not able to ping frin host to router2

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • not able to ping frin host to router2

    Hi all,

    I am rather new to all of this, I am currently studying for my CCNA and after successfully getting 3 routers to communicate with one another I am now trying to advance my learning.

    Sorry if this is a really trivial answer! but I am rather stuck as to what I am doing wrong and any help greatly welcomed.

    I have 3 routers connected together with a switch hanging off R1 (see diagram).

    off that switch I have a laptop which is assigned address of 192.168.10.18
    the swtich is 192.168.10.2, the eth0 on r1 is 10.1

    why is it i can not ping from r3 (or router 2 for that matter) to the switch1 (192.168.40.2 to 192.168.10.2) yet when i try and ping to or out from my laptop- I cannot?

    I looked up online and i thought i would add some acl's to the router to check that a ping is permitted so....

    I have added this to r1 config;

    #access-list 101 permit IP any any
    #access-list 101 permit icmp any any

    does ACL need to applied on all routers? before a succesful ping from 10.18 to 40.2 can work?

    or is this not the underlying problem?




    thanks,

    Chris noob to networking
    Attached Files

  • #2
    Re: not able to ping frin host to router2

    Hi ellis1884

    What does your route table look like for each router? You shouldn't need any ACL's if the router configurations pretty simple. Your ACL is probably getting in the way depending on which interface and direction you applied the ACL on.

    Get rid of the ACL and check that your routes are setup. Do you have a default route configured or a static route for the 192.168.10.0/24 subnet? Since this is test lab can you provide r3's config?

    Ryan
    Last edited by ryansmitty; 31st August 2009, 02:32.

    Comment


    • #3
      Re: not able to ping frin host to router2

      R1 route table:

      C 192.168.10.0/24 is directly connected, Ethernet0
      R 192.168.40.0/24 [120/1] via 192.168.20.2, 00:00:12, Serial0
      C 192.168.20.0/24 is directly connected, Serial0

      R1 config

      r1#sh run
      Building configuration...

      Current configuration:
      !
      version 12.1
      service timestamps debug uptime
      service timestamps log uptime
      no service password-encryption
      !
      hostname r1
      !
      enable secret 5 $1$qFmv$1Kv90CxUZCLS.zS3VS7qr/
      enable password rain2
      !
      !
      !
      !
      !
      clock timezone gmt 0
      ip subnet-zero
      !
      !
      !
      !
      interface Ethernet0
      ip address 192.168.10.1 255.255.255.0
      no ip mroute-cache
      !
      interface Serial0
      ip address 192.168.20.1 255.255.255.0
      no ip mroute-cache
      clockrate 64000
      !
      interface Serial1
      ip address 192.168.30.1 255.255.255.0
      no ip mroute-cache
      shutdown
      !
      router rip
      network 192.168.10.0
      network 192.168.20.0
      !
      ip classless
      ip route 192.168.16.0 255.255.255.0 10.10.10.3
      no ip http server
      !
      access-list 1 permit 0.0.0.2 255.255.255.0
      access-list 101 permit ip any any
      access-list 101 permit icmp any any
      snmp-server engineID local 00000009020000E01EA9BAC8
      snmp-server community public RO
      !
      line con 0
      transport input none
      line aux 0
      line vty 0 4
      password xxxxx
      login
      !
      ntp server 78.129.207.3
      end


      R2 route table:

      R 192.168.10.0/24 [120/1] via 192.168.20.1, 00:00:18, Serial0/0
      C 192.168.40.0/24 is directly connected, Ethernet0/0
      C 192.168.20.0/24 is directly connected, Serial0/0

      R2 config

      r2#sh run
      Building configuration...

      Current configuration : 710 bytes
      !
      version 12.3
      service timestamps debug datetime msec
      service timestamps log datetime msec
      no service password-encryption
      !
      hostname r2
      !
      boot-start-marker
      boot-end-marker
      !
      enable secret 5 $1$wrEu$oJiMoDLep9WfWB5nPuwfM0
      enable password xxxxxx
      !
      no aaa new-model
      ip subnet-zero
      ip cef
      !
      !
      !
      !
      !
      !
      !
      interface Ethernet0/0
      ip address 192.168.40.1 255.255.255.0
      half-duplex
      !
      interface Serial0/0
      ip address 192.168.20.2 255.255.255.0
      no fair-queue
      !
      router rip
      network 192.168.20.0
      network 192.168.40.0
      !
      ip http server
      ip classless
      !
      !
      access-list 101 permit ip any any
      access-list 101 permit icmp any any
      snmp-server community public RO
      !
      line con 0
      line aux 0
      line vty 0 4
      password xxxxxx
      login
      !
      !
      end


      R3 route table:

      R 192.168.10.0/24 [120/2] via 192.168.40.1, 00:00:14, Ethernet0
      C 192.168.40.0/24 is directly connected, Ethernet0
      R 192.168.20.0/24 [120/1] via 192.168.40.1, 00:00:14, Ethernet0

      R3 config:

      r3#sh run
      Building configuration...

      Current configuration:
      !
      version 12.1
      service timestamps debug uptime
      service timestamps log uptime
      no service password-encryption
      !
      hostname r3
      !
      enable secret 5 $1$7VpO$2loMk6dfic4ZHkmLZJDKo1
      enable password xxxxxx
      !
      !
      !
      !
      !
      clock timezone gmt 0
      ip subnet-zero
      !
      !
      !
      !
      interface Ethernet0
      description ethernet0conn
      ip address 192.168.40.2 255.255.255.0
      no ip mroute-cache
      !
      interface Serial0
      ip address 192.168.50.1 255.255.255.0
      no ip mroute-cache
      !
      interface Serial1
      ip address 192.168.60.1 255.255.255.0
      no ip mroute-cache
      shutdown
      !
      router rip
      network 192.168.40.0
      !
      ip classless
      ip route 192.168.16.0 255.255.255.0 10.10.10.1
      no ip http server
      !
      snmp-server engineID local 00000009020000107B36F10C
      snmp-server community public RO
      !
      line con 0
      transport input none
      line aux 0
      line vty 0 4
      password xxxxx
      login
      !
      end

      Comment


      • #4
        Re: not able to ping frin host to router2

        You have a route to the 192.168.10.0/24 subnet via RIP from both R2 and R3 so the routing is correct. You have configured the ACL but not applied it to any interfaces so the traffic will not be filtered.

        Are you saying that you can ping from R2 and R3 to the switch but you cannot ping to or from the PC?

        I would imagine that you do not have the host set up correctly. Check and confirm the following host config:

        IP Address: 192.168.10.18
        Subnet mask: 255.255.255.0
        Default Gateway: 192.168.10.1
        Infrastructure Architect
        CCNA, CCNA Security, MCSE, JNCIS

        Comment


        • #5
          Re: not able to ping frin host to router2

          thanks BigDeesDad!

          silly me, first off I removed the ACL from all routers, and then pinged across the network, still nothing.

          I looked once again at the host ip config and I forgot to add in the gateway address! duh!!

          it now pings all ok

          Comment

          Working...
          X