Announcement

Collapse
No announcement yet.

Replacing two routers with a single (multi)modular one

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Replacing two routers with a single (multi)modular one

    Hi,
    I have to replace a cisco 837 (connected to an adsl circuit) and a
    1720 (connected to an HDSL circuit via a serial modem) with a new 1841
    having 2 WICS (Adsl and serial).

    The 837 and the 1720 are perimeter routers, used by an internal router
    and a couple of PIX firewalls to manage a few VPNs.
    So it's important that the new 1841 will work exactly as the 837 and
    the 1720.

    I post below the relevant parts of the 837 and 1720 configs, plus a
    tentative config of the 1841.

    My problem is how to manage the (default) routes on the new 1841...
    can you point me to the right direction please?

    Any help is greatly appreciated

    Thanks in advance
    Guido




    837 (manages ADSL circuit)
    ----------------------------
    interface Ethernet0
    ip address aaa.aaa.aaa.aaa 255.255.255.248
    hold-queue 100 out
    !!
    interface ATM0
    no ip address
    no atm ilmi-keepalive
    dsl operating-mode auto
    hold-queue 224 in
    !
    interface ATM0.1 point-to-point
    bandwidth 1280
    ip address bbb.bbb.bbb.bbb 255.255.255.252
    no snmp trap link-status
    pvc 8/35
    encapsulation aal5snap
    !
    !
    interface FastEthernet1
    duplex auto
    speed auto
    !
    interface FastEthernet2
    duplex auto
    speed auto
    !
    interface FastEthernet3
    duplex auto
    speed auto
    !
    interface FastEthernet4
    duplex auto
    speed auto
    !
    ip forward-protocol nd
    ip route 0.0.0.0 0.0.0.0 ATM0.1

    1720 (manages HDSL circuit)
    ----------------------------
    interface FastEthernet0
    bandwidth 100000
    ip address xxx.xxx.xxx.xxx 255.255.255.248
    speed auto
    !
    interface Serial0
    bandwidth 256
    no ip address
    encapsulation frame-relay IETF
    !
    interface Serial0.1 point-to-point
    bandwidth 2048
    ip address yyy.yyy.yyy.yyy 255.255.255.252
    no arp frame-relay
    no cdp enable
    frame-relay interface-dlci 345 IETF
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 Serial0.1

    1841 (new router with WIC ADSL & serial WIC x to replace both 837 and
    1720)
    ------------------------------------------------------------------------
    interface FastEthernet0/0
    description ** replaces 1720 FastEthernet0 **
    bandwidth 100000
    ip address xxx.xxx.xxx.xxx 255.255.255.248
    speed auto
    !
    interface FastEthernet0/1
    description ** replaces 837 Ethernet0 **
    bandwidth 100000
    ip address aaa.aaa.aaa.aaa 255.255.255.248
    speed auto
    !
    interface Serial0/0/0
    bandwidth 256
    no ip address
    encapsulation frame-relay IETF
    !
    interface Serial0/0/0.1 point-to-point
    description ** replaces 1720 serial0.1 **
    bandwidth 2048
    ip address yyy.yyy.yyy.yyy 255.255.255.252
    no arp frame-relay
    no cdp enable
    frame-relay interface-dlci 345 IETF
    !
    interface ATM0/1/0
    no ip address
    no atm ilmi-keepalive
    dsl operating-mode auto
    hold-queue 224 in
    !
    interface ATM0/1/0.1 point-to-point
    description ** replaces 837 ATM0.1 **
    bandwidth 1280
    ip address bbb.bbb.bbb.bbb 255.255.255.252
    no snmp trap link-status
    pvc 8/35
    encapsulation aal5snap
    !
    ip classless
    ip route ---> *** how should I set this to have this 1841 behave
    exactly as 1720+837? ***
    Last edited by guidobras; 28th August 2009, 09:57.

  • #2
    Re: Replacing two routers with a single (multi)modular one

    You can either Load Balance across the two links or have a primary/failover configuration.

    Load Balance:
    Router(config)# ip route 0.0.0.0 0.0.0.0 interface atm0/1/0.1
    Router(config)# ip route 0.0.0.0 0.0.0.0 interface serial0/0/0.1

    Primary/Failover:
    Router(config)# ip route 0.0.0.0 0.0.0.0 interface atm0/1/0.1
    Router(config)# ip route 0.0.0.0 0.0.0.0 interface serial0/0/0.1 metric 10
    Infrastructure Architect
    CCNA, CCNA Security, MCSE, JNCIS

    Comment


    • #3
      Re: Replacing two routers with a single (multi)modular one

      Thanks BigDeesDad.

      Actually I need to implement a different (and conceptually very simple) setup:

      -if a packet is entering router from FastEthernet0/0 then send it via Serial0/0/0.1
      -if it is entering router from interface FastEthernet0/1then send it via ATM0/1/0.1

      Isn't it possible?
      Guido

      Comment


      • #4
        Re: Replacing two routers with a single (multi)modular one

        Oh i see. Well in that case you want to do some policy based routing. Maybe something like this:

        Create standard access lists to permit LAN traffic
        Router(config)# access-list 1 permit x.x.x.x 0.0.0.7
        Router(config)# access-list 2 permit a.a.a.a 0.0.0.7

        Create route maps to map access-list to next-hop interface
        Router(config)# route-map ISP1 permit 10
        Router(config-route-map)# match ip address 1
        Router(config-route-map)# set ip next-hop interface serial0/0/0.1

        Router(config)# route-map ISP2 permit 20
        Router(config-route-map)# match ip address 2
        Router(config-route-map)# set ip next-hop interface atm0/1/0.1

        Apply route map to FastEthernet 0/0
        Router(config-if)#ip policy route-map ISP1

        Apply route map to FastEthernet 0/1
        Router(config-if)#ip policy route-map ISP2
        Infrastructure Architect
        CCNA, CCNA Security, MCSE, JNCIS

        Comment

        Working...
        X