Announcement

Collapse
No announcement yet.

Poor throughput on Cisco 2611

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Poor throughput on Cisco 2611

    I have a Cisco 2611 that was just installed. Intrnet traffic on the private network is terribly slow. Below is the configuration we're currently using. Hopefully someone will see something that can correct this problem.

    The public network is a subnet of 64 addresses, 66.165.53.192/26

    Thanks,

    Jack

    ----

    cisco2611#show running-config
    Building configuration...

    Current configuration : 1609 bytes
    !
    ! NVRAM config last updated at 14:51:51 PDT Thu Aug 6 2009
    !
    version 12.3
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    !
    hostname cisco2611
    !
    security authentication failure rate 10 log
    security passwords min-length 6
    logging buffered 4096 debugging
    logging console critical
    enable secret
    enable password
    !
    clock timezone PST -8
    clock summer-time PDT recurring
    ip subnet-zero
    !
    !
    ip name-server 66.165.53.197
    ip name-server 66.165.53.198
    ip dhcp excluded-address 192.168.123.1 192.168.123.69
    !
    ip dhcp pool 192.168.123.70-99
    !
    ip dhcp pool tnl-pool
    network 192.168.123.0 255.255.255.0
    domain-name nwcascades.com
    dns-server 66.165.53.197 66.165.53.198
    default-router 192.168.123.38
    lease 7
    !
    mpls ldp logging neighbor-changes
    !
    !
    !
    !
    !
    !
    !
    !
    !
    no voice hpi capture buffer
    no voice hpi capture destination
    !
    !
    !
    !
    !
    !
    interface Ethernet0/0
    ip address 66.165.53.231 255.255.255.192
    ip broadcast-address 66.165.53.255
    ip nat outside
    full-duplex
    no mop enabled
    !
    interface Ethernet0/1
    ip address 192.168.123.38 255.255.255.0
    ip nat inside
    full-duplex
    no mop enabled
    !
    router rip
    redistribute connected
    network 66.0.0.0
    network 192.168.123.0
    !
    ip default-gateway 66.165.53.193
    ip nat inside source list tnl-staff interface Ethernet0/0 overload
    no ip http server
    ip classless
    ip route 0.0.0.0 0.0.0.0 66.165.53.193
    ip route 66.165.53.192 255.255.255.192 Ethernet0/0
    ip route 192.168.123.0 255.255.255.0 Ethernet0/1
    !
    !
    ip access-list standard tnl-staff
    permit 192.168.123.0 0.0.0.255
    deny any
    dialer-list 1 protocol ip permit
    dialer-list 1 protocol ipx permit
    !
    !
    snmp-server community public RO
    snmp-server enable traps tty
    !
    !
    !
    !
    line con 0
    line aux 0
    line vty 0 4
    password 7 123F5C5B46475E1E3E
    login
    !
    ntp clock-period 17208453
    ntp server 209.123.234.24
    !
    !
    end

    cisco2611#

  • #2
    Re: Poor throughput on Cisco 2611

    Have you looked at CPU, Memory, and Link utilization on the router?

    Also, why are you redistributing routes for the public network?

    Comment


    • #3
      Re: Poor throughput on Cisco 2611

      There are less that a dozen Macs and one PC on the private network. The router has 32M of RAM about 15M is utilized.

      What would you suggest here? I haven't messed with these in a long time.

      Jack

      Comment


      • #4
        Re: Poor throughput on Cisco 2611

        How about looking at the interface stats on the router. Any CRC errors, drops, overruns, etc.? also, how about the CPU on the router, what percentage is it running at?

        Comment


        • #5
          Re: Poor throughput on Cisco 2611

          cisco2611#sh interface stats
          Ethernet0/0
          Switching path Pkts In Chars In Pkts Out Chars Out
          Processor 161326 16839952 128800 10387776
          Route cache 1585880 1585741218 1235340 296557802
          Total 1747206 1602581170 1364140 306945578
          Ethernet0/1
          Switching path Pkts In Chars In Pkts Out Chars Out
          Processor 170303 17572257 137706 16559731
          Route cache 1235347 296558579 1585883 1585741646
          Total 1405650 314130836 1723589 1602301377
          cisco2611#



          cisco2611#sh interface
          Ethernet0/0 is up, line protocol is up
          Hardware is AmdP2, address is 0004.9a3e.cc40 (bia 0004.9a3e.cc40)
          Internet address is 66.165.53.231/26
          MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
          reliability 255/255, txload 1/255, rxload 1/255
          Encapsulation ARPA, loopback not set
          Keepalive set (10 sec)
          ARP type: ARPA, ARP Timeout 04:00:00
          Last input 00:00:00, output 00:00:00, output hang never
          Last clearing of "show interface" counters never
          Input queue: 1/75/0/0 (size/max/drops/flushes); Total output drops: 0
          Queueing strategy: fifo
          Output queue: 0/40 (size/max)
          5 minute input rate 4000 bits/sec, 5 packets/sec
          5 minute output rate 4000 bits/sec, 5 packets/sec
          1748905 packets input, 1603277273 bytes, 0 no buffer
          Received 45839 broadcasts, 0 runts, 0 giants, 0 throttles
          0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
          0 input packets with dribble condition detected
          1365931 packets output, 307316632 bytes, 0 underruns
          0 output errors, 0 collisions, 3 interface resets
          0 babbles, 0 late collision, 0 deferred
          0 lost carrier, 0 no carrier
          0 output buffer failures, 0 output buffers swapped out
          Ethernet0/1 is up, line protocol is up
          Hardware is AmdP2, address is 0004.9a3e.cc41 (bia 0004.9a3e.cc41)
          Internet address is 192.168.123.38/24
          MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
          reliability 255/255, txload 1/255, rxload 1/255
          Encapsulation ARPA, loopback not set
          Keepalive set (10 sec)
          ARP type: ARPA, ARP Timeout 04:00:00
          Last input 00:00:02, output 00:00:01, output hang never
          Last clearing of "show interface" counters never
          Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
          Queueing strategy: fifo
          Output queue: 0/40 (size/max)
          5 minute input rate 3000 bits/sec, 3 packets/sec
          5 minute output rate 3000 bits/sec, 4 packets/sec
          1407536 packets input, 314517647 bytes, 0 no buffer
          Received 71549 broadcasts, 0 runts, 0 giants, 0 throttles
          85170 input errors, 85110 CRC, 42428 frame, 0 overrun, 60 ignored
          0 input packets with dribble condition detected
          1725147 packets output, 1602991060 bytes, 0 underruns
          0 output errors, 0 collisions, 3 interface resets
          0 babbles, 0 late collision, 0 deferred
          0 lost carrier, 0 no carrier
          0 output buffer failures, 0 output buffers swapped out
          cisco2611#

          Comment


          • #6
            Re: Poor throughput on Cisco 2611

            cisco2611#sh processes cpu
            CPU utilization for five seconds: 1%/0%; one minute: 0%; five minutes: 1%
            PID Runtime(ms) Invoked uSecs 5Sec 1Min 5Min TTY Process
            1 4 2 2000 0.00% 0.00% 0.00% 0 Chunk Manager
            2 8 31977 0 0.00% 0.00% 0.00% 0 Load Meter
            3 240 138 1739 0.49% 0.04% 0.02% 66 Virtual Exec
            4 0 1 0 0.00% 0.00% 0.00% 0 EDDRI_MAIN
            5 109750 18922 5800 0.00% 0.06% 0.05% 0 Check heaps
            6 92 70 1314 0.00% 0.00% 0.00% 0 Pool Manager
            7 0 1 0 0.00% 0.00% 0.00% 0 AAA_SERVER_DEADT
            8 0 2 0 0.00% 0.00% 0.00% 0 Timers
            9 0 2 0 0.00% 0.00% 0.00% 0 Serial Backgroun
            10 0 2 0 0.00% 0.00% 0.00% 0 AAA high-capacit
            11 8 5330 1 0.00% 0.00% 0.00% 0 Environmental mo
            12 30569 46349 659 0.00% 0.00% 0.00% 0 ARP Input
            13 0 1 0 0.00% 0.00% 0.00% 0 HC Counter Timer
            14 0 2 0 0.00% 0.00% 0.00% 0 DDR Timers
            15 4 2 2000 0.00% 0.00% 0.00% 0 Entity MIB API
            16 0 2 0 0.00% 0.00% 0.00% 0 ATM Idle Timer
            17 0 1 0 0.00% 0.00% 0.00% 0 SERIAL A'detect
            18 28 159617 0 0.00% 0.00% 0.00% 0 GraphIt
            19 0 2 0 0.00% 0.00% 0.00% 0 Dialer event
            20 0 1 0 0.00% 0.00% 0.00% 0 Critical Bkgnd
            21 1309 25833 50 0.00% 0.00% 0.00% 0 Net Background
            22 4 11 363 0.00% 0.00% 0.00% 0 Logger
            23 44 159613 0 0.00% 0.00% 0.00% 0 TTY Background
            24 100 159625 0 0.00% 0.00% 0.00% 0 Per-Second Jobs
            25 0 2 0 0.00% 0.00% 0.00% 0 SM Monitor
            26 0 1 0 0.00% 0.00% 0.00% 0 HDV background
            27 8 2 4000 0.00% 0.00% 0.00% 0 VNM DSPRM MAIN
            28 0 5 0 0.00% 0.00% 0.00% 0 Net Input
            29 12 31977 0 0.00% 0.00% 0.00% 0 Compute load avg
            30 96528 2674 36098 0.00% 0.07% 0.05% 0 Per-minute Jobs
            31 0 1 0 0.00% 0.00% 0.00% 0 CES Line Conditi
            32 0 1 0 0.00% 0.00% 0.00% 0 AAL2CPS TIMER_CU
            33 0 2 0 0.00% 0.00% 0.00% 0 AAA Server
            PID Runtime(ms) Invoked uSecs 5Sec 1Min 5Min TTY Process
            34 0 1 0 0.00% 0.00% 0.00% 0 AAA ACCT Proc
            35 0 1 0 0.00% 0.00% 0.00% 0 ACCT Periodic Pr
            36 0 2 0 0.00% 0.00% 0.00% 0 AAA Dictionary R
            37 299304 246636 1213 0.40% 0.18% 0.22% 0 IP Input
            38 0 1 0 0.00% 0.00% 0.00% 0 ICMP event handl
            39 9751 18613 523 0.00% 0.00% 0.00% 0 CDP Protocol
            40 4 3 1333 0.00% 0.00% 0.00% 0 PPP Hooks
            42 0 1 0 0.00% 0.00% 0.00% 0 X.25 Encaps Mana
            43 0 2 0 0.00% 0.00% 0.00% 0 KRB5 AAA
            44 0 1 0 0.00% 0.00% 0.00% 0 VPDN call manage
            45 0 1 0 0.00% 0.00% 0.00% 0 SSS Manager
            46 20 21315 0 0.00% 0.00% 0.00% 0 SSS Test Client
            47 88 873 100 0.08% 0.00% 0.00% 0 TCP Timer
            48 36 17 2117 0.00% 0.00% 0.00% 0 TCP Protocols
            49 0 1 0 0.00% 0.00% 0.00% 0 Socket Timers
            50 0 534 0 0.00% 0.00% 0.00% 0 HTTP CORE
            51 0 2 0 0.00% 0.00% 0.00% 0 PPP IP Route
            52 0 2 0 0.00% 0.00% 0.00% 0 PPP IPCP
            53 12198 2676 4558 0.00% 0.00% 0.00% 0 IP Background
            54 12 2668 4 0.00% 0.00% 0.00% 0 IP RIB Update
            55 0 1 0 0.00% 0.00% 0.00% 0 Asy FS Helper
            56 0 1 0 0.00% 0.00% 0.00% 0 RARP Input
            57 68 36 1888 0.00% 0.00% 0.00% 0 DHCPD Receive
            58 4321 2664 1621 0.00% 0.00% 0.00% 0 IP Cache Ager
            59 0 1 0 0.00% 0.00% 0.00% 0 COPS
            60 4 2 2000 0.00% 0.00% 0.00% 0 PPP Bind
            61 4 1 4000 0.00% 0.00% 0.00% 0 PAD InCall
            62 0 2 0 0.00% 0.00% 0.00% 0 X.25 Background
            63 851 2666 319 0.00% 0.00% 0.00% 0 Adj Manager
            64 0 2 0 0.00% 0.00% 0.00% 0 Tag Input
            65 0 2 0 0.00% 0.00% 0.00% 0 Tag Input
            66 96 159619 0 0.00% 0.00% 0.00% 0 RUDPV1 Main Proc
            67 0 1 0 0.00% 0.00% 0.00% 0 bsm_timers
            68 48 159623 0 0.00% 0.00% 0.00% 0 bsm_xmt_proc
            PID Runtime(ms) Invoked uSecs 5Sec 1Min 5Min TTY Process
            69 0 2 0 0.00% 0.00% 0.00% 0 SNMP Timers
            70 0 2 0 0.00% 0.00% 0.00% 0 Dialer Forwarder
            71 0 2 0 0.00% 0.00% 0.00% 0 PPP SSS
            72 0 1 0 0.00% 0.00% 0.00% 0 CES Client SVC R
            73 0 2 0 0.00% 0.00% 0.00% 0 LOCAL AAA
            74 0 2 0 0.00% 0.00% 0.00% 0 ENABLE AAA
            75 0 2 0 0.00% 0.00% 0.00% 0 LINE AAA
            76 4 2 2000 0.00% 0.00% 0.00% 0 TPLUS
            78 0 2 0 0.00% 0.00% 0.00% 0 ASNL
            79 100 2 50000 0.00% 0.00% 0.00% 0 CCVPM_HDSPRM
            80 4 2 2000 0.00% 0.00% 0.00% 0 VSP_MGR
            81 0 6397 0 0.00% 0.00% 0.00% 0 CRM_CALL_UPDATE_
            82 0 1 0 0.00% 0.00% 0.00% 0 VoIP AAA
            83 0 1 0 0.00% 0.00% 0.00% 0 QOS_MODULE_MAIN
            84 0 1 0 0.00% 0.00% 0.00% 0 RPMS_PROC_MAIN
            85 4 1 4000 0.00% 0.00% 0.00% 0 CCVPM_HTSP
            86 0 1 0 0.00% 0.00% 0.00% 0 CCVPM_R2
            87 0 1 0 0.00% 0.00% 0.00% 0 CCSWVOICE
            88 0 1 0 0.00% 0.00% 0.00% 0 sssapp
            89 4 1 4000 0.00% 0.00% 0.00% 0 http client proc
            91 0 2 0 0.00% 0.00% 0.00% 0 AAA SEND STOP EV
            92 0 1 0 0.00% 0.00% 0.00% 0 Syslog Traps
            93 4 2665 1 0.00% 0.00% 0.00% 0 SAA Event Proces
            94 36 159602 0 0.00% 0.00% 0.00% 0 trunk conditioni
            95 0 1 0 0.00% 0.00% 0.00% 0 trunk conditioni
            96 0 1 0 0.00% 0.00% 0.00% 0 VPDN Scal
            98 28915 138705 208 0.00% 0.00% 0.00% 0 IP NAT Ager
            99 4 2 2000 0.00% 0.00% 0.00% 0 IP SNMP
            100 0 1 0 0.00% 0.00% 0.00% 0 PDU DISPATCHER
            101 84 2 42000 0.00% 0.00% 0.00% 0 SNMP ENGINE
            102 0 1 0 0.00% 0.00% 0.00% 0 SNMP ConfCopyPro
            103 0 1 0 0.00% 0.00% 0.00% 0 SNMP Traps
            104 7380 43764 168 0.00% 0.00% 0.00% 0 NAT MIB Helper
            105 72 161645 0 0.00% 0.00% 0.00% 0 NTP
            PID Runtime(ms) Invoked uSecs 5Sec 1Min 5Min TTY Process
            106 0 1333 0 0.00% 0.00% 0.00% 0 DHCPD Timer
            107 1963 45288 43 0.00% 0.00% 0.00% 0 DHCPD Database
            108 40 5765 6 0.00% 0.00% 0.00% 0 RIP Router
            109 68 5764 11 0.00% 0.00% 0.00% 0 RIP Send
            cisco2611#

            Comment


            • #7
              Re: Poor throughput on Cisco 2611

              You've got a lot of broadcasts on both ETH interfaces and a lot of errors on ETH0/1. The counters have never been reset so how long has it been running?

              Can you clear the counters and then check them every hour to see how fast and how much the errors increase on ETH0/1 (if at all)?

              Comment


              • #8
                Re: Poor throughput on Cisco 2611

                I did a cold boot of the router about 22 hrs. ago.

                There was a linux box where the router now is. It didn't have this problem.

                Comment


                • #9
                  Re: Poor throughput on Cisco 2611

                  I'm trying to remember, do the counters get cleared on a reboot? If so, that's a lot of errors in 22 hours. If not, how about clearing them now and checking them in an hour?

                  Comment


                  • #10
                    Re: Poor throughput on Cisco 2611

                    Will do... Thanks

                    Comment


                    • #11
                      Re: Poor throughput on Cisco 2611

                      Post back here with the output of the sh int command after an hour or two or in the morning and let's see what the counters look like then.

                      Comment


                      • #12
                        Re: Poor throughput on Cisco 2611

                        I reset the counters. Changed to half duplex and the performance went up a lot. There are now a large amount of collisions on the private interface.

                        Any suggestions?

                        Jack

                        Comment


                        • #13
                          Re: Poor throughput on Cisco 2611

                          Collisions are always a result of a duplex mismatch. Change the duplex settings on whatever the router is connected to to match the routers duplex settings. Both sides should be set to 10Mbps Half-duplex or 100Mbps Full-duplex.

                          Comment


                          • #14
                            Re: Poor throughput on Cisco 2611

                            A collision will only occur on a half duplex network. A full duplex network will not have collisions. If you have slow or sluggish throughput it could be any number of issues, but if this has only occurred recently it might point to a faulty NIC card on the network or a host with a virus trying to do a DOS attack on your internal network. I would suggest disconnecting each host individually and see if the slow throughput still occurs.
                            Last edited by Spintry; 28th August 2009, 11:59.

                            Comment


                            • #15
                              Re: Poor throughput on Cisco 2611

                              A duplex mismatch will always cause collisions as one side uses collision avoidance and the other side doesn't. Since his router is set to half-duplex it's almost 100% assured that whatever the router is connected to is set to full-duplex. Both sides of the link need to be set to the same duplex setting.

                              http://en.wikipedia.org/wiki/Duplex_mismatch
                              Last edited by joeqwerty; 28th August 2009, 12:09.

                              Comment

                              Working...
                              X