Announcement

Collapse
No announcement yet.

Line protocol down when connected via crossover

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Line protocol down when connected via crossover

    Hi All,

    I have two routers connected via crossover cable. One router shows line protocol down. When I connect the two routers via a switch and straigth through cables they can see each other. I've also connected two PC's with the cross over cable and they can ping each other fine. So issue is obviously with the routers. Config is below:

    Router1:

    "
    version 12.3
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Router
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    ip subnet-zero
    ip cef
    !
    !
    !
    !
    !
    !
    !
    !
    interface Ethernet0/0
    ip address 10.1.1.1 255.255.255.0
    full-duplex
    !
    interface Serial0/0
    no ip address
    shutdown
    !
    interface BRI0/0
    no ip address
    encapsulation hdlc
    shutdown
    !
    interface Serial0/1
    no ip address
    shutdown
    !
    interface Ethernet1/0
    no ip address
    shutdown
    half-duplex
    !
    ip http server
    ip classless
    !
    !
    !
    line con 0
    line aux 0
    line vty 0 4
    !
    !
    end
    "

    Router2:

    "
    version 12.3
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Router
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    ip subnet-zero
    ip cef
    !
    !
    !
    !
    !
    !
    !
    !
    interface Ethernet0/0
    ip address 10.1.1.2 255.255.255.0
    full-duplex
    !
    interface Serial0/0
    no ip address
    shutdown
    !
    interface BRI0/0
    no ip address
    encapsulation hdlc
    shutdown
    !
    interface Ethernet0/1
    no ip address
    shutdown
    half-duplex
    !
    interface Serial0/1
    no ip address
    shutdown
    !
    ip http server
    ip classless
    !
    !
    !
    line con 0
    line aux 0
    line vty 0 4
    !
    !
    end
    "


    Cross over cable is connected via Ethernet0/0 on both ruoters.

    Thanks

    Michael
    Michael Armstrong
    www.m80arm.co.uk
    MCITP: EA, MCTS, MCSE 2003, MCSA 2003: Messaging, CCA, VCP 3.5, 4, 5, VCAP5-DCD, VCAP5-DCA, ITIL, MCP, PGP Certified Technician

    ** Remember to give credit where credit is due and leave reputation points sigpic where appropriate **

  • #2
    Re: Line protocol down when connected via crossover

    Use a strait cable?

    post a "show int e0/0"

    Comment


    • #3
      Re: Line protocol down when connected via crossover

      Nope - I think router to router communication needs to be via a cross over cable. I tried a straight through cable and both interface line protocol's are down.

      Below info is when routers are connected via Crossover

      RouterA#show inter ethernet 0/0
      Ethernet0/0 is up, line protocol is up
      Hardware is AmdP2, address is 0002.fd8a.e3a0 (bia 0002.fd8a.e3a0)
      Internet address is 10.1.1.1/24
      MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
      reliability 255/255, txload 1/255, rxload 1/255
      Encapsulation ARPA, loopback not set
      Keepalive set (10 sec)
      ARP type: ARPA, ARP Timeout 04:00:00
      Last input 00:18:32, output 00:00:03, output hang never
      Last clearing of "show interface" counters never
      Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
      Queueing strategy: fifo
      Output queue: 0/40 (size/max)
      5 minute input rate 0 bits/sec, 0 packets/sec
      5 minute output rate 0 bits/sec, 0 packets/sec
      29 packets input, 4349 bytes, 0 no buffer
      Received 15 broadcasts, 0 runts, 0 giants, 0 throttles
      0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
      0 input packets with dribble condition detected
      344 packets output, 28918 bytes, 0 underruns
      170 output errors, 0 collisions, 2 interface resets
      0 babbles, 0 late collision, 0 deferred
      170 lost carrier, 0 no carrier
      0 output buffer failures, 0 output buffers swapped out

      RouterB#show interface ethernet 0/0

      Ethernet0/0 is up, line protocol is down
      Hardware is AmdP2, address is 0002.fd74.c9c0 (bia 0002.fd74.c9c0)
      Internet address is 10.1.1.2/24
      MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
      reliability 128/255, txload 1/255, rxload 1/255
      Encapsulation ARPA, loopback not set
      Keepalive set (10 sec)
      ARP type: ARPA, ARP Timeout 04:00:00
      Last input 00:19:01, output 00:00:05, output hang never
      Last clearing of "show interface" counters never
      Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
      Queueing strategy: fifo
      Output queue: 0/40 (size/max)
      5 minute input rate 0 bits/sec, 0 packets/sec
      5 minute output rate 0 bits/sec, 0 packets/sec
      25 packets input, 3548 bytes, 0 no buffer
      Received 10 broadcasts, 0 runts, 0 giants, 0 throttles
      0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
      0 input packets with dribble condition detected
      333 packets output, 23430 bytes, 0 underruns
      276 output errors, 0 collisions, 2 interface resets
      0 babbles, 0 late collision, 0 deferred
      276 lost carrier, 0 no carrier
      0 output buffer failures, 0 output buffers swapped out


      Michael
      Last edited by m80arm; 16th August 2009, 10:41.
      Michael Armstrong
      www.m80arm.co.uk
      MCITP: EA, MCTS, MCSE 2003, MCSA 2003: Messaging, CCA, VCP 3.5, 4, 5, VCAP5-DCD, VCAP5-DCA, ITIL, MCP, PGP Certified Technician

      ** Remember to give credit where credit is due and leave reputation points sigpic where appropriate **

      Comment


      • #4
        Re: Line protocol down when connected via crossover

        Yes a router-router connection via Ethernet should use a cross-over cable.

        Try setting the duplex to auto instead of forcing to full duplex operation. I have had this is the past and configuring auto-negotiate solved the problem.
        Infrastructure Architect
        CCNA, CCNA Security, MCSE, JNCIS

        Comment


        • #5
          Re: Line protocol down when connected via crossover

          For the heck of it try turning off keepalives on the ethernet interfaces of both routers and then try to ping one from the other and vice versa.

          Comment

          Working...
          X